This product requires an installed version of Sims 3.... [CLOSED]

View previous topic View next topic Go down

This product requires an installed version of Sims 3.... [CLOSED]

Post by nilahxo on Sat 09 Feb 2013, 05:08

I have the sims 3 and pets expansion pack downloaded through origin. I download the seasons expansion on here, and am trying to install it. I am using crossover to install it, but when I run it at first it was saying I have a corrupt version of Sims 3. I just tried to run it again and this product requires an installed version of Sims 3. I don't know how to do any of this on a mac, and it's so frustrating.

nilahxo
Beginner
Beginner

Posts : 1
Points : 1718
Reputation : 0
Join date : 2013-02-09

View user profile

Back to top Go down

Re: This product requires an installed version of Sims 3.... [CLOSED]

Post by bgk92 on Tue 12 Feb 2013, 06:30

I'm having the same problem with late night, does it ask for a localized version of sims 3 or something like that?

bgk92
Beginner
Beginner

Posts : 2
Points : 1716
Reputation : 0
Join date : 2013-02-12

View user profile

Back to top Go down

Re: This product requires an installed version of Sims 3.... [CLOSED]

Post by ladystardustsang on Sat 16 Feb 2013, 17:20

I'm having the same issue on PC and my sims 3 game is from steam. Is yours? I wonder if that has something to do with it?

ladystardustsang
Beginner
Beginner

Posts : 1
Points : 1711
Reputation : 0
Join date : 2013-02-16

View user profile

Back to top Go down

Re: This product requires an installed version of Sims 3.... [CLOSED]

Post by andrea212 on Sat 16 Feb 2013, 20:17

Try putting The Sims 3 app in the Desktop and installing the expansion there to see if you can.

andrea212
Posting Nerd
Posting Nerd

Posts : 61
Points : 1940
Reputation : 4
Join date : 2012-09-05

View user profile

Back to top Go down

Re: This product requires an installed version of Sims 3.... [CLOSED]

Post by Algester on Mon 18 Mar 2013, 17:30

I'm sorry I cant help you guys since your clearly having trouble where to post first if your using a VMware I suggest go to the windows section... not here, if guys want to play sims on the OSX then I suggest to follow the sticky http://games4theworld.bestgoo.com/t2755-easy-method-of-installing-sims-3-base-gameexpansions-mac-guide

You will need stuffit Expander to extract the .zip file of the expansion packs...
the manual updates the 1.2 GB single patch and the expansions updates

Algester
Beginner
Beginner

Posts : 14
Points : 1762
Reputation : 3
Join date : 2013-01-12

View user profile

Back to top Go down

Re: This product requires an installed version of Sims 3.... [CLOSED]

Post by TCPCohen on Tue 19 Mar 2013, 22:50

nilahxo wrote:I have the sims 3 and pets expansion pack downloaded through origin. I download the seasons expansion on here, and am trying to install it. I am using crossover to install it, but when I run it at first it was saying I have a corrupt version of Sims 3. I just tried to run it again and this product requires an installed version of Sims 3. I don't know how to do any of this on a mac, and it's so frustrating.

Hello!

Why are you using Crossover to install it? You don't need that.
You have to create a DMG with Disk Utility and put into that all the items you get after you unzip the RAR with Stuffit Expander. Do this with every expansion and let me know how it goes.


To the other people in this post: Create a new thread so everyone can read you and help you. Smile
avatar
TCPCohen
Posting Lord
Posting Lord

Favourite games : Sims 3
Male Posts : 202
Points : 2076
Reputation : 13
Join date : 2012-10-17
Age : 32
Location : Spain

View user profile

Back to top Go down

Re: This product requires an installed version of Sims 3.... [CLOSED]

Post by Helper on Wed 20 Mar 2013, 00:04

Firstly try uninstalling the sims 3 base game and installing it again if it dosent work tell me and i will think of a solution.

The Helper

_________________
The Helper
Here To Help
avatar
Helper
Beginner
Beginner

Windows version :
  • Windows 8

System architecture :
  • 64 bits (x64)

Favourite games : Flight Simulators, Sims 4
Posts : 10
Points : 1694
Reputation : 0
Join date : 2013-03-19
Age : 19
Location : London , UK

View user profile

Back to top Go down

Re: This product requires an installed version of Sims 3.... [CLOSED]

Post by JMEgaming on Mon 26 May 2014, 08:07

Algester wrote:I'm sorry I cant help you guys since your clearly having trouble where to post first if your using a VMware I suggest go to the windows section... not here, if guys want to play sims on the OSX then I suggest to follow the sticky http://games4theworld.bestgoo.com/t2755-easy-method-of-installing-sims-3-base-gameexpansions-mac-guide

You will need stuffit Expander to extract the .zip file of the expansion packs...
the manual updates the 1.2 GB single patch and the expansions updates
It says "only admins get to read this"

JMEgaming
Beginner
Beginner

Posts : 1
Points : 1247
Reputation : 0
Join date : 2014-05-26

View user profile

Back to top Go down

Re: This product requires an installed version of Sims 3.... [CLOSED]

Post by Phoebe on Thu 29 May 2014, 10:42

JMEgaming wrote:It says "only admins get to read this"

Hello,
Please open a new topic if you have a problem for us to help you. 

Topic is closed.

_________________
avatar
Phoebe
Super Spammer
Super Spammer

Windows version :
  • .

System architecture :
  • 64 bits (x64)

Favourite games : The Sims series, Elder Scrolls Skyrim, The Walking Dead, Sacred I-II, Fables,Vampire Masquerade Bloodlines, Civilization, Don't Starve, Popmundo
Female Posts : 783
Points : 2772
Reputation : 119
Join date : 2012-09-17
Age : 28
Location : Neverland

View user profile

Back to top Go down

View previous topic View next topic Back to top


Permissions in this forum:
You cannot reply to topics in this forum