Game stops at town loading screen aprox. 98% [SOLVED]

View previous topic View next topic Go down

Game stops at town loading screen aprox. 98% [SOLVED]

Post by thedibhuman on Mon 18 Feb 2013, 15:06

I have my own copy of sims 3 base game and downloaded all 17 expansions. I installed it following directions very carefully.

I load up the game, choose appaloossa plains, and it starts loading the town. it loads the bar up almost to the very end, then just sits there like that forever. Ive tried waiting, hitting windows button and clicking on it again, still stuck there. I really want to play my game.

I havent gotten any mods yet either.

Anyone know how to fix this? Thank you!

thedibhuman
Beginner
Beginner

Posts : 7
Points : 1720
Reputation : 0
Join date : 2013-02-18

View user profile

Back to top Go down

Re: Game stops at town loading screen aprox. 98% [SOLVED]

Post by Natalya on Mon 18 Feb 2013, 15:15

Have you tried this with other towns? Is it the same?

Also, are your setting set on high or low?

_________________
A huge WWE and Sims fan!

Please take my poll for favorite Sims 3 creature : http://games4theworld.bestgoo.com/t6795-poll-favorite-sim-type#47880
And the poll for favorite Sims 3 Expansion and Stuff pack : http://games4theworld.bestgoo.com/t6796-poll-favorite-expansion-stuff-pack
avatar
Natalya
Posting Lord
Posting Lord

Windows version :
  • Windows 7

System architecture :
  • 64 bits (x64)

Favourite games : Sims 3, WWE 12, WWE 13, Yu-Gi-Oh!, Harry Potter games
Female Posts : 256
Points : 2415
Reputation : 21
Join date : 2012-01-01
Age : 27
Location : Greece

View user profile

Back to top Go down

Re: Game stops at town loading screen aprox. 98% [SOLVED]

Post by thedibhuman on Mon 18 Feb 2013, 15:27

Thanks for the quick reply!

I just deleted the game cache files and tried loading up bridgeport instead, it seems to be stuck as well. The loading circle keeps spinning, the game tips keep scrolling, but the music stops and the bar seems to sit there loading only to the very last bit.

I'll try making my settings lower, then load up twinbrook, as that was the last town to work for me last time i had the game installed. It seems the least demanding of the towns.

//EDIT

Also, task manager says the game is running, and even with firefox running my cpu usage is a max of 38%.

//EDIT

Setting the graphics down made it load! Thank you so much! Ive been struggling with this since October!

Very Happy thank you so so much!

thedibhuman
Beginner
Beginner

Posts : 7
Points : 1720
Reputation : 0
Join date : 2013-02-18

View user profile

Back to top Go down

Re: Game stops at town loading screen aprox. 98% [SOLVED]

Post by Natalya on Mon 18 Feb 2013, 17:19

You're very welcome!!! I am glad I could help and enjoy your game now! Happy simming buddy! The Sims 3 plumbob

_________________
A huge WWE and Sims fan!

Please take my poll for favorite Sims 3 creature : http://games4theworld.bestgoo.com/t6795-poll-favorite-sim-type#47880
And the poll for favorite Sims 3 Expansion and Stuff pack : http://games4theworld.bestgoo.com/t6796-poll-favorite-expansion-stuff-pack
avatar
Natalya
Posting Lord
Posting Lord

Windows version :
  • Windows 7

System architecture :
  • 64 bits (x64)

Favourite games : Sims 3, WWE 12, WWE 13, Yu-Gi-Oh!, Harry Potter games
Female Posts : 256
Points : 2415
Reputation : 21
Join date : 2012-01-01
Age : 27
Location : Greece

View user profile

Back to top Go down

View previous topic View next topic Back to top


Permissions in this forum:
You cannot reply to topics in this forum