"Build Mode" really slow

View previous topic View next topic Go down

"Build Mode" really slow

Post by bokisis on Sat 20 Apr 2013, 19:07

I installed Sims 3 and all expansion and stuff pack properly (I have many CC's installed) . The game runs fine and everything works, expect in-game "Build Mode" . When I go into it, everything is so slow Sad... Rotating, moving (even moving objects, too).
When I rotate screen I must wait 10 seconds for it to be rotated (same problem with moving screen, too). "Live Mode" and "Buy" modes work fine! I have much CC installed.I don't believe "Build" is slow because CC, because "Buy" and "Live" modes work perfectly. And yes, house in which I build is CC (downloaded) from site.

HELP!

bokisis
Posting Nerd
Posting Nerd

Windows version :
  • Windows 8
  • Windows 7

System architecture :
  • 32 bits (x86)

Favourite games : Borderlands 2, CoD BOII, NFS MW 2012, CS 1.6, Sims 3, Dead Island DmC....
Male Posts : 38
Points : 1630
Reputation : 1
Join date : 2013-04-14

View user profile

Back to top Go down

Re: "Build Mode" really slow

Post by Aɾყα on Sat 20 Apr 2013, 20:22

Hello,

Still, it makes sense to test without CC. It doesn't necessarily have to do with how much CC you have.
To do this, drag your "Mods" folder out of Documents\Electronic Arts\The Sims 3, for example onto the desktop. If it turns out to work better that way, put your mods and cc back in small groups so you can test your game and find out which mod/cc is causing it.

_________________




"Under sun and sky, we greet you warmly"

avatar
Aɾყα
Forum Administratrix
First Lady of the Forum
Forum Administratrix First Lady of the Forum

Windows version :
  • Windows 8
  • Windows XP
  • Windows 10

System architecture :
  • 32 bits (x86)
  • 64 bits (x64)

Female Posts : 15105
Points : 20014
Reputation : 1430
Join date : 2011-05-31

View user profile

Back to top Go down

Re: "Build Mode" really slow

Post by TUN3R on Sun 21 Apr 2013, 02:12

Build mode IS slow on weak or over-worked PC's, or if you have many mods and expansions.

It works the same for me, it's not a bug it's just Black Box' poor development (or Maxis? I usually blame Black Box for screwing up but seeing as SimCity runs and feels a lot like The Sims 3 this could be Maxis' fault). Get rid of some mods, expansions or buy a new PC, those are the only solutions.

For me mods don't make a difference, they just make the game load slower. Keeping only 3 - 4 expansions installed makes the game run nearly perfectly, and only then is most of the Build Mode lag gone.

TUN3R
BANNED
BANNED

Windows version :
  • Windows 7

System architecture :
  • 64 bits (x64)

Favourite games : Grand Theft Auto: San Andreas
Male Posts : 646
Points : -7291
Reputation : -9982
Join date : 2012-02-19

View user profile

Back to top Go down

Re: "Build Mode" really slow

Post by bokisis on Sun 21 Apr 2013, 08:47

Thank you, both. Lady ElDi, in my "Mods" folder, in sub-folder "Packages" I have only two files

1.NoBuildSparkles
2.nointro

So I don't think "Mods" folder is causing my Build Mode runs slow.
Is the Custom Content same like "Store Content"? I was wrong, I don't have any CC (just few houses) , because my "Packages" folder have just 2 regular files, I have a lot "Store Content". Custom Content icon is a small purple star? And a "Store Content" icon is a small shopping bag? Yes, I have a lot "Store Content" not CC. Sorry. But, if I have few CC houses, where are they located (house I downloaded is .sims3pack file)? Is there anything I can do expect deleting some store content?

TUN3R, my PC is very strong, my Build mode worked before, without these content.

Is there anything I can do? (I will not touch Mods folder because there are just original files in it).

bokisis
Posting Nerd
Posting Nerd

Windows version :
  • Windows 8
  • Windows 7

System architecture :
  • 32 bits (x86)

Favourite games : Borderlands 2, CoD BOII, NFS MW 2012, CS 1.6, Sims 3, Dead Island DmC....
Male Posts : 38
Points : 1630
Reputation : 1
Join date : 2013-04-14

View user profile

Back to top Go down

Re: "Build Mode" really slow

Post by invalidusername on Sun 21 Apr 2013, 11:26

I would recommend trying the game without those cc houses, especially if you had downloaded them from the (original/official) exchange site. you should be able to find them by going through your installed content tab on the launcher. Just select those houses, and uninstall them.
avatar
invalidusername
=D Child of Admin =D
=D Child of Admin =D

Windows version :
  • Windows 8

System architecture :
  • 64 bits (x64)

Favourite games : The Sims, Assassin's Creed (All), Elder Scolls, Dragon Age : Origins, Harvest Moon, Mario, Zelda, Psychonauts, SimCity, House of the Dead : Overkill, Magic: The Gathering, Saint's Row, Civilization 5, The Witcher
Female Posts : 2043
Points : 4504
Reputation : 219
Join date : 2011-10-20
Age : 24
Location : Michigan

View user profile

Back to top Go down

View previous topic View next topic Back to top


Permissions in this forum:
You cannot reply to topics in this forum