Expansion Launch Issue

Page 1 of 2 1, 2  Next

View previous topic View next topic Go down

Expansion Launch Issue

Post by torq on Sun 19 May 2013, 17:20

I downloaded the base game (sims 3), works fine. I downloaded the university expansion and followed the correct steps. I put the two crack files in the base game (game>bin). I can launch the base game fine. When I launch the expansion, it runs but I get a black screen.


torq
Beginner
Beginner

Posts : 7
Points : 1623
Reputation : 0
Join date : 2013-05-19

View user profile

Back to top Go down

Re: Expansion Launch Issue

Post by zzshin on Sun 19 May 2013, 17:38

How you update your base game ?
avatar
zzshin
Posting Lord
Posting Lord

Windows version :
  • Windows 7

System architecture :
  • 32 bits (x86)
  • 64 bits (x64)

Favourite games : The Sims 3 / Hitman
Male Posts : 264
Points : 1951
Reputation : 14
Join date : 2013-05-13
Location : Malaysia

View user profile

Back to top Go down

Re: Expansion Launch Issue

Post by torq on Sun 19 May 2013, 17:40

Used the launch where you need disk, went to updates and there was a store patch so I downloaded that. That's all I did

torq
Beginner
Beginner

Posts : 7
Points : 1623
Reputation : 0
Join date : 2013-05-19

View user profile

Back to top Go down

Re: Expansion Launch Issue

Post by zzshin on Sun 19 May 2013, 17:51

And where you get your university expansion from ? i think there won't be a problem if the expansion are compatible
avatar
zzshin
Posting Lord
Posting Lord

Windows version :
  • Windows 7

System architecture :
  • 32 bits (x86)
  • 64 bits (x64)

Favourite games : The Sims 3 / Hitman
Male Posts : 264
Points : 1951
Reputation : 14
Join date : 2013-05-13
Location : Malaysia

View user profile

Back to top Go down

Re: Expansion Launch Issue

Post by torq on Sun 19 May 2013, 17:52

from here

torq
Beginner
Beginner

Posts : 7
Points : 1623
Reputation : 0
Join date : 2013-05-19

View user profile

Back to top Go down

Re: Expansion Launch Issue

Post by zzshin on Sun 19 May 2013, 17:56

avatar
zzshin
Posting Lord
Posting Lord

Windows version :
  • Windows 7

System architecture :
  • 32 bits (x86)
  • 64 bits (x64)

Favourite games : The Sims 3 / Hitman
Male Posts : 264
Points : 1951
Reputation : 14
Join date : 2013-05-13
Location : Malaysia

View user profile

Back to top Go down

Re: Expansion Launch Issue

Post by torq on Sun 19 May 2013, 17:59

Yea that works thats what I did to launch sims 3. BUT when I do that for the expansion, I get the black screen

torq
Beginner
Beginner

Posts : 7
Points : 1623
Reputation : 0
Join date : 2013-05-19

View user profile

Back to top Go down

Re: Expansion Launch Issue

Post by Adwomin on Mon 20 May 2013, 16:45

torq wrote:Yea that works thats what I did to launch sims 3. BUT when I do that for the expansion, I get the black screen
Hello, That doesn't make sense. Read this, please: http://games4theworld.org/sims3faq.html#always_get_in_same_game

_________________
Bonsoir, friend.


~ Nobody's gril. ~
avatar
Adwomin
free society
free society

Windows version :
  • Windows 8
  • Windows 7

System architecture :
  • 32 bits (x86)
  • 64 bits (x64)

Favourite games : GTA Series, Cities: Skylines, Prison Architect, Borderlands series
Female Posts : 19211
Points : 1026420
Reputation : 2253
Join date : 2010-03-12
Age : 16
Location : Del Perro Heights

View user profile https://www.games4theworld.org

Back to top Go down

Re: Expansion Launch Issue

Post by torq on Tue 21 May 2013, 21:56

followed steps, still get black screen.

torq
Beginner
Beginner

Posts : 7
Points : 1623
Reputation : 0
Join date : 2013-05-19

View user profile

Back to top Go down

Re: Expansion Launch Issue

Post by Shamrock on Tue 21 May 2013, 21:58

Ok, what I don't get is what do you mean by launching the base game or the expansion?
You should just open the launcher and launch the game from there. Any expansion you installed will be included...

_________________
Have some tea, and take care!
Best regards,

Shamrock  





Please PM or e-mail me for any help or advice!
avatar
Shamrock
=D Child of Admin =D
=D Child of Admin =D

Windows version :
  • Windows 8
  • Windows 7

System architecture :
  • 64 bits (x64)

Favourite games : The Sims 3 (series), Warcraft III, Civilization V, Vampire Bloodlines, Football Manager 2012, Pokemon games
Male Posts : 3265
Points : 5940
Reputation : 381
Join date : 2012-03-06
Location : On the slim border between sane and insane

View user profile

Back to top Go down

Re: Expansion Launch Issue

Post by Adwomin on Tue 21 May 2013, 21:59

torq wrote:followed steps, still get black screen.

Shamrock wrote:Ok, what I don't get is what do you mean by launching the base game or the expansion?
You should just open the launcher and launch the game from there. Any expansion you installed will be included...
Hello,

That's what I've been trying to explain with that link.
If you can launch the base game correctly, it means all your expansion packs are already working. If they're not lit up on the Game Launcher, then it means there's a problem.

_________________
Bonsoir, friend.


~ Nobody's gril. ~
avatar
Adwomin
free society
free society

Windows version :
  • Windows 8
  • Windows 7

System architecture :
  • 32 bits (x86)
  • 64 bits (x64)

Favourite games : GTA Series, Cities: Skylines, Prison Architect, Borderlands series
Female Posts : 19211
Points : 1026420
Reputation : 2253
Join date : 2010-03-12
Age : 16
Location : Del Perro Heights

View user profile https://www.games4theworld.org

Back to top Go down

Re: Expansion Launch Issue

Post by torq on Tue 21 May 2013, 23:33

It is lit up on the launcher. The way I launch game is through the game folder then the bin folder. I then click on the application. How else would I without the disk, since it says no disk?

torq
Beginner
Beginner

Posts : 7
Points : 1623
Reputation : 0
Join date : 2013-05-19

View user profile

Back to top Go down

Re: Expansion Launch Issue

Post by Adwomin on Tue 21 May 2013, 23:35

Hi there,

No disk? You didn't say anything about that.
Please follow these steps to fix that issue: http://games4theworld.bestgoo.com/t1171-must-read-how-to-install-the-sims-3-correctly
DO NOT skip any steps and RE-DOWNLOAD the manual patch and the Ultimate Fix. Good luck!

_________________
Bonsoir, friend.


~ Nobody's gril. ~
avatar
Adwomin
free society
free society

Windows version :
  • Windows 8
  • Windows 7

System architecture :
  • 32 bits (x86)
  • 64 bits (x64)

Favourite games : GTA Series, Cities: Skylines, Prison Architect, Borderlands series
Female Posts : 19211
Points : 1026420
Reputation : 2253
Join date : 2010-03-12
Age : 16
Location : Del Perro Heights

View user profile https://www.games4theworld.org

Back to top Go down

Re: Expansion Launch Issue

Post by torq on Tue 21 May 2013, 23:36

Admin wrote:Hi there,

No disk? You didn't say anything about that.
Please follow these steps to fix that issue: http://games4theworld.bestgoo.com/t1171-must-read-how-to-install-the-sims-3-correctly
DO NOT skip any steps and RE-DOWNLOAD the manual patch and the Ultimate Fix. Good luck!

Yea, I did all that..

//EDIT

Drag & drop the .exe and .dll file in there to exactly: C:\Program Files (x86)\Electronic Arts\The Sims 3\Game\Bin

I just have everything in a folder on my desktop, could that be why?

torq
Beginner
Beginner

Posts : 7
Points : 1623
Reputation : 0
Join date : 2013-05-19

View user profile

Back to top Go down

Re: Expansion Launch Issue

Post by Shamrock on Wed 22 May 2013, 09:35

What is this "everything" in your desktop folder?
You must have installed your game, and installation files are in C:\Program Files (x86)\Electronic Arts\The Sims 3\Game\Bin regardless of wether you have shortcuts on your desktop. This is where you need to drag & drop the files from the Crack folder of the Ultimate Fix!
Then you can launch the game through your desktop shortcuts, it doesn't matter!

_________________
Have some tea, and take care!
Best regards,

Shamrock  





Please PM or e-mail me for any help or advice!
avatar
Shamrock
=D Child of Admin =D
=D Child of Admin =D

Windows version :
  • Windows 8
  • Windows 7

System architecture :
  • 64 bits (x64)

Favourite games : The Sims 3 (series), Warcraft III, Civilization V, Vampire Bloodlines, Football Manager 2012, Pokemon games
Male Posts : 3265
Points : 5940
Reputation : 381
Join date : 2012-03-06
Location : On the slim border between sane and insane

View user profile

Back to top Go down

Re: Expansion Launch Issue

Post by CrazyyFox on Thu 23 May 2013, 17:07

I might have the same problem, I've followed all the steps as well, although all my sims 3 ( The normal and Seasons expansion) are installed on the Data (D:) . The base game works just fine, when I start up the game from the launcher its starts but there's no expansion, just the base game. When I start up TS3W, from the Bin, it shows a black screen and this error message : Unable to start game , Service initialization failed (0x024e424f)

I'm assuming its the same error as torq's.

CrazyyFox
Beginner
Beginner

Windows version :
  • Windows 8

System architecture :
  • 64 bits (x64)

Favourite games : Sims series, Pokemon, Harvest moon, MMo's
Female Posts : 5
Points : 1615
Reputation : 0
Join date : 2013-05-23
Age : 22
Location : Canada

View user profile

Back to top Go down

Re: Expansion Launch Issue

Post by zzshin on Thu 23 May 2013, 17:39

Try the step that we talked about in this forum and see it can work or not.
avatar
zzshin
Posting Lord
Posting Lord

Windows version :
  • Windows 7

System architecture :
  • 32 bits (x86)
  • 64 bits (x64)

Favourite games : The Sims 3 / Hitman
Male Posts : 264
Points : 1951
Reputation : 14
Join date : 2013-05-13
Location : Malaysia

View user profile

Back to top Go down

Re: Expansion Launch Issue

Post by Shamrock on Thu 23 May 2013, 18:52

CrazyyFox wrote:I might have the same problem, I've followed all the steps as well, although all my sims 3 ( The normal and Seasons expansion) are installed on the Data (D:) . The base game works just fine, when I start up the game from the launcher its starts but there's no expansion, just the base game. When I start up TS3W, from the Bin, it shows a black screen and this error message : Unable to start game , Service initialization failed (0x024e424f)

Is D: an external drive?
Also, did you follow everything above?

_________________
Have some tea, and take care!
Best regards,

Shamrock  





Please PM or e-mail me for any help or advice!
avatar
Shamrock
=D Child of Admin =D
=D Child of Admin =D

Windows version :
  • Windows 8
  • Windows 7

System architecture :
  • 64 bits (x64)

Favourite games : The Sims 3 (series), Warcraft III, Civilization V, Vampire Bloodlines, Football Manager 2012, Pokemon games
Male Posts : 3265
Points : 5940
Reputation : 381
Join date : 2012-03-06
Location : On the slim border between sane and insane

View user profile

Back to top Go down

Re: Expansion Launch Issue

Post by CrazyyFox on Thu 23 May 2013, 21:08

Shamrock wrote:
CrazyyFox wrote:I might have the same problem, I've followed all the steps as well, although all my sims 3 ( The normal and Seasons expansion) are installed on the Data (D:) . The base game works just fine, when I start up the game from the launcher its starts but there's no expansion, just the base game. When I start up TS3W, from the Bin, it shows a black screen and this error message : Unable to start game , Service initialization failed (0x024e424f)

Is D: an external drive?
Also, did you follow everything above?

I've followed all the steps in : http://games4theworld.bestgoo.com/t1171-must-read-how-to-install-the-sims-3-correctly . All it did was mess up my launcher, or Origin. But the game itself still works, if I use the TS3 shortcut in the Bin.

The (D:) .. Uhh. Well it was built-in my computer, Kinda like a second (C:)? I'm not too good with this. I just install my games on the (D:) because the other ones full.

CrazyyFox
Beginner
Beginner

Windows version :
  • Windows 8

System architecture :
  • 64 bits (x64)

Favourite games : Sims series, Pokemon, Harvest moon, MMo's
Female Posts : 5
Points : 1615
Reputation : 0
Join date : 2013-05-23
Age : 22
Location : Canada

View user profile

Back to top Go down

Re: Expansion Launch Issue

Post by Shamrock on Thu 23 May 2013, 21:15

Ok, then D: isn't your problem.
So you had the base game, and installed expansions, right?
Do you have mods in your game?

_________________
Have some tea, and take care!
Best regards,

Shamrock  





Please PM or e-mail me for any help or advice!
avatar
Shamrock
=D Child of Admin =D
=D Child of Admin =D

Windows version :
  • Windows 8
  • Windows 7

System architecture :
  • 64 bits (x64)

Favourite games : The Sims 3 (series), Warcraft III, Civilization V, Vampire Bloodlines, Football Manager 2012, Pokemon games
Male Posts : 3265
Points : 5940
Reputation : 381
Join date : 2012-03-06
Location : On the slim border between sane and insane

View user profile

Back to top Go down

Re: Expansion Launch Issue

Post by CrazyyFox on Thu 23 May 2013, 21:17

Shamrock wrote:Ok, then D: isn't your problem.
So you had the base game, and installed expansions, right?
Do you have mods in your game?

I installed Seasons, as the intructions told me to. I used a CD-key that was given by the Instructions in Seasons, when I downloaded it.

I don't have any mods.

CrazyyFox
Beginner
Beginner

Windows version :
  • Windows 8

System architecture :
  • 64 bits (x64)

Favourite games : Sims series, Pokemon, Harvest moon, MMo's
Female Posts : 5
Points : 1615
Reputation : 0
Join date : 2013-05-23
Age : 22
Location : Canada

View user profile

Back to top Go down

Re: Expansion Launch Issue

Post by Shamrock on Thu 23 May 2013, 21:22

Ok then you've done something wrong: the game and the expansions are one and the same. When you open the Launcher, the expansion must appear in the bottom left corner, and when you launch the game, all the expansions start. Those are not separate games...
What happens when you try to launch from the Launcher?

_________________
Have some tea, and take care!
Best regards,

Shamrock  





Please PM or e-mail me for any help or advice!
avatar
Shamrock
=D Child of Admin =D
=D Child of Admin =D

Windows version :
  • Windows 8
  • Windows 7

System architecture :
  • 64 bits (x64)

Favourite games : The Sims 3 (series), Warcraft III, Civilization V, Vampire Bloodlines, Football Manager 2012, Pokemon games
Male Posts : 3265
Points : 5940
Reputation : 381
Join date : 2012-03-06
Location : On the slim border between sane and insane

View user profile

Back to top Go down

Re: Expansion Launch Issue

Post by CrazyyFox on Thu 23 May 2013, 21:28

Shamrock wrote:Ok then you've done something wrong: the game and the expansions are one and the same. When you open the Launcher, the expansion must appear in the bottom left corner, and when you launch the game, all the expansions start. Those are not separate games...
What happens when you try to launch from the Launcher?

A pop-up shows up. "Sims3 Launcher has stopped working." And the launcher never shows up. It worked fine until I followed the "How to install Sims 3 correctly" intructions, also, I'm not sure the base game was downloaded from this website, I've had it for a while.

CrazyyFox
Beginner
Beginner

Windows version :
  • Windows 8

System architecture :
  • 64 bits (x64)

Favourite games : Sims series, Pokemon, Harvest moon, MMo's
Female Posts : 5
Points : 1615
Reputation : 0
Join date : 2013-05-23
Age : 22
Location : Canada

View user profile

Back to top Go down

Re: Expansion Launch Issue

Post by Shamrock on Thu 23 May 2013, 21:30

Ok, here's what I would suggest:
Save your content: move the folder My Documents\Electronic Arts\The Sims 3 to your desktop.
Then uninstall all your games.
Re install your games from G4TW using the instructions.
Put back your folder when you're done...

_________________
Have some tea, and take care!
Best regards,

Shamrock  





Please PM or e-mail me for any help or advice!
avatar
Shamrock
=D Child of Admin =D
=D Child of Admin =D

Windows version :
  • Windows 8
  • Windows 7

System architecture :
  • 64 bits (x64)

Favourite games : The Sims 3 (series), Warcraft III, Civilization V, Vampire Bloodlines, Football Manager 2012, Pokemon games
Male Posts : 3265
Points : 5940
Reputation : 381
Join date : 2012-03-06
Location : On the slim border between sane and insane

View user profile

Back to top Go down

Re: Expansion Launch Issue

Post by CrazyyFox on Thu 23 May 2013, 21:36

Alright, I'll try, tell you about it when Im done.

CrazyyFox
Beginner
Beginner

Windows version :
  • Windows 8

System architecture :
  • 64 bits (x64)

Favourite games : Sims series, Pokemon, Harvest moon, MMo's
Female Posts : 5
Points : 1615
Reputation : 0
Join date : 2013-05-23
Age : 22
Location : Canada

View user profile

Back to top Go down

Page 1 of 2 1, 2  Next

View previous topic View next topic Back to top


Permissions in this forum:
You cannot reply to topics in this forum