Sims 3 - Service Initialization failed (some numbers)

View previous topic View next topic Go down

Sims 3 - Service Initialization failed (some numbers)

Post by nuuken on Mon 20 May 2013, 20:36

I'm running OSX Mountain Lion. I have been searching for a answer but seems like no one is having the same problem as me. I've tried many things, but nothing have helped me.

So I have some complications running my Sims 3 downloaded from tpb (Sims 3 base game + some expansions). I have tried different downloads from tpb as well, and every time I have used g4tw's guide on how to install sims 3 correctly, applied the ultimate fix, the manual patch and so on. I'm pretty sure I have done what I should and everything so I'm pretty tired of trying to make Sims 3 work on my mac now.

Okay, so here's what happens: Every single time I have downloaded and installed (and re-downloaded and re-installed) the game, it worked perfectly the first and second time. So when I open the game, the launcher (idk if that's what it's called, but the blue window thingy) and I click play. The big blue window with the green sims sign appear, The Sims 3 plumbob, like normal, and then the screen blinks and turns blue and then black. Then I get the message "Unable to start game ' Service initialization failed (0x024e424f)", the screen switches between blue and black a couple of times, and a new message appears "Exception raised
Unhandled exception 0x80000003 at address 0x0058b006.
Do you wish to debug it ?". When I proceed to click yes or no, nothing happens.

I have tried things like changing the Sims 3 folder's name, deleting ipatch files and some other which I can't remember, re-downloading, re-installing, downloading other Sims 3 from tpb etc.

Anyone have any idea on what do to? In that case, please explain very simply.

(I'm so sorry if this is in the wrong forum and my poor english!)

Thank you!

//MOVED
Shamrock

nuuken
Beginner
Beginner

Female Posts : 1
Points : 1556
Reputation : 0
Join date : 2013-05-20
Age : 20

View user profile

Back to top Go down

Re: Sims 3 - Service Initialization failed (some numbers)

Post by Shamrock on Mon 20 May 2013, 20:52

The guide is different for Mac. Please try these links:

_________________
Have some tea, and take care!
Best regards,

Shamrock  





Please PM or e-mail me for any help or advice!
avatar
Shamrock
Forum Moderator
Taking care of the Forum
Forum Moderator Taking care of the Forum

Windows version :
  • Windows 8
  • Windows 7

System architecture :
  • 64 bits (x64)

Favourite games : The Sims 3 (series), Warcraft III, Civilization V, Vampire Bloodlines, Football Manager 2012, Pokemon games
Male Posts : 3265
Points : 5880
Reputation : 381
Join date : 2012-03-06
Location : On the slim border between sane and insane

View user profile

Back to top Go down

Re: Sims 3 - Service Initialization failed (some numbers)

Post by missmarshmellow108 on Fri 14 Jun 2013, 00:02

I'm actually having the exact same problem... (along with eps not showing up in launcher). I have a 2.5 GHz Intel Core i5 Lion (10.7.5) and I have no idea what I should do. I'm not sure where this post was moved to and I'm really confused being new to this site...
I have all expansions and its cracked with the Ultimate Fix.
Please help.

missmarshmellow108
Beginner
Beginner

Posts : 14
Points : 1702
Reputation : 1
Join date : 2013-01-06

View user profile

Back to top Go down

Re: Sims 3 - Service Initialization failed (some numbers)

Post by Phoebe on Fri 14 Jun 2013, 09:45

@missmarshmellow108 wrote:I'm actually having the exact same problem... (along with eps not showing up in launcher). I have a 2.5 GHz Intel Core i5 Lion (10.7.5) and I have no idea what I should do. I'm not sure where this post was moved to and I'm really confused being new to this site...
I have all expansions and its cracked with the Ultimate Fix.
Please help.

Hello,

Please open a new thread for your problem, with this way I'd be easier to help you. And these problems are about not applying the fix correctly...

_________________
avatar
Phoebe
Forum Moderatrix
Taking care of the Forum
Forum Moderatrix Taking care of the Forum

Windows version :
  • .

System architecture :
  • 64 bits (x64)

Favourite games : The Sims series, Elder Scrolls Skyrim, The Walking Dead, Sacred I-II, Fables,Vampire Masquerade Bloodlines, Civilization, Don't Starve, Popmundo
Female Posts : 783
Points : 2708
Reputation : 119
Join date : 2012-09-17
Age : 28
Location : Neverland

View user profile

Back to top Go down

Re: Sims 3 - Service Initialization failed (some numbers)

Post by cccantstop on Sat 22 Jun 2013, 22:23

@nuuken wrote:window with the green sims sign appear, , like normal, and then the screen blinks and turns blue and then black. Then I get the message "Unable to start game ' Service initialization failed (0x024e424f)", the screen switches between blue and black a couple of times, and a new message appears "Exception raised
Unhandled exception 0x80000003 at address 0x0058b006.
Do you wish to debug it ?". When I proceed to click yes or no, nothing happens.

I have the exact same issue

cccantstop
Beginner
Beginner

System architecture :
  • 64 bits (x64)

Posts : 3
Points : 1523
Reputation : 0
Join date : 2013-06-22

View user profile

Back to top Go down

Re: Sims 3 - Service Initialization failed (some numbers)

Post by Phoebe on Sun 23 Jun 2013, 10:47

@cccantstop wrote:I have the exact same issue

Have you tried those steps which Shamrock suggested?:
@Shamrock wrote:The guide is different for Mac. Please try these links:


_________________
avatar
Phoebe
Forum Moderatrix
Taking care of the Forum
Forum Moderatrix Taking care of the Forum

Windows version :
  • .

System architecture :
  • 64 bits (x64)

Favourite games : The Sims series, Elder Scrolls Skyrim, The Walking Dead, Sacred I-II, Fables,Vampire Masquerade Bloodlines, Civilization, Don't Starve, Popmundo
Female Posts : 783
Points : 2708
Reputation : 119
Join date : 2012-09-17
Age : 28
Location : Neverland

View user profile

Back to top Go down

Re: Sims 3 - Service Initialization failed (some numbers)

Post by Grubby on Mon 29 Jul 2013, 06:12

The guide isn't very clear - I spent a few hours yesterday trying to install on Mountain Lion OSX - I now have the same issue with the service init error... I've been stalking the boards here - when I get home I guess I could try changing the documents folder to .old or re-patching then applying ultimate fix.... 

You could update the guide to say when you use the MAC_cracked torrent - instead of dragging the .app to the applications folder you should make sure it's actually in a The Sims 3 folder within the application folder.... 

found that updating from the launcher didn't work so I d/l the superpatch 1.3 gigs... unzipped and was a document file which didn't launch with anything... then by trial and error unzipped again to reveal the executable patch update.... 

world adventures DMG needed to change the default.ini file's game version

also Shamrocks video link isn't viewable - not sure if there's any treasure to be found in there but I can't view.

Grubby
Beginner
Beginner

Posts : 1
Points : 1484
Reputation : 0
Join date : 2013-07-29

View user profile

Back to top Go down

Re: Sims 3 - Service Initialization failed (some numbers)

Post by Shamrock on Mon 29 Jul 2013, 10:52

Sorry, Admin must have changed the location of the video...

_________________
Have some tea, and take care!
Best regards,

Shamrock  





Please PM or e-mail me for any help or advice!
avatar
Shamrock
Forum Moderator
Taking care of the Forum
Forum Moderator Taking care of the Forum

Windows version :
  • Windows 8
  • Windows 7

System architecture :
  • 64 bits (x64)

Favourite games : The Sims 3 (series), Warcraft III, Civilization V, Vampire Bloodlines, Football Manager 2012, Pokemon games
Male Posts : 3265
Points : 5880
Reputation : 381
Join date : 2012-03-06
Location : On the slim border between sane and insane

View user profile

Back to top Go down

Re: Sims 3 - Service Initialization failed (some numbers)

Post by Adwomin on Mon 29 Jul 2013, 22:36

@Shamrock wrote:Sorry, Admin must have changed the location of the video...
Hello,

Ah yes, we've removed all the old "Fixes" to clean things up, it was very messy and confusing.
Anyway, the video is still available on Youtube. I just don't have the link either, I'm afraid. Sad

_________________
Bonsoir, friend.


~ Nobody's gril. ~
avatar
Adwomin
free society
free society

Windows version :
  • Windows 8
  • Windows 7

System architecture :
  • 32 bits (x86)
  • 64 bits (x64)

Favourite games : GTA Series, Cities: Skylines, Prison Architect, Borderlands series
Female Posts : 19211
Points : 1026349
Reputation : 2242
Join date : 2010-03-12
Age : 15
Location : Del Perro Heights

View user profile https://www.games4theworld.org

Back to top Go down

View previous topic View next topic Back to top


Permissions in this forum:
You cannot reply to topics in this forum