The Sims 3 unable to start through launcher and TS3W

View previous topic View next topic Go down

The Sims 3 unable to start through launcher and TS3W

Post by SirHeraldo on Sat 25 May 2013, 02:08

As the title would suggest, I am having issues running the game. Similar to a few other threads, I get "There was an error during startup. Please see the Log for more details" when attempting to start from the launcher and "Unable to start game - Service initialization failed (0x0175dcbb)."

I have the following expansions:
Ambitions, Generations, Late Night, Seasons, Supernatural, University Life, and World Adventures.

I have attempted to reinstall the game through "Add or Remove Programs," though I have not deleted anything else. I was able to run the game with BlackBox and its unofficial updates with AwesomeMod, unofficial patches, and a large sum of twallan's mods.

I can provide system specifications, the exact order/steps in which I have downloaded/installed the game, and other various things that I have done previous to the installation of the game upon request.

Sorry for the lack of information in the post- I'm in a bit of a hurry!

Cheers!
-SirHeraldo

SirHeraldo
Beginner
Beginner

Posts : 4
Points : 1586
Reputation : 0
Join date : 2013-05-25

View user profile

Back to top Go down

Re: The Sims 3 unable to start through launcher and TS3W

Post by The_gh0stm4n on Sat 25 May 2013, 02:31

SirHeraldo wrote:As the title would suggest, I am having issues running the game. Similar to a few other threads, I get "There was an error during startup. Please see the Log for more details" when attempting to start from the launcher and "Unable to start game - Service initialization failed (0x0175dcbb)."

I have the following expansions:
Ambitions, Generations, Late Night, Seasons, Supernatural, University Life, and World Adventures.

I have attempted to reinstall the game through "Add or Remove Programs," though I have not deleted anything else. I was able to run the game with BlackBox and its unofficial updates with AwesomeMod, unofficial patches, and a large sum of twallan's mods.

I can provide system specifications, the exact order/steps in which I have downloaded/installed the game, and other various things that I have done previous to the installation of the game upon request.

Sorry for the lack of information in the post- I'm in a bit of a hurry!

Cheers!
-SirHeraldo

Hello there,

First of all we do not recommend using/installing these "Sims 3 collections" like the "Blackbox" or others. Please download and install the base game and the expansions all separately.

Now try re-applying the "Ultimate fix". If this doesn't help, please refer to this article here
for proper uninstallation: http://simswiki.info/wiki.php?title=Game_Help:TS3_Uninstall
I recommend deleting the registry keys manually.

It is NOT important, in which order you install expansions. Please (re-) read this here: http://games4theworld.bestgoo.com/t1171-must-read-how-to-install-the-sims-3-correctly



_________________
Respectfully,

The_gh0stm4n
G4TW Forum Gatekeeper



avatar
The_gh0stm4n
VETERAN Moderator
Inspector General & Forum O.G.
VETERAN Moderator Inspector General & Forum O.G.

Windows version :
  • Windows 8
  • Windows 7
  • Windows XP
  • Windows 10

System architecture :
  • 32 bits (x86)
  • 64 bits (x64)

Favourite games : The Sims 3, L.A. Noire, Saints Row, Red Faction, Minecraft, Plants vs. Zombies: Garden Warfare, Titanfall, Team Fortress 2, Darkest Hour, GTA V, GTA: San Andreas, S.W.A.T. 4, Counter-Strike, Hitman, Borderlands, Fallout, Dishonored, Call of Duty, Battlefield, The Binding of Isaac: Afterbirth†, Enter the Gungeon.
Male Posts : 14302
Points : 18981
Reputation : 2020
Join date : 2012-11-02
Location : The Situation Room

View user profile

Back to top Go down

Re: The Sims 3 unable to start through launcher and TS3W

Post by SirHeraldo on Sat 25 May 2013, 02:47

I did not use any BlackBox content in the installation that gave me errors. I only used Games4theWorld files and installers.

I will delete the registry keys again - If I recall correctly, I removed them before I started to use the Games4theWorld files.

I should have followed the steps there- I suppose I'll re-install the game to make sure.

Though this might be unrelated- after I uninstalled BlackBox and its unofficial updates, a nasty mess of "missing" game stuff was left in the "Add or Remove Programs" menu and I was unable to delete it, though I am able to remove anything that I install now.

I'll attempt to install the files one-by-one and report if there are any issues arising and with what expansions.

Cheers!
-SirHeraldo

//EDIT

Well, I could get The Sims 3 to work without the fix- I just used the
regular crack for the base game. When I tested it with both University
and World Adventures, I get the following error:

[Instruction data]
004e1ed6 => DasmX86Dll.dll not found.

That's probably what's causing the error.


I
managed to find a copy of it online (yes yes, I know it's dangerous)
and ploinked it into my SysWOW64 and System32 folders. A reboot later
and no luck.

I've searched my computer for the .dll but I can't
seem to find it (other than in the SysWOW64 folder). A few googles and
it turns out that both Spore and Sims 3 players have been missing it.

What further action should I take? Do I just give up?

Cheers!
-SirHeraldo

SirHeraldo
Beginner
Beginner

Posts : 4
Points : 1586
Reputation : 0
Join date : 2013-05-25

View user profile

Back to top Go down

Re: The Sims 3 unable to start through launcher and TS3W

Post by Shamrock on Sat 25 May 2013, 11:43

Ok, looks like the uninstall of your Blackbox left traces, which probably conflicts with your new install.
Please uninstall all your games again, then hold the Windows Key (bottom left of the keyboard, with the Windows sign on it) and the R key. Type regedit. If it asks for permissions say yes.
Navigate to HKEY_LOCAL_MACHINE/SOFTWARE/Wow6432Node, and Delete everything related to the Sims 3 (usually in the Sims folder, but with the Blackbox I'm not sure...).
Then restart your computer and re install everything following the instructions!
Hope it works!!

_________________
Have some tea, and take care!
Best regards,

Shamrock  





Please PM or e-mail me for any help or advice!
avatar
Shamrock
=D Child of Admin =D
=D Child of Admin =D

Windows version :
  • Windows 8
  • Windows 7

System architecture :
  • 64 bits (x64)

Favourite games : The Sims 3 (series), Warcraft III, Civilization V, Vampire Bloodlines, Football Manager 2012, Pokemon games
Male Posts : 3265
Points : 5913
Reputation : 381
Join date : 2012-03-06
Location : On the slim border between sane and insane

View user profile

Back to top Go down

Re: The Sims 3 unable to start through launcher and TS3W

Post by SirHeraldo on Sat 25 May 2013, 12:09

I've already deleted all of the cache files. Did I forget to mention that?

I followed all of the steps, but when I updated my game it started returning an error. I could, however, use the regular Sims 3 game without the update. How mysterious.

For further clarification, I downloaded the update from the specified link in the "How to install" thread. I also found that it would stop working with the University game update, which is the same as the patch specified in the "How to Install" thread at the moment I've written this post.

If the whole matter becomes too much of a hassle, I'll probably try my luck with another distribution.

SirHeraldo
Beginner
Beginner

Posts : 4
Points : 1586
Reputation : 0
Join date : 2013-05-25

View user profile

Back to top Go down

Re: The Sims 3 unable to start through launcher and TS3W

Post by Aɾყα on Mon 27 May 2013, 09:22

Hello,

Don't worry about it, we'll get to the bottom of this.
The error you're getting with WA and UL, does it occur during installation? Or when you start the game?
Which error are you getting from the manual patch?

_________________




"Under sun and sky, we greet you warmly"

avatar
Aɾყα
Forum Administratrix
First Lady of the Forum
Forum Administratrix First Lady of the Forum

Windows version :
  • Windows 8
  • Windows XP
  • Windows 10

System architecture :
  • 32 bits (x86)
  • 64 bits (x64)

Female Posts : 15110
Points : 20055
Reputation : 1435
Join date : 2011-05-31

View user profile

Back to top Go down

Re: The Sims 3 unable to start through launcher and TS3W

Post by SirHeraldo on Mon 27 May 2013, 17:41

Welp, I already uninstalled the G4TW version and tried another that ended up working flawlessly. Ergo, I won't be able to test anymore, but I can certainly give you what information I still have. Sorry to disappoint you!

First off- System specs. I have the following components that may be a source of the fault:

Intel Core i7 x64
8GB of RAM
Nvidia GeForce 560 Ti

In my most recent (and for the most part working) game, I have everything except for Showtime and Pets.

In my G4TW installation, I had errors in both the startup of the launcher and attempting to launch the game through TS3W. The error occurred when I had University Life installed- I could boot up TS3 without a problem. I later tried it with WA but unfortunately I was confused and didn't remember to open it with the TS3W found in WA. The game still started normally, I just didn't have any of the WA content.

Looking back on the matter, I probably should have tried to start the game with a different patch such as the one that came with 70s, 80s, 90s stuff.

I forgot the error code (did I mention it above?), but when I googled it I found that people had the error with both The Sims 3 and Spore. I also looked at the error log generated by the launcher and it said that it was missing a .dll.

So that narrows it down for the most part- Either the most recent patch, University Life, or an improper installation service could be what's causing the problem. It also may be the vague install instructions- Do we install every EP like the "how to install" manual describes or do we just run the setup.exe(s) for every EP or SP? Are there a few steps implied by the install guide that I'm missing?

Once again- sorry for deleting my game content. 3 days was a little too much of a wait for me. Nevertheless, thanks for paying attention to the thread and attempting to help. Smile

Cheers!
-SirHeraldo

SirHeraldo
Beginner
Beginner

Posts : 4
Points : 1586
Reputation : 0
Join date : 2013-05-25

View user profile

Back to top Go down

View previous topic View next topic Back to top


Permissions in this forum:
You cannot reply to topics in this forum