Can't update to 1.50 - iPatch needs to change permissions for these files : Thesims3.app

View previous topic View next topic Go down

Can't update to 1.50 - iPatch needs to change permissions for these files : Thesims3.app

Post by jozzrr on Tue 04 Jun 2013, 03:04

Hi everyone,

My name is Jocelyn and I'm encountering some problems installing The Sims 3 in my macbook pro. I am following everything exactly to the letter as specified on the new Sims 3 mac guide (i'm even using the programs recommended to extract and all that).

The problem begins when I get to step number 6. I click on the "update now" button and let it download. As soon as its close to finishing the update, I receive this message:

"Patch needs to change permissions for these files :
Thesims3.app" Options are cancel or change.

Cancel - cancels the whole update, and change - changes permissions and attempts to patch the game but results in an "Unknown error occured" . Then it closes. After this error, when i try to open the Sims 3, it gives me the "Unknown error occured" message again and it closes. At this point, It no longer lets me access the game launcher and need to reinstall. I have done this 3 times with the same results.

Therefore, it will not let me update to 1.50 from 1.2

Any ideas how to deal/fix this problem? Any help is appreciated Very Happy



Last edited by jozzrr on Wed 05 Jun 2013, 02:57; edited 1 time in total (Reason for editing : additional information)

jozzrr
Beginner
Beginner

Posts : 2
Points : 1654
Reputation : 0
Join date : 2013-06-04

View user profile

Back to top Go down

Re: Can't update to 1.50 - iPatch needs to change permissions for these files : Thesims3.app

Post by Shamrock on Tue 04 Jun 2013, 09:59

Don't worry, upper than 1.50 isn't out yet... Wink
I don't know if that exists on Mac, but try to run it as Admin?
You need to change the permissions to access the files otherwise... Do you know how to do it?

_________________
Have some tea, and take care!
Best regards,

Shamrock  





Please PM or e-mail me for any help or advice!
avatar
Shamrock
=D Child of Admin =D
=D Child of Admin =D

Windows version :
  • Windows 8
  • Windows 7

System architecture :
  • 64 bits (x64)

Favourite games : The Sims 3 (series), Warcraft III, Civilization V, Vampire Bloodlines, Football Manager 2012, Pokemon games
Male Posts : 3265
Points : 5994
Reputation : 381
Join date : 2012-03-06
Location : On the slim border between sane and insane

View user profile

Back to top Go down

Re: Can't update to 1.50 - iPatch needs to change permissions for these files : Thesims3.app

Post by jozzrr on Tue 04 Jun 2013, 19:37

I did try to change the permission manually but I already have reading and writing permissions on all files so I didnt really have to change anything. I still can't update and I have to idea why. I actually went on to install the expansion packs without updating but a bunch are not compatible with the version I have. I get this message :



So I'm just wondering if there is anyway around installing the update, or if there is another way I can update to 1.50 so that I can install all other packs.

Also, I noticed the info box in the torrent I downloaded says not to update, yet the mac guide says to update, so I'm confused as to what to do to get the base game and all expansions to work

Edit*******

I actually found a manual patch that is applied for this particular problem which is step 11 in the ultimate fix, so I'm going to install that and see if it lets me install the other packs, fingers crossed


Last edited by jozzrr on Wed 05 Jun 2013, 03:30; edited 3 times in total (Reason for editing : additional information)

jozzrr
Beginner
Beginner

Posts : 2
Points : 1654
Reputation : 0
Join date : 2013-06-04

View user profile

Back to top Go down

Re: Can't update to 1.50 - iPatch needs to change permissions for these files : Thesims3.app

Post by Sponsored content


Sponsored content


Back to top Go down

View previous topic View next topic Back to top


Permissions in this forum:
You cannot reply to topics in this forum