Lots of Lag! (specifically World Adventures)

View previous topic View next topic Go down

Lots of Lag! (specifically World Adventures)

Post by Yearin on Sat 22 Jun 2013, 01:28

Hello!

I manged to play the game for a couple days without any major problems (a tiny bit of lag here and there and some moments when the sound wouldn't work but it was always fixed if I re-booted the game) but the real issues started when I decided to take my sims on their first trip. My sims are now stuck sleeping in China because it just takes a crazy long time for anything to happen.


The problem:
The game freezes for over a minute every second or so. Music, my mouse pointer, and background stuff (like the trees swaying) still continue fine but any actions (e.g. anything I click) or movements from my sims stops. Sim world time stops too (which is why my sims are stuck sleeping right now T_T). This never happened before during regular town gameplay.

My Computer:
I have most of the expansions packs installed (e.g. late night, WA, master suite stuff, pets, ambitions, etc.) but I don't have any mods (only the things (e.g. ultimate fix or manual patch) downloaded from this site)
I'm running on Windows 7 with the following specs:

  • Processor: Intel(R) Core(TM) i5 CPU       M 480  @ 2.67GHz (4 CPUs), ~2.7GHz
  • Memory: 4096MB RAM
  • Available OS Memory: 3764MB RAM
  • Video Card: AMD Radeon HD 6550M


What I've Done Already:
I googled the issue and tried a bunch of things. I downloaded Gamebooster, I've defraged my computer, cleaned all the junk, sweeped malware, and added an FPS limiter. All of these things did nothing, if anything it might have made it worse because I now have small sound glitching issues although only during the startup/loading screen.


Please let me know if there's anything I can do to fix this issue! I'm so frustrated!


<3 Yearin

Yearin
Beginner
Beginner

Windows version :
  • Windows 7

Favourite games : Oblivion, Dragon Age, Sims
Posts : 8
Points : 1669
Reputation : 0
Join date : 2013-05-28

View user profile

Back to top Go down

Re: Lots of Lag! (specifically World Adventures)

Post by The_gh0stm4n on Sat 22 Jun 2013, 03:05

@Yearin wrote:Hello!

I manged to play the game for a couple days without any major problems (a tiny bit of lag here and there and some moments when the sound wouldn't work but it was always fixed if I re-booted the game) but the real issues started when I decided to take my sims on their first trip. My sims are now stuck sleeping in China because it just takes a crazy long time for anything to happen.


The problem:
The game freezes for over a minute every second or so. Music, my mouse pointer, and background stuff (like the trees swaying) still continue fine but any actions (e.g. anything I click) or movements from my sims stops. Sim world time stops too (which is why my sims are stuck sleeping right now T_T). This never happened before during regular town gameplay.

My Computer:
I have most of the expansions packs installed (e.g. late night, WA, master suite stuff, pets, ambitions, etc.) but I don't have any mods (only the things (e.g. ultimate fix or manual patch) downloaded from this site)
I'm running on Windows 7 with the following specs:

  • Processor: Intel(R) Core(TM) i5 CPU       M 480  @ 2.67GHz (4 CPUs), ~2.7GHz
  • Memory: 4096MB RAM
  • Available OS Memory: 3764MB RAM
  • Video Card: AMD Radeon HD 6550M


What I've Done Already:
I googled the issue and tried a bunch of things. I downloaded Gamebooster, I've defraged my computer, cleaned all the junk, sweeped malware, and added an FPS limiter. All of these things did nothing, if anything it might have made it worse because I now have small sound glitching issues although only during the startup/loading screen.


Please let me know if there's anything I can do to fix this issue! I'm so frustrated!


<3 Yearin

Hello,

Have you already tried any of the suggestions posted here ? http://games4theworld.bestgoo.com/t857-the-sims-3-crashes-freezes-to-desktop-fix-updated-on-29-09-2012

Besides that, you could try is to go to My documents/Electronic Arts/The Sims 3 and then delete the "unnecessary" cache:


-CASPartCache.package
-compositorCache.package
-scriptCache.package
-simCompositorCache.package
-socialCache.package
-plus the contents of the folders "WorldCaches" & "Thumbnails"


Start the game then and see if this changed anything. Have you installed the latest 1.55 patch ? I haven't yet tried the 1.55 patch (for a good reason !), but I have similar issues when travelling to China, France and Egypt (I'm on patch-level 1.50). What you could try is to google for the following mods: NRAAS Overwatch, NRAAS ErrorTrap and NRAAS Traveler (these are three separate mods). Maybe they can help out with the travelling issues.


But if you are on the patch 1.55 you probably have to wait for a while - I'm not sure if these mods have been updated for the new patch already.

If you are willing to experiment, then try the following too: go to My Documents/Electronic Arts and rename the folder "The Sims 3" in any way you like (for example: "The Sims 3_backup"). This will basically disable all your savefiles and any installed mods/CC.

Now when you start the game you'll see that all your saves are gone (for now; don't worry, they are still in the renamed folder). Start a completely fresh savegame and then travel.

However, it looks to me like this travelling issue is not related to mods/CC or corrupted savefiles. This might be just a "bug" which can only be corrected by a patch (or some mods).



I suggest, still, that you first delete the cache and only if this doesn't work you can consider renaming the folder "The Sims 3".

_________________



G4TW Forum rules // G4TW Forum FAQ // G4TW Downloads // G4TW on ThePiratebay

How to install The Sims Medieval // The Sims 2 overview ! // How to install The Sims 3 // Expansion install checklist for TS3 // How to install The Sims 4



Feel free to e-mail me for general questions about G4TW & site navigation problems. Also, when after 24 hours of you posting a topic on the Forum you have not received a reply and still need help, you can send me an e-mail message as well!



avatar
The_gh0stm4n
VETERAN Moderator
Inspector General & Forum O.G.
VETERAN Moderator Inspector General & Forum O.G.

Windows version :
  • Windows 8
  • Windows 7
  • Windows XP
  • Windows 10

System architecture :
  • 32 bits (x86)
  • 64 bits (x64)

Favourite games : The Sims 3, L.A. Noire, Saints Row, Red Faction, Minecraft, Plants vs. Zombies: Garden Warfare, Titanfall, Team Fortress 2, Darkest Hour, GTA V, GTA: San Andreas, S.W.A.T. 4, Counter-Strike, Hitman, Borderlands, Fallout, Dishonored, Call of Duty, Battlefield, The Binding of Isaac: Afterbirth†, Enter the Gungeon.
Male Posts : 14830
Points : 19689
Reputation : 2094
Join date : 2012-11-02
Location : The Situation Room

View user profile

Back to top Go down

Re: Lots of Lag! (specifically World Adventures)

Post by Yearin on Mon 24 Jun 2013, 03:20

Hi again!

Thanks for the help and thanks for the link! I hadn't seen that topic because (stupid me) I was searching only for "lag" and didn't think of searching for "freezes".


I tried moving all the exe. files to the DEP and deleted all the "unnecessary" cache and stuff; that helped a lot at first (I couldn't find the World cache folder though). I ran the game for a couple minutes without any major freezes. After an hour or so it started freezing again (it's still semi-playable but it's annoying). I didn't try some of the other things because I really don't think it's a computer graphics issue since I'm already playing on low and I tried other things related to graphics that didn't help.

I haven't tried the 1.55 patch yet so I guess I'll wait until the other mods update before I update my game and then I'll try those mods that you suggested.
I'll let you know how it goes but if you had any other suggestions please let me know Smile

Thanks again!


Yearin <3

Yearin
Beginner
Beginner

Windows version :
  • Windows 7

Favourite games : Oblivion, Dragon Age, Sims
Posts : 8
Points : 1669
Reputation : 0
Join date : 2013-05-28

View user profile

Back to top Go down

Re: Lots of Lag! (specifically World Adventures)

Post by Shamrock on Mon 24 Jun 2013, 10:53

Did you try Game booster?

_________________
Have some tea, and take care!
Best regards,

Shamrock  





Please PM or e-mail me for any help or advice!
avatar
Shamrock
=D Child of Admin =D
=D Child of Admin =D

Windows version :
  • Windows 8
  • Windows 7

System architecture :
  • 64 bits (x64)

Favourite games : The Sims 3 (series), Warcraft III, Civilization V, Vampire Bloodlines, Football Manager 2012, Pokemon games
Male Posts : 3265
Points : 5994
Reputation : 381
Join date : 2012-03-06
Location : On the slim border between sane and insane

View user profile

Back to top Go down

Re: Lots of Lag! (specifically World Adventures)

Post by Sponsored content


Sponsored content


Back to top Go down

View previous topic View next topic Back to top


Permissions in this forum:
You cannot reply to topics in this forum