I give up. Help PLEASE!

View previous topic View next topic Go down

I give up. Help PLEASE!

Post by atila on Fri 28 Jun 2013, 21:53

As I said in other thread, I wanted to reinstall the expansions which weren't working (although they have been installed. Technically, they were 'working', only the stuff was invisible or appeared as little black balls), so I uninstalled everything completely and started the process again. I have .dmg files from 1 year ago when I installed everything. 

Today I followed the new .pdf guide and installed everything as stated. When I started the game launcher, I noticed that almost half of the expansions weren't there (on the bottom of the launcher when you can see which ones are installed). Also, the game wasn't working. At first I got the service initialization failed message and then black screen and then debug message.

Then I browsed this forum and found yet another installation guide, provided with the crack (ultimate fix). I mean, what the hell??? One guide says crack only the base game, one says crack everything separately. Which procedure is right???? 
So I tried cracking everything again separately and the game still doesn't work.

I am desperate. What should I do? Should I make new .dmg files? Maybe mine are corrupted and because of that some expansions didn't work. But making new .dmg files is a long and painful proces and combined with the complicated installation it's just near to impossible if you don't have a day or two off. Why doesn't anyone upload .dmg files? I mean, with so many mac users, it's not rational that every single one of us makes everything alone.
avatar
atila
Beginner
Beginner

Posts : 11
Points : 1871
Reputation : 0
Join date : 2012-07-20

View user profile

Back to top Go down

Re: I give up. Help PLEASE!

Post by atila on Fri 28 Jun 2013, 21:54

Also, can anyone tell me how to get a clean uninstall, as to wipe everything sims-related off computer? 
I think the sims uninstaller doesn't do that.
avatar
atila
Beginner
Beginner

Posts : 11
Points : 1871
Reputation : 0
Join date : 2012-07-20

View user profile

Back to top Go down

Re: I give up. Help PLEASE!

Post by Jassie on Sat 29 Jun 2013, 09:48

I am no expert at anything, but I had kinda similar problem with launcher a while back. Every expansion was installed but launcher did not show them at all. I realized that they had magically been installed into a subfolder! I installed all Sims directly to Applications, but some expansions were in Applications/Sims 3, have no idea why. But this fixed when I just kept installing them over and over again. Some expansions went to the right place the second installation, some needed three. And I swear, I didn't even make the Sims 3 folder where they got installed and I had absolutely nothing to do with that. 

See if you find anything useful here: http://games4theworld.bestgoo.com/t11885-only-seeing-7-expansions-at-the-launcher-though-all-are-correctly-installed-solved

(My solves can be found somewhere in the middle of the conversation before the speaker problem)

Jassie
Beginner
Beginner

Posts : 13
Points : 1561
Reputation : 0
Join date : 2013-05-28

View user profile

Back to top Go down

Re: I give up. Help PLEASE!

Post by atila on Wed 03 Jul 2013, 12:27

Excatly the same happened to me! Some were automatically installed into Sims 3 subfolder, which was also automatically made.
So you just reinstalled everything multiple times?
avatar
atila
Beginner
Beginner

Posts : 11
Points : 1871
Reputation : 0
Join date : 2012-07-20

View user profile

Back to top Go down

View previous topic View next topic Back to top


Permissions in this forum:
You cannot reply to topics in this forum