Weird lag and freeze issues

View previous topic View next topic Go down

Weird lag and freeze issues

Post by KittyKarnage on Tue 16 Jul 2013, 06:55

I just bought a brand new computer, here are the specs
Processor: AMD A10-Series 
RAM: 6gb 
HD Size: 750gb 
Graphics: AMD Radeon HD 8610G 
Operating System: Windows 8


and The Sims is almost unplayable due to the lag, even though I have it on the lowest settings possible. I have all the expansion packs installed and were all installed from Games4theWorld. This lag is constant from the day I started playing, when I go in build mode there is no lag though. 

I need help on figuring out what my problem could be. Thank you in advanced!

KittyKarnage
Beginner
Beginner

Posts : 1
Points : 1560
Reputation : 0
Join date : 2013-07-16

View user profile

Back to top Go down

Re: Weird lag and freeze issues

Post by cezra31 on Tue 16 Jul 2013, 07:31

Hello,

Try this LadyEldi suggested in this link.
Specially try the GameBooster, it will help a lot.

_________________
Regards,
cezra31









Loop
Start playing when buffered ( Only Notify

) -
%
Smart Buffer
Estimated Time:
Donate to SmartVideo!
Global Preferences
avatar
cezra31
Posting Master
Posting Master

Windows version :
  • Windows 8
  • Windows 7

System architecture :
  • 32 bits (x86)
  • 64 bits (x64)

Favourite games : The Sims 3, Left 4 Dead, NBA 2k, Warcraft III, Need For Speed, League of Legends
Male Posts : 500
Points : 2712
Reputation : 55
Join date : 2012-03-25
Age : 19
Location : I'm right here beside you.

View user profile

Back to top Go down

View previous topic View next topic Back to top


Permissions in this forum:
You cannot reply to topics in this forum