Sims 3 wont open but launcher works fine?

View previous topic View next topic Go down

Sims 3 wont open but launcher works fine?

Post by vannakins on Thu 10 Oct 2013, 16:29

Howdy,

my Sims 3 base game worked well before I installed the Supernatural expansion pack. Now that I have the Supernatural expansion, the launcher pops up and it seems as though everything it working fine until I press the play button. I wait. Five minutes pass... ten minutes... fifteen minutes... Nothing pops up. There is no Sims 3 running in the system tray. It's as if I just closed it instead of pressing play.

About a week ago, I had the Sims 3 base game along with Pets and Supernatural. Everything was working fine until I tried to install a corrupted Seasons expansion. I decided not to fool with any of that for too long, and ended up just starting back up completely from scratch - even torrenting the .rars from this site again (I left Seasons and Pets out this time.)

Any solutions?

ps - i also have custom content, but they're supposedly working fine since my friend has the exact same stuff that I have. And I don't have any mods. I run Windows Vista.

vannakins
Beginner
Beginner

Posts : 1
Points : 1469
Reputation : 0
Join date : 2013-10-10

View user profile

Back to top Go down

Re: Sims 3 wont open but launcher works fine?

Post by The_gh0stm4n on Sat 12 Oct 2013, 01:04

vannakins wrote:Howdy,

my Sims 3 base game worked well before I installed the Supernatural expansion pack. Now that I have the Supernatural expansion, the launcher pops up and it seems as though everything it working fine until I press the play button. I wait. Five minutes pass... ten minutes... fifteen minutes... Nothing pops up. There is no Sims 3 running in the system tray. It's as if I just closed it instead of pressing play.

About a week ago, I had the Sims 3 base game along with Pets and Supernatural. Everything was working fine until I tried to install a corrupted Seasons expansion. I decided not to fool with any of that for too long, and ended up just starting back up completely from scratch - even torrenting the .rars from this site again (I left Seasons and Pets out this time.)

Any solutions?

ps - i also have custom content, but they're supposedly working fine since my friend has the exact same stuff that I have. And I don't have any mods. I run Windows Vista.

Hello,

Can you try to re-do the steps from 2 to 4 here ? http://games4theworld.bestgoo.com/t1171-must-read-how-to-install-the-sims-3-correctly

That means: re-apply the "manual patch" (step #2) and the the Ultimate fix (step #4). Then double-click on the TS3W.exe in the base game location C:\Program files(x86)\Electronic Arts\The Sims 3\Game\Bin. Choose "copy and replace" for both files. You can also make a shortcut to the desktop from the TS3W.exe.

Good luck !

_________________
Respectfully,

The_gh0stm4n
G4TW Forum Gatekeeper



avatar
The_gh0stm4n
VETERAN Moderator
Inspector General & Forum O.G.
VETERAN Moderator Inspector General & Forum O.G.

Windows version :
  • Windows 8
  • Windows 7
  • Windows XP
  • Windows 10

System architecture :
  • 32 bits (x86)
  • 64 bits (x64)

Favourite games : The Sims 3, L.A. Noire, Saints Row, Red Faction, Minecraft, Plants vs. Zombies: Garden Warfare, Titanfall, Team Fortress 2, Darkest Hour, GTA V, GTA: San Andreas, S.W.A.T. 4, Counter-Strike, Hitman, Borderlands, Fallout, Dishonored, Call of Duty, Battlefield, The Binding of Isaac: Afterbirth†, Enter the Gungeon.
Male Posts : 14419
Points : 19139
Reputation : 2036
Join date : 2012-11-02
Location : The Situation Room

View user profile

Back to top Go down

View previous topic View next topic Back to top


Permissions in this forum:
You cannot reply to topics in this forum