Locating earlier manual patches?

View previous topic View next topic Go down

Locating earlier manual patches?

Post by Ragin on Wed 23 Oct 2013, 09:09

My launcher always says I have the latest update, so I've always been using manual patches. Well I am at 1.55 and can't find a link to 1.57 that isn't an EA link, could anyone help me out?

Those "http://akamai.cdn.ea.com" links give me a "Problem loading page; Unable to connect" page(They've never worked for me). I'm currently downloading the manual patch 1.63 via MEGA, but I need 1.57 to be installed first, isn't that right?
avatar
Ragin
Beginner
Beginner

Windows version :
  • Windows 7

System architecture :
  • 64 bits (x64)

Favourite games : Strategy, RPG, Survival, Simulation
Male Posts : 14
Points : 1672
Reputation : 0
Join date : 2013-04-14

View user profile

Back to top Go down

Re: Locating earlier manual patches?

Post by J.T. on Wed 23 Oct 2013, 10:25

You don‘t need to update to 1.57 first. The manual patch is a super patcher intended to allow users to update at any patch levels.

_________________

"Part of growing up is doing what's best for the people you care about, even if sometimes, that means hurting someone else."

avatar
J.T.
=D Child of Admin =D
=D Child of Admin =D

Windows version :
  • Windows 7

System architecture :
  • 32 bits (x86)

Male Posts : 3442
Points : 5875
Reputation : 306
Join date : 2013-01-29
Age : 21
Location : Panem

View user profile

Back to top Go down

Re: Locating earlier manual patches?

Post by Ragin on Wed 23 Oct 2013, 15:41

cat2006house wrote:You don‘t need to update to 1.57 first. The manual patch is a super patcher intended to allow users to update at any patch levels.
That's great to know, thanks a lot! I'll remember this from now on.
avatar
Ragin
Beginner
Beginner

Windows version :
  • Windows 7

System architecture :
  • 64 bits (x64)

Favourite games : Strategy, RPG, Survival, Simulation
Male Posts : 14
Points : 1672
Reputation : 0
Join date : 2013-04-14

View user profile

Back to top Go down

Re: Locating earlier manual patches?

Post by J.T. on Wed 23 Oct 2013, 15:45

Ragin wrote:
cat2006house wrote:You don‘t need to update to 1.57 first. The manual patch is a super patcher intended to allow users to update at any patch levels.
That's great to know, thanks a lot! I'll remember this from now on.
Anything else we can help you with?

_________________

"Part of growing up is doing what's best for the people you care about, even if sometimes, that means hurting someone else."

avatar
J.T.
=D Child of Admin =D
=D Child of Admin =D

Windows version :
  • Windows 7

System architecture :
  • 32 bits (x86)

Male Posts : 3442
Points : 5875
Reputation : 306
Join date : 2013-01-29
Age : 21
Location : Panem

View user profile

Back to top Go down

View previous topic View next topic Back to top


Permissions in this forum:
You cannot reply to topics in this forum