"This update requires that a previous version of the Sims 3 is installed", HELP?

View previous topic View next topic Go down

"This update requires that a previous version of the Sims 3 is installed", HELP?

Post by justneedhelp on Tue 05 Nov 2013, 17:57

I tried to update my Sims 3 when trying to get the Into the Future extension, I used the ultimate fix and even the manual patch 1.63, but get the same message every time: 
"Setup has detected that no version of the Sims 3 is installed.
This update requires that a previous version of the application is installed." (ca, it's translated)
I have the all in one edition and all I want is to get Into the future to work. Please help!

justneedhelp
Beginner
Beginner

Posts : 5
Points : 1505
Reputation : 0
Join date : 2013-11-05

View user profile

Back to top Go down

Re: "This update requires that a previous version of the Sims 3 is installed", HELP?

Post by Sephymuffins on Tue 05 Nov 2013, 19:52

Hello,

I know there are a few other moderators that are on here that know more details on what I'm about to say, but unfortunately, the All in One edition of your Sims 3 game is NOT compatible with one, two or all of these things:  The other pirated expansion packs, the Ultimate Fix and the Manual Patch.  The error your game is throwing out is in direct correlation with incompatibility issues I just mentioned!  : (

Unfortunately, I am going to have to advise you to go through the process of downloading each expansion pack (and base game if necessary), separately.  You can do so, from here:  http://thepiratebay.sx/user/games4theworld/0/7.

The download speeds are great and normally if you choose to download them all in one go with your torrent application, it won't take much longer than at least one day - as long as you have a good, strong internet signal (and your ISP is good).  Smile

I'm sorry to be the bearer of bad news!  Let us know if you need any further help or if you have any questions.  For further assistance in regards to the Manual Patch and the Ultimate fix, please click the links in my signature.  Good luck!
avatar
Sephymuffins
Posting Master
Posting Master

Windows version :
  • Windows 8
  • Windows 7

System architecture :
  • 32 bits (x86)
  • 64 bits (x64)

Favourite games : The Sims™, Final Fantasy, F.E.A.R, Resident Evil, Silent Hill, Minecraft, DayZ, Infestation: Survivor Stories, 7 Days To Die, Metal Gear Rising, The Walking Dead, Fable 3, Bioshock, Skyrim, Fallout, Spore.
Female Posts : 582
Points : 2473
Reputation : 80
Join date : 2013-03-07
Age : 27
Location : East Coast.

View user profile http://www.games4theworlddownloads.org/

Back to top Go down

Re: "This update requires that a previous version of the Sims 3 is installed", HELP?

Post by J.T. on Wed 06 Nov 2013, 12:44

Please download Your Uninstaller Pro from the link Sephy's mentioned and uninstall the AIO version with the Uninstaller Super Mode. Restart your computer afterwards, and download and install any torrents you want from the link.

However, it is advised to have a look at this: http://games4theworld.bestgoo.com/t1171-must-read-how-to-install-the-sims-3-correctly

_________________

"Part of growing up is doing what's best for the people you care about, even if sometimes, that means hurting someone else."

avatar
J.T.
=D Child of Admin =D
=D Child of Admin =D

Windows version :
  • Windows 7

System architecture :
  • 32 bits (x86)

Male Posts : 3442
Points : 5926
Reputation : 306
Join date : 2013-01-29
Age : 21
Location : Panem

View user profile

Back to top Go down

Re: "This update requires that a previous version of the Sims 3 is installed", HELP?

Post by justneedhelp on Wed 06 Nov 2013, 17:48

This was some sad news Sad I downloaded your uninstaller pro, but it can't find the Sims 3 aio edition, what to do?

justneedhelp
Beginner
Beginner

Posts : 5
Points : 1505
Reputation : 0
Join date : 2013-11-05

View user profile

Back to top Go down

Re: "This update requires that a previous version of the Sims 3 is installed", HELP?

Post by justneedhelp on Wed 06 Nov 2013, 18:50

Aaand when I'm installing the Sims 3 base game all over again, I get to the final step; "9. When the Installation is completed, open the '# Crack' file in this .rar and Copy + Paste the 'TS3.exe' to 'Game Directory > Game > Bin' and REPLACE it by the existing one." I can't paste it because it says the disk is full, and nothing can be deleted of course. Any suggestions? Appreciate the help Very Happy

justneedhelp
Beginner
Beginner

Posts : 5
Points : 1505
Reputation : 0
Join date : 2013-11-05

View user profile

Back to top Go down

Re: "This update requires that a previous version of the Sims 3 is installed", HELP?

Post by Sephymuffins on Wed 06 Nov 2013, 20:00

Hello,

Have you been able to find the AIO yet, or are you installing The Sims 3 over it in the hopes of just starting new?  If you CANNOT find the game, or at least an uninstaller .exe, go into the folder you have of the game in your Program Files.  Once there, look in the AIO's /game/bin folder until you see a lot of executable (.exe) files.  There SHOULD be an "UNINSTALL" .exe somewhere in there.  Sometimes you download games through torrents, every now and again you have to manually uninstall - some games, your computer won't pick up on, neither will UninstallPro.  It's rare but it happens! 

I can show you an example:
http://i40.tinypic.com/91fjpj.png

It's not The Sims 3 game, however if you look closely, the file says "UNins000".  It's abbreviated a bit, however I'd run that file to uninstall that game from my PC.  See if you can find a file such as that.  If you can, great.  If not, try the steps found here: http://www.ehow.com/how_6817346_remove-program-won_t-uninstall.html.

In regards to your latest post:  The only steps you want to follow are the steps that consist of JUST FIVE.  It seems you are following the "Installation Guide" file within the .rar of your basegame.  You do NOT want to follow these steps, nor use the #Crack INSIDE the .rar of the game!  (Example:  http://i42.tinypic.com/kantz4.png)  You only want to open the "Installation Guide" for the serial number it will provide you - just disregard the rest.  If you are following the steps that cat2006house linked you to, the first step is to successfully install the basegame and any/all expansions you want.  Then you move on to step 2, etc.  If you need help beyond just the steps, I made a video in my signature to assist anyone not understand the steps 100%.  Smile
avatar
Sephymuffins
Posting Master
Posting Master

Windows version :
  • Windows 8
  • Windows 7

System architecture :
  • 32 bits (x86)
  • 64 bits (x64)

Favourite games : The Sims™, Final Fantasy, F.E.A.R, Resident Evil, Silent Hill, Minecraft, DayZ, Infestation: Survivor Stories, 7 Days To Die, Metal Gear Rising, The Walking Dead, Fable 3, Bioshock, Skyrim, Fallout, Spore.
Female Posts : 582
Points : 2473
Reputation : 80
Join date : 2013-03-07
Age : 27
Location : East Coast.

View user profile http://www.games4theworlddownloads.org/

Back to top Go down

Re: "This update requires that a previous version of the Sims 3 is installed", HELP?

Post by justneedhelp on Wed 06 Nov 2013, 21:01

Yeah thanks, finally managed to uninstall manually Smile 

Does that mean I shouldn't mount the game either? (Cause I don't see any other way) I tried this without using the crack, just mounting, and when I got to the welcome page at the launcher it said: "You're playing an unfinished, unauthorized version of The Sims 3" and when I click play they demanded registration code again, but none worked, it just kept popping up after I clicked done. What to do now? Sad Can I install the Sims 3 base game without mounting?

justneedhelp
Beginner
Beginner

Posts : 5
Points : 1505
Reputation : 0
Join date : 2013-11-05

View user profile

Back to top Go down

Re: "This update requires that a previous version of the Sims 3 is installed", HELP?

Post by Sephymuffins on Wed 06 Nov 2013, 21:09

Hello,

I'm not sure I follow.  You don't always need to mount a game like a virtual drive, so long as the contents of the .rar is extracted somewhere (preferably your desktop).  All I ever need to do is run the setup.exe and use one of the serial numbers from the "Installation Instructions" file.  Once you install the games, you don't want to necessarily try and run them until AFTER you've applied the Manual Patch and then the Ultimate Fix.  You may get a "insert disk 1" error without applying these two things to your game, not to mention many other errors.  Mind you, if you're following the steps we've been talking about, you need to ensure you have at least one expansion pack compatible with the Ultimate Fix.
avatar
Sephymuffins
Posting Master
Posting Master

Windows version :
  • Windows 8
  • Windows 7

System architecture :
  • 32 bits (x86)
  • 64 bits (x64)

Favourite games : The Sims™, Final Fantasy, F.E.A.R, Resident Evil, Silent Hill, Minecraft, DayZ, Infestation: Survivor Stories, 7 Days To Die, Metal Gear Rising, The Walking Dead, Fable 3, Bioshock, Skyrim, Fallout, Spore.
Female Posts : 582
Points : 2473
Reputation : 80
Join date : 2013-03-07
Age : 27
Location : East Coast.

View user profile http://www.games4theworlddownloads.org/

Back to top Go down

Re: "This update requires that a previous version of the Sims 3 is installed", HELP?

Post by justneedhelp on Wed 06 Nov 2013, 21:23

Okay thank you, sorry for being a noob!
But I thought that you had to mount the ISO-files? I don't see setup.exe no where in the Sims 3 files I downloaded from the link. :s

"The Sims 3 [FULL] * Games4theworld *
Included:

- Installation Guide
- The Sims 3 StartDisk.ISO
- The Sims 3 Disk 1.ISO
- Crack"



justneedhelp
Beginner
Beginner

Posts : 5
Points : 1505
Reputation : 0
Join date : 2013-11-05

View user profile

Back to top Go down

Re: "This update requires that a previous version of the Sims 3 is installed", HELP?

Post by Sponsored content


Sponsored content


Back to top Go down

View previous topic View next topic Back to top


Permissions in this forum:
You cannot reply to topics in this forum