Problems in the future - bot building machine

View previous topic View next topic Go down

Problems in the future - bot building machine

Post by Minaki on Sun 24 Nov 2013, 11:03

I can somewhat use the bot building machine. I can use it to research nanites and trait chips and even to build Plumbots. The problem is when I discover a new type of nanite, the machine says "Nanite $0" for all of them. I also can't build trait chips because my sim gliches and gets teleported away from the machine.

I saw someone else was having the same problem and was advised installing the store fixes so I tried that. The problem is, for me, just installing the fixes didn't solve the problem so I was wondering if anyone else found another solution I could try.

Minaki
Posting Nerd
Posting Nerd

Windows version :
  • Windows 7

System architecture :
  • 64 bits (x64)

Female Posts : 21
Points : 2144
Reputation : 0
Join date : 2011-11-04
Age : 26
Location : Portugal

View user profile

Back to top Go down

Re: Problems in the future - bot building machine

Post by The_gh0stm4n on Sun 24 Nov 2013, 12:06

@Minaki wrote:I can somewhat use the bot building machine. I can use it to research nanites and trait chips and even to build Plumbots. The problem is when I discover a new type of nanite, the machine says "Nanite $0" for all of them. I also can't build trait chips because my sim gliches and gets teleported away from the machine.

I saw someone else was having the same problem and was advised installing the store fixes so I tried that. The problem is, for me, just installing the fixes didn't solve the problem so I was wondering if anyone else found another solution I could try.
Hello,

Try selling that machine in "buy-mode", then buy a new machine.


avatar
The_gh0stm4n
VETERAN Moderator
Inspector General & Forum O.G.
VETERAN Moderator Inspector General & Forum O.G.

Windows version :
  • Windows 8
  • Windows 7
  • Windows XP
  • Windows 10

System architecture :
  • 32 bits (x86)
  • 64 bits (x64)

Favourite games : The Sims 3, L.A. Noire, Saints Row, Red Faction, Minecraft, Plants vs. Zombies: Garden Warfare, Titanfall, Team Fortress 2, Darkest Hour, GTA: San Andreas, S.W.A.T. 4, Counter-Strike, Hitman, Borderlands, Fallout, Dishonored, Call of Duty, Battlefield, The Binding of Isaac: Afterbirth†
Male Posts : 14062
Points : 18656
Reputation : 1981
Join date : 2012-11-02
Age : 30
Location : San Fierro

View user profile

Back to top Go down

Re: Problems in the future - bot building machine

Post by Minaki on Sun 24 Nov 2013, 12:16

Carlos G. wrote:Hello,

Try selling that machine in "buy-mode", then buy a new machine.
Ahead of you actually :p
Already did and it didn't solve the problem. Now I'm trying to start a new game to see if the other save was corrupted. This will take a while, but I'll keep you posted.

Minaki
Posting Nerd
Posting Nerd

Windows version :
  • Windows 7

System architecture :
  • 64 bits (x64)

Female Posts : 21
Points : 2144
Reputation : 0
Join date : 2011-11-04
Age : 26
Location : Portugal

View user profile

Back to top Go down

Re: Problems in the future - bot building machine

Post by The_gh0stm4n on Sun 24 Nov 2013, 12:23

@Minaki wrote:Ahead of you actually :p
Already did and it didn't solve the problem. Now I'm trying to start a new game to see if the other save was corrupted. This will take a while, but I'll keep you posted.
You tried ALL suggestions in the topic you posted ? Like removing all of the old store fixes, and then deleting the scriptCache.package file too (in My Documents/Electronic Arts) ?

I'm afraid you then have to wait for a second opinion on this. Wat.

avatar
The_gh0stm4n
VETERAN Moderator
Inspector General & Forum O.G.
VETERAN Moderator Inspector General & Forum O.G.

Windows version :
  • Windows 8
  • Windows 7
  • Windows XP
  • Windows 10

System architecture :
  • 32 bits (x86)
  • 64 bits (x64)

Favourite games : The Sims 3, L.A. Noire, Saints Row, Red Faction, Minecraft, Plants vs. Zombies: Garden Warfare, Titanfall, Team Fortress 2, Darkest Hour, GTA: San Andreas, S.W.A.T. 4, Counter-Strike, Hitman, Borderlands, Fallout, Dishonored, Call of Duty, Battlefield, The Binding of Isaac: Afterbirth†
Male Posts : 14062
Points : 18656
Reputation : 1981
Join date : 2012-11-02
Age : 30
Location : San Fierro

View user profile

Back to top Go down

Re: Problems in the future - bot building machine

Post by Minaki on Sun 24 Nov 2013, 12:30

Carlos G. wrote:You tried ALL suggestions in the topic you posted ? Like removing all of the old store fixes, and then deleting the scriptCache.package file too (in My Documents/Electronic Arts) ?

I'm afraid you then have to wait for a second opinion on this. Wat.
Yeah, I had fixes but they were from downs-sims3 so I deleted those first before following the instructions to install the new fixes (I have store items on both .sims3packs and .packages formats, so I followed the instructions for both as said on the .txt document). As for deleting the scriptCache.package I didn't have to do so manually 'cause I run my game through a program called Simager, that has an option to clean that and other files before launching the game, so I use the program to do it for me.


Also, as I was browsing for the pet store to put on my neighbourhood just now, I noticed that some expansion buildings are repeated and I have 2 of the same building. Can I safely delete one of them or should I just ignore it and keep both to be safe?

Minaki
Posting Nerd
Posting Nerd

Windows version :
  • Windows 7

System architecture :
  • 64 bits (x64)

Female Posts : 21
Points : 2144
Reputation : 0
Join date : 2011-11-04
Age : 26
Location : Portugal

View user profile

Back to top Go down

Re: Problems in the future - bot building machine

Post by The_gh0stm4n on Sun 24 Nov 2013, 12:37

@Minaki wrote:Yeah, I had fixes but they were from downs-sims3 so I deleted those first before following the instructions to install the new fixes (I have store items on both .sims3packs and .packages formats, so I followed the instructions for both as said on the .txt document). As for deleting the scriptCache.package I didn't have to do so manually 'cause I run my game through a program called Simager, that has an option to clean that and other files before launching the game, so I use the program to do it for me.


Also, as I was browsing for the pet store to put on my neighbourhood just now, I noticed that some expansion buildings are repeated and I have 2 of the same building. Can I safely delete one of them or should I just ignore it and keep both to be safe?
If you have two identical buildings, then yes, you can delete one of them, if you want to.

I have no idea why the thing with the bot-making machine works for the other person, but not for you. My only explanation is that you have conflicting mods. If so, you can try removing all mods, but this is rather an 'experiment'.
avatar
The_gh0stm4n
VETERAN Moderator
Inspector General & Forum O.G.
VETERAN Moderator Inspector General & Forum O.G.

Windows version :
  • Windows 8
  • Windows 7
  • Windows XP
  • Windows 10

System architecture :
  • 32 bits (x86)
  • 64 bits (x64)

Favourite games : The Sims 3, L.A. Noire, Saints Row, Red Faction, Minecraft, Plants vs. Zombies: Garden Warfare, Titanfall, Team Fortress 2, Darkest Hour, GTA: San Andreas, S.W.A.T. 4, Counter-Strike, Hitman, Borderlands, Fallout, Dishonored, Call of Duty, Battlefield, The Binding of Isaac: Afterbirth†
Male Posts : 14062
Points : 18656
Reputation : 1981
Join date : 2012-11-02
Age : 30
Location : San Fierro

View user profile

Back to top Go down

Re: Problems in the future - bot building machine

Post by Minaki on Sun 24 Nov 2013, 12:40

Carlos G. wrote:If you have two identical buildings, then yes, you can delete one of them, if you want to.

I have no idea why the thing with the bot-making machine works for the other person, but not for you. My only explanation is that you have conflicting mods. If so, you can try removing all mods, but this is rather an 'experiment'.
Yeah, that's my next try if starting a new game doesn't fix it.

edit 1: Yep, I'm about to remove most of my mods (I'm leaving nraas, awesomemod, no intro and the store fixes) and give it a try. If that fixes the try I'll need to move to the 50/50 method. If not... I dunno .-.

edit 2: The difference on the loading time with and without mods is superb xD Anyways, the bot making machine now works fine without mods so I guess next week (I can only play sims on the weekends cause of college) I'll be starting with the 50/50 method until I find the conflicting file(s).

Minaki
Posting Nerd
Posting Nerd

Windows version :
  • Windows 7

System architecture :
  • 64 bits (x64)

Female Posts : 21
Points : 2144
Reputation : 0
Join date : 2011-11-04
Age : 26
Location : Portugal

View user profile

Back to top Go down

Re: Problems in the future - bot building machine

Post by Feliseda on Mon 25 Nov 2013, 05:21

What helped me was various things, turns out for my issue with this, it was an outdated store fix, out dated ultimate fix, and i had several small mods that were out dated.

I had to remove a few mods because there were not any updated versions, and update the others.

Feliseda
Beginner
Beginner

Posts : 11
Points : 1384
Reputation : 0
Join date : 2013-11-13

View user profile

Back to top Go down

Re: Problems in the future - bot building machine

Post by Sephymuffins on Mon 25 Nov 2013, 07:13

Hello there,

I'm glad to know you're able to narrow it down! Please let us know when you find the problem file/s and when you are able to safely play your game.  Smile

@Feliseda wrote:What helped me was various things, turns out for my issue with this, it was an outdated store fix, out dated ultimate fix, and i had several small mods that were out dated.

I had to remove a few mods because there were not any updated versions, and update the others.
Yes Feliseda, that's a great suggestion as this method of really checking everything usually does prove to be worth it - mods are very nasty buggers at times and if you're not careful, they can wreak havok on your game without you knowing. 

One of my suggestions for downloading Mods, is to (if they are found on Modthesims for example) check the comments.  Go to the very last few pages of comments and read through them, as many people will test the mods casually on a patch level that goes far beyond what patch level the Mod originally came out/was released for.  I've found quite a few mods that were made in/for The Sims 3 patch level 1.10.6;  this is pretty much a "deathwish" for your game as the latest patch is 1.63!  However, I read through the comments and found out that a few people had tested it for 1.57-1.63 and it was working on their game.  

Always check the comments.

Happy Simming The Sims Plumbob 1
avatar
Sephymuffins
Posting Master
Posting Master

Windows version :
  • Windows 8
  • Windows 7

System architecture :
  • 32 bits (x86)
  • 64 bits (x64)

Favourite games : The Sims™, Final Fantasy, F.E.A.R, Resident Evil, Silent Hill, Minecraft, DayZ, Infestation: Survivor Stories, 7 Days To Die, Metal Gear Rising, The Walking Dead, Fable 3, Bioshock, Skyrim, Fallout, Spore.
Female Posts : 582
Points : 2356
Reputation : 80
Join date : 2013-03-07
Age : 27
Location : East Coast.

View user profile http://www.games4theworlddownloads.org/

Back to top Go down

Re: Problems in the future - bot building machine

Post by Minaki on Mon 25 Nov 2013, 12:23

@Sephymuffins wrote:One of my suggestions for downloading Mods, is to (if they are found on Modthesims for example) check the comments.  Go to the very last few pages of comments and read through them, as many people will test the mods casually on a patch level that goes far beyond what patch level the Mod originally came out/was released for.  I've found quite a few mods that were made in/for The Sims 3 patch level 1.10.6;  this is pretty much a "deathwish" for your game as the latest patch is 1.63!  However, I read through the comments and found out that a few people had tested it for 1.57-1.63 and it was working on their game.  

Always check the comments.

Happy Simming The Sims Plumbob 1
Yeah, I tried to do that, but I guess I failed. I separated my mods into updated for 1.63 and not updated and then moved on to the comments. The problem was when the comments didn't say anything about 1.63, then I had to rely on my judgement of the mod... if they were, for instance, base game compatible, then I took the risk to install them (clearly I must've misjudged a few mods on that selection process) and, quite frankly, I had never found anything weird until I went to the future, prolly cause I have NRaas fixing most of the script errors. Speaking of which, everytime I went to the future, I'd have about 40 script error notifications, most of them related to the nanines and nanite spawners. Before I move on to the 50/50 method I need to run the game with no mods again and see if I'm still getting those or not WhatDidUJustCallMe?

Minaki
Posting Nerd
Posting Nerd

Windows version :
  • Windows 7

System architecture :
  • 64 bits (x64)

Female Posts : 21
Points : 2144
Reputation : 0
Join date : 2011-11-04
Age : 26
Location : Portugal

View user profile

Back to top Go down

Re: Problems in the future - bot building machine

Post by Sephymuffins on Mon 25 Nov 2013, 20:41

@Minaki wrote:
@Sephymuffins wrote:One of my suggestions for downloading Mods, is to (if they are found on Modthesims for example) check the comments.  Go to the very last few pages of comments and read through them, as many people will test the mods casually on a patch level that goes far beyond what patch level the Mod originally came out/was released for.  I've found quite a few mods that were made in/for The Sims 3 patch level 1.10.6;  this is pretty much a "deathwish" for your game as the latest patch is 1.63!  However, I read through the comments and found out that a few people had tested it for 1.57-1.63 and it was working on their game.  

Always check the comments.

Happy Simming The Sims Plumbob 1
Yeah, I tried to do that, but I guess I failed. I separated my mods into updated for 1.63 and not updated and then moved on to the comments. The problem was when the comments didn't say anything about 1.63, then I had to rely on my judgement of the mod... if they were, for instance, base game compatible, then I took the risk to install them (clearly I must've misjudged a few mods on that selection process) and, quite frankly, I had never found anything weird until I went to the future, prolly cause I have NRaas fixing most of the script errors. Speaking of which, everytime I went to the future, I'd have about 40 script error notifications, most of them related to the nanines and nanite spawners. Before I move on to the 50/50 method I need to run the game with no mods again and see if I'm still getting those or not WhatDidUJustCallMe?
Hello again,

I'm sorry you're having to go through so much trouble. 

My recommendation would be to do one mod at a time with no other CC attached to your game while you're testing.  Also, attempt to do this in Windowed mode, considering your load times should be faster and the game in general will more quicker so that way it doesn't take you as long.  Wink

Good luck!  The Sims Plumbob 1
avatar
Sephymuffins
Posting Master
Posting Master

Windows version :
  • Windows 8
  • Windows 7

System architecture :
  • 32 bits (x86)
  • 64 bits (x64)

Favourite games : The Sims™, Final Fantasy, F.E.A.R, Resident Evil, Silent Hill, Minecraft, DayZ, Infestation: Survivor Stories, 7 Days To Die, Metal Gear Rising, The Walking Dead, Fable 3, Bioshock, Skyrim, Fallout, Spore.
Female Posts : 582
Points : 2356
Reputation : 80
Join date : 2013-03-07
Age : 27
Location : East Coast.

View user profile http://www.games4theworlddownloads.org/

Back to top Go down

Re: Problems in the future - bot building machine

Post by Minaki on Mon 25 Nov 2013, 22:31

@Sephymuffins wrote:Hello again,

I'm sorry you're having to go through so much trouble. 

My recommendation would be to do one mod at a time with no other CC attached to your game while you're testing.  Also, attempt to do this in Windowed mode, considering your load times should be faster and the game in general will more quicker so that way it doesn't take you as long.  Wink
Good luck!  The Sims Plumbob 1
I always play the game on window mode cause I like to do other stuff while the game is loading. Before testing the mods I've slowly been adding all my other folders such as CAS, CAP, Build Mode, Buy Mode etc, to rule those out, cause although mods and overrides are usually the ones to blame, I have come to learn that any file can cause issues as long as its corrupted or conflicting with other files.
So far so good, everything is working fine, I was able to try out the nanite and trait chips systems for the 1st time, yay! Now I'll remove all the easy folders into my desktop again and continue the 50/50 method on the 3 remaining folders: scripts and mods (overrides), mods and modified objects (both from packages). Unfortunately this is where the 50/50 method gets trickier cause if I have trouble with any of the folders than yes, it goes down to trying the files one by one.

edit: modified objects folder is clean, as is the mods folder; only the scripts and mods folder left to try now. either the problem is on that one or I have mods conflicting with each other. if the folder works well all by itself but now with the others, I'll use the Dashboard to search for conflicts. anyways, that folder will need to wait until tomorrow 'cause I got college tomorrow and its getting late here.

Minaki
Posting Nerd
Posting Nerd

Windows version :
  • Windows 7

System architecture :
  • 64 bits (x64)

Female Posts : 21
Points : 2144
Reputation : 0
Join date : 2011-11-04
Age : 26
Location : Portugal

View user profile

Back to top Go down

Re: Problems in the future - bot building machine

Post by Sephymuffins on Mon 25 Nov 2013, 23:49

Hello again,

Just a heads up, most scripting mods are not going to work with your patch level of the game.  Almost all scripting mods that were released have yet to be updated and because of patch 1.63 coming out.  It would not surprise me that your folder of scripting mods is causing the problem.

Good luck with testing out your mods tomorrow.  The Sims Plumbob 1
avatar
Sephymuffins
Posting Master
Posting Master

Windows version :
  • Windows 8
  • Windows 7

System architecture :
  • 32 bits (x86)
  • 64 bits (x64)

Favourite games : The Sims™, Final Fantasy, F.E.A.R, Resident Evil, Silent Hill, Minecraft, DayZ, Infestation: Survivor Stories, 7 Days To Die, Metal Gear Rising, The Walking Dead, Fable 3, Bioshock, Skyrim, Fallout, Spore.
Female Posts : 582
Points : 2356
Reputation : 80
Join date : 2013-03-07
Age : 27
Location : East Coast.

View user profile http://www.games4theworlddownloads.org/

Back to top Go down

Re: Problems in the future - bot building machine

Post by Minaki on Tue 26 Nov 2013, 18:07

@Sephymuffins wrote:Hello again,

Just a heads up, most scripting mods are not going to work with your patch level of the game.  Almost all scripting mods that were released have yet to be updated and because of patch 1.63 coming out.  It would not surprise me that your folder of scripting mods is causing the problem.
Good luck with testing out your mods tomorrow.  The Sims Plumbob 1
I now at least half of them were said to be 1.63 compatible, either by the autor of the mod or by testers on the comments page, so the first thing I'll do is go back to Mod the Sims and separate the ones I'm sure are updated from the ones that may or may not be compatible with 1.63. Then, I'll try all the compatible ones at the same time and, if there's no problems, I can start testing the not-so-compatible ones one by one. I should've tried all the mods by friday I hope. I'm kinda overwhelmed with college stuff to do.

edit: so I've been testing the mods in small packs of 5-10 folders at the time, again based not only on the 1.63 compatible but also on my instinct. It came down to a point when I only had 9 folders left to test and I was like "Omg don't tell me this really WAS just a conflict issue >_<" but then, by some miracle, the nanites went back to costing $0, so I now know one or more of these 9 sript mods is the problem ^_^

edit 2: again, my instinct led me straight to the right mod :Di updated it and now the nanite price is back. all i need to do now is try the game again with all the cc at the same time and hope there's no conflicts

edit 3: It worked, the bot building machine is finally working properly, not only on the test game, but also on the old save I was playing. Starting this weekend I can finally go back to playing my sims again. Cheers ^_^

Minaki
Posting Nerd
Posting Nerd

Windows version :
  • Windows 7

System architecture :
  • 64 bits (x64)

Female Posts : 21
Points : 2144
Reputation : 0
Join date : 2011-11-04
Age : 26
Location : Portugal

View user profile

Back to top Go down

View previous topic View next topic Back to top


Permissions in this forum:
You cannot reply to topics in this forum