Mirror links doesn't work

View previous topic View next topic Go down

Mirror links doesn't work

Post by Cambiel on Wed 08 Jan 2014, 11:31

So I searched in Google to find the links to have Midnight Hollow in Sims 3. When I searched everywhere including in this website. I still can't download the Midnight Hollow for free when I click the links(all the same,mega.co.nz) that I searched it said that my browser needs to be update but when I try to searched it, it said that Google chrome is always updated and when I try other recommended browsers like the Firefox it still not working. I know it's not actually related to this website but I have this problem several months ago and I still can't figure it out why I can't download it in mega.co.nz whenever I click the mirror links I still can't access to mega.co.nz .... I'm so frustrated because I really really want to have that town but I can't fix the problem. Please help me to fix it :'(

Cambiel
Beginner
Beginner

Posts : 1
Points : 1323
Reputation : 0
Join date : 2014-01-08

View user profile

Back to top Go down

Re: Mirror links doesn't work

Post by The_gh0stm4n on Fri 10 Jan 2014, 18:38

@Cambiel wrote:So I searched in Google to find the links to have Midnight Hollow in Sims 3. When I searched everywhere including in this website. I still can't download the Midnight Hollow for free when I click the links(all the same,mega.co.nz) that I searched it said that my browser needs to be update but when I try to searched it, it said that Google chrome is always updated and when I try other recommended browsers like the Firefox it still not working. I know it's not actually related to this website but I have this problem several months ago and I still can't figure it out why I can't download it in mega.co.nz whenever I click the mirror links I still can't access to mega.co.nz .... I'm so frustrated because I really really want to have that town but I can't fix the problem. Please help me to fix it :'(


Hello,

You can cleae the browser data (in both Firefox and Chrome) by pressing Ctrl + Shift + Del. Mark the boxes cache and cookies and click on "OK".

Re-start the browsers and see if it works. As for me, I don't have any problems with that.

Keep us updated !


avatar
The_gh0stm4n
VETERAN Moderator
Inspector General & Forum O.G.
VETERAN Moderator Inspector General & Forum O.G.

Windows version :
  • Windows 8
  • Windows 7
  • Windows XP
  • Windows 10

System architecture :
  • 32 bits (x86)
  • 64 bits (x64)

Favourite games : The Sims 3, L.A. Noire, Saints Row, Red Faction, Minecraft, Plants vs. Zombies: Garden Warfare, Titanfall, Team Fortress 2, Darkest Hour, GTA: San Andreas, S.W.A.T. 4, Counter-Strike, Hitman, Borderlands, Fallout, Dishonored, Call of Duty, Battlefield, The Binding of Isaac: Afterbirth†
Male Posts : 14082
Points : 18683
Reputation : 1985
Join date : 2012-11-02
Age : 30
Location : San Fierro

View user profile

Back to top Go down

View previous topic View next topic Back to top


Permissions in this forum:
You cannot reply to topics in this forum