Mods not working[SOLVED]

View previous topic View next topic Go down

Mods not working[SOLVED]

Post by fbmm on Mon 10 Feb 2014, 12:09

I think I have a Mac-specific problem.

I have a few expansion packs installed and loads of CC (both sims3packs and packages), they work fine. I actually don't have a Electronic Arts folder in User/Documents, the game simply doesn't generate one. Instead, this directory is in The Sims 3/Contents/Resources/transgaming/c_drive/Program Files/Electronic Arts/The Sims 3/Game/Bin/%USERPROFILE%/My Documents/Electronic Arts/The Sims 3 (whoa, that's hell of a long path). So, there's where all my Sims 3 stuff is stored, saves, CC, everything.

In the Mods folder, I have a Resource.cfg file and all the packages are working (even default replacements) except for game mods. I've asked this question in the Nraas forums and I've been told that I cannot get the mods working if I have my Sims 3 folder in that path. I reinstalled, did the fixes but that folder just stays there. Any idea how to make game mods work? I'd really like to use some Nrass mods or Awesomemod. (When I put the two awesomemod in my Mods/Packages or Overrides folder, the just wouldn't start loading after the intro.)

fbmm
Posting Nerd
Posting Nerd

Female Posts : 24
Points : 1428
Reputation : 0
Join date : 2014-02-10

View user profile

Back to top Go down

Re: Mods not working[SOLVED]

Post by Dieneryn on Tue 11 Feb 2014, 15:30

Hello,

I'm just making a guess here, but do you have several accounts for your mac? That could be why it does not appear directly in your Documents folder..
avatar
Dieneryn
Posting Master
Posting Master

Favourite games : The Sims Series, Harvest Moon Series, Legend of Zelda, Patapon, Ultimate Marvel vs Capcom, Pheonix Wright Series, Mario, and several other MMORPGs
Female Posts : 592
Points : 2652
Reputation : 86
Join date : 2012-09-09
Age : 27
Location : Woodland Realm, Mirkwood

View user profile

Back to top Go down

Re: Mods not working[SOLVED]

Post by fbmm on Tue 11 Feb 2014, 18:41

No, I only have one account.

I'm thinking about moving that %USERPROFILE% folder somewhere else, like to the desktop, so the game should generate a new one, I'm just not sure where. Anyway, I'd like to keep my saves and installed CC. If I just replace the new folder to the saved one, will I be able to keep them? The saves will of course work but what about the sim3packs? They're stored in the Downloads folder (after installing them) and it would take ages to install them again one by one.

fbmm
Posting Nerd
Posting Nerd

Female Posts : 24
Points : 1428
Reputation : 0
Join date : 2014-02-10

View user profile

Back to top Go down

Re: Mods not working[SOLVED]

Post by fbmm on Fri 21 Feb 2014, 17:27

So, I tried moving the %USERPROFILE% folder to see where does the game generate a new Sims 3 folder. Well, it created a new %USERPROFILE% folder in the same exact location. On the good side, sims3packs still work after putting back the old folder.

What else could I do to get the mods work?

fbmm
Posting Nerd
Posting Nerd

Female Posts : 24
Points : 1428
Reputation : 0
Join date : 2014-02-10

View user profile

Back to top Go down

Re: Mods not working[SOLVED]

Post by Dieneryn on Mon 24 Feb 2014, 05:13

Hello,

Have you made sure that those mods work fine on mac and for your version of Sims?
avatar
Dieneryn
Posting Master
Posting Master

Favourite games : The Sims Series, Harvest Moon Series, Legend of Zelda, Patapon, Ultimate Marvel vs Capcom, Pheonix Wright Series, Mario, and several other MMORPGs
Female Posts : 592
Points : 2652
Reputation : 86
Join date : 2012-09-09
Age : 27
Location : Woodland Realm, Mirkwood

View user profile

Back to top Go down

Re: Mods not working[SOLVED]

Post by fbmm on Mon 24 Feb 2014, 22:21

I haven't read anything about some mods being uncompatible with the mac version of the game.
I removed all the mods then downloaded again the nraas mastercontroller (latest version, my game is also patched to the latest version), put it to the packages folder and nothing happened. There should be new nraas menus but there's nothing. Which is weird because everything else works (both packages and sims3packs), except mods.

fbmm
Posting Nerd
Posting Nerd

Female Posts : 24
Points : 1428
Reputation : 0
Join date : 2014-02-10

View user profile

Back to top Go down

Re: Mods not working[SOLVED]

Post by fbmm on Tue 25 Feb 2014, 17:54

Yay, I fixed it!

I had Wine and WineBottler installed and once I tried to install the Create a World Tool (which is impossible on a mac). WineBottler made some prefixes, one of them was named Sims 3 and had a folder somewhere (not the userprofile one that my game was using but somewhere in application data or something like that). First, I removed the prefixes, deleted those folders, uninstalled Wine and WineBottler. Then I moved the whole %USERPROFILE% folder to my desktop and opened the launcher – tadaam, the game generated a new one in the correct place! I put back my saves there, every CC works fine including mods.

And even my game seems to be loading faster than before.


Helper edit: Happy to hear that! Please let us know if you have more problems. Topic is closed.


-Phoebe

fbmm
Posting Nerd
Posting Nerd

Female Posts : 24
Points : 1428
Reputation : 0
Join date : 2014-02-10

View user profile

Back to top Go down

Re: Mods not working[SOLVED]

Post by Sponsored content


Sponsored content


Back to top Go down

View previous topic View next topic Back to top


Permissions in this forum:
You cannot reply to topics in this forum