'Sims 3 has stopped working'

View previous topic View next topic Go down

'Sims 3 has stopped working'

Post by madsxo on Mon 10 Feb 2014, 18:13

Hi there,
To my frustration my game keeps popping up with 'The Sims 3 has stopped working'. I've noticed a pattern however, it's when I'm on a different part of the map and I click to go back to my household. Or when I load the game, click my household and the game starts to zoom in. It's as though the game attempts to get there and dies half way through.

My specs are:
HP Envy M6 Notebook
Windows 8 64 Bit
6144mb RAM
Intel Core i5-3230M CPU @ 2.60GHz
Configurable graphics - Integrated Intel HD 4000 and dedicated Radeon HD 7670M.

I've tried lots of different things. Windowed mode, lowering specs, turning off internet, having no CC, checking if CC is corrupted, changing graphics driver. My TS3W.exe and the other exes are also set to high performance on my Catalyst Control Centre. I've also tried the guide given on this website which explains 4GB patch and DEP. Nothing has worked.

I really can't figure out the problem. I assumed it might be to do with graphics so I downloaded FRAPs to see what was going on. I really don't know an awful lot about what FPS are but I have screenshotted my game when it crashes and it has died 50FPS and 40FPS. In the case below it died on 40FPS going into the household from neighbourhood view after just loading up.


The game doesn't seem to struggle at all though as in game (when it does decide to play) it's usually varying around 70-80FPS, and even more (100+) if on CAS etc.

Sorry for length, it is so frustrating and I would be so grateful if anybody could help me!

Update: just applied the ultimate fix and still happening Sad

madsxo
Beginner
Beginner

Posts : 3
Points : 1289
Reputation : 0
Join date : 2014-02-10

View user profile

Back to top Go down

Re: 'Sims 3 has stopped working'

Post by The_gh0stm4n on Mon 10 Feb 2014, 22:10

@madsxo wrote:Hi there,
To my frustration my game keeps popping up with 'The Sims 3 has stopped working'. I've noticed a pattern however, it's when I'm on a different part of the map and I click to go back to my household. Or when I load the game, click my household and the game starts to zoom in. It's as though the game attempts to get there and dies half way through.

My specs are:
HP Envy M6 Notebook
Windows 8 64 Bit
6144mb RAM
Intel Core i5-3230M CPU @ 2.60GHz
Configurable graphics - Integrated Intel HD 4000 and dedicated Radeon HD 7670M.

I've tried lots of different things. Windowed mode, lowering specs, turning off internet, having no CC, checking if CC is corrupted, changing graphics driver. My TS3W.exe and the other exes are also set to high performance on my Catalyst Control Centre. I've also tried the guide given on this website which explains 4GB patch and DEP. Nothing has worked.

I really can't figure out the problem. I assumed it might be to do with graphics so I downloaded FRAPs to see what was going on. I really don't know an awful lot about what FPS are but I have screenshotted my game when it crashes and it has died 50FPS and 40FPS. In the case below it died on 40FPS going into the household from neighbourhood view after just loading up.


The game doesn't seem to struggle at all though as in game (when it does decide to play) it's usually varying around 70-80FPS, and even more (100+) if on CAS etc.

Sorry for length, it is so frustrating and I would be so grateful if anybody could help me!

Update: just applied the ultimate fix and still happening Sad


Hello,

I assume you already have chosen your AMD Radeon GPU for the TS3W.exe, in the Catalyst Control Center ?

And what you haven't tried (probably) is this: how did actually apply that "4 GB patch" ? After downloading, double-click on it. In the next window, you have to choose the TS3W.exe in your base game location. Usually that's C:\Program files(x86)\Electronic Arts\The Sims 3\Game\Bin. Wait for the message "executable successfully patched" - and close the 4 GB patch then.

Also, re-read this guide here, even though you say you have tried "everything" there already: http://games4theworld.bestgoo.com/t857-the-sims-3-crashes-freezes-to-desktop-fix-updated-on-7-01-2014

Next, please close down your anti-virus completely, before playing The Sims 3.

Then go to My Documents/Electronic Arts/The Sims 3 and delete all contents inside the Currentgame.sims3 folder. Also, in
My Documents/Electronic Arts/The Sims 3, delete the following stuff:



-CASPartCache.package
-compositorCache.package
-scriptCache.package
-simCompositorCache.package
-socialCache.package
-plus the contents of the folders "WorldCaches" & "Thumbnails"



So much for that. The main purpose of the "Ultimate fix" is that it allows you to play the game without having a physical disc inserted. Yes, it's good that you applied it (correctly), but that's not the end of the story. Also, turning off the internet during play has no (significant) effect on game performance - besides, EA has no way of knowing what games you pirated anyway, whether you have your internet turned on or off.

See if anything of these things help you - if not, let us know. There might be a few other things we could try.

Good luck for now though !

avatar
The_gh0stm4n
VETERAN Moderator
Inspector General & Forum O.G.
VETERAN Moderator Inspector General & Forum O.G.

Windows version :
  • Windows 8
  • Windows 7
  • Windows XP
  • Windows 10

System architecture :
  • 32 bits (x86)
  • 64 bits (x64)

Favourite games : The Sims 3, L.A. Noire, Saints Row, Red Faction, Minecraft, Plants vs. Zombies: Garden Warfare, Titanfall, Team Fortress 2, Darkest Hour, GTA: San Andreas, S.W.A.T. 4, Counter-Strike, Hitman, Borderlands, Fallout, Dishonored, Call of Duty, Battlefield, The Binding of Isaac: Afterbirth†
Male Posts : 14081
Points : 18681
Reputation : 1985
Join date : 2012-11-02
Age : 30
Location : San Fierro

View user profile

Back to top Go down

Re: 'Sims 3 has stopped working'

Post by madsxo on Tue 11 Feb 2014, 12:19

Hi Carlos Smile
thanks for your reply!

I did all the steps mentioned, the 4gb patch again, turning off anti virus - no use. The game was still crashing whilst going down into my household.

However on a plus side, today I completely removed my mods folder and sims3packs installed and my game has started to work properly. I'm not entirely sure how to figure out which custom content is causing the problem.

I have some hair packages, make up, piercings and clothes. The only thing I have other than that are 3 NRAAS mods - Overwatch, Woohooer and Story Progression. I made sure yesterday that these were up to date with my patch level hence why I never suspected that Mods would be the problem.

Also I own the base game, seasons and island paradise - I torrented late night, generations and pets :-)

Thanks again - hopefully we can get to the bottom of this!! Smile

Just a quick update - I have made 2 different mods folders and have been experimenting. With no CC whatsoever the game is working. But with no CC whatsoever and just the Nraas mods the game is working. So it has to be one of my package files :-(

madsxo
Beginner
Beginner

Posts : 3
Points : 1289
Reputation : 0
Join date : 2014-02-10

View user profile

Back to top Go down

Re: 'Sims 3 has stopped working'

Post by bbcakess on Tue 11 Feb 2014, 12:53

I had the same problem! It only worked when I removed all CC, but I needed mods for my game to run smoothly. I decided to reinstall all games(I had quite a few to download haha) and it worked for me. It doesn't happen anymore even when im playing for a few hours and I can have CC.
I also tried everything before reinstalling and nothing's worked.

bbcakess
Beginner
Beginner

Posts : 8
Points : 1505
Reputation : 0
Join date : 2013-07-14

View user profile

Back to top Go down

Re: 'Sims 3 has stopped working'

Post by madsxo on Tue 11 Feb 2014, 13:15

@bbcakess wrote:I had the same problem! It only worked when I removed all CC, but I needed mods for my game to run smoothly. I decided to reinstall all games(I had quite a few to download haha) and it worked for me. It doesn't happen anymore even when im playing for a few hours and I can have CC.
I also tried everything before reinstalling and nothing's worked.
Okay! Yeah my laptop isn't amazing so Overwatch would be really handy hence why I didn't really want to lose it! I will give reinstalling a go :)Thank you! It's such an annoying problem!

madsxo
Beginner
Beginner

Posts : 3
Points : 1289
Reputation : 0
Join date : 2014-02-10

View user profile

Back to top Go down

Re: 'Sims 3 has stopped working'

Post by bbcakess on Tue 11 Feb 2014, 16:06

I'd also recommend downloading game booster + ccleaner, so you can clean your computer from junk, fix registry errors etc. good luck.

bbcakess
Beginner
Beginner

Posts : 8
Points : 1505
Reputation : 0
Join date : 2013-07-14

View user profile

Back to top Go down

Re: 'Sims 3 has stopped working'

Post by The_gh0stm4n on Tue 11 Feb 2014, 23:39

@madsxo wrote:Hi Carlos Smile
thanks for your reply!

I did all the steps mentioned, the 4gb patch again, turning off anti virus - no use. The game was still crashing whilst going down into my household.

However on a plus side, today I completely removed my mods folder and sims3packs installed and my game has started to work properly. I'm not entirely sure how to figure out which custom content is causing the problem.

I have some hair packages, make up, piercings and clothes. The only thing I have other than that are 3 NRAAS mods - Overwatch, Woohooer and Story Progression. I made sure yesterday that these were up to date with my patch level hence why I never suspected that Mods would be the problem.

Also I own the base game, seasons and island paradise - I torrented late night, generations and pets :-)

Thanks again - hopefully we can get to the bottom of this!! Smile

Just a quick update - I have made 2 different mods folders and have been experimenting. With no CC whatsoever the game is working. But with no CC whatsoever and just the Nraas mods the game is working. So it has to be one of my package files :-(


Hello again,

Well, at least a little bit of progress ! Smile 

Back to your problem: one method could be for you to "scan" your .package files with "Delphy's dashboard" (google for it). However, it's not always reliable, so you might try the "clasical" method, put ONE .package in, start the game, see if it works, then exit the game, put the next .package in, etc.

Of course, this can be very tiresome, especially if you have lots of .packages, but it's (usually at least) the safest method of filtering your content.

If the problem lies in one of your .sims3packs, then it's a bit more tricky, but you should try filtering the .packages first. Good luck again !


P.S. while my tips in my previous reply seemingly didn't help in this case here, you should still remember them though, for the future. Wink


avatar
The_gh0stm4n
VETERAN Moderator
Inspector General & Forum O.G.
VETERAN Moderator Inspector General & Forum O.G.

Windows version :
  • Windows 8
  • Windows 7
  • Windows XP
  • Windows 10

System architecture :
  • 32 bits (x86)
  • 64 bits (x64)

Favourite games : The Sims 3, L.A. Noire, Saints Row, Red Faction, Minecraft, Plants vs. Zombies: Garden Warfare, Titanfall, Team Fortress 2, Darkest Hour, GTA: San Andreas, S.W.A.T. 4, Counter-Strike, Hitman, Borderlands, Fallout, Dishonored, Call of Duty, Battlefield, The Binding of Isaac: Afterbirth†
Male Posts : 14081
Points : 18681
Reputation : 1985
Join date : 2012-11-02
Age : 30
Location : San Fierro

View user profile

Back to top Go down

View previous topic View next topic Back to top


Permissions in this forum:
You cannot reply to topics in this forum