Multiple problems ending with service initialization error

View previous topic View next topic Go down

Multiple problems ending with service initialization error

Post by redprospect51 on Sat 30 Jul 2011, 04:24

Hi I just downloaded your entire series from the base all the way to town life stuff. I installed everything fine, and the proceeded to install the most recent everything fix. I applied all the cracks in the ultimate fix making sure to put the generations crack into the base game bin. ( I notice that in your guide step 11 and 10 are the same so i didn't bother repeating) I then copied all the town life stuff over to the base game file as well.

So first I couldn't get the launcher to work, as soon as i clicked the "play"button the launcher would freeze, I searched your forums and saw the solution of opening game through the base game folder (electronic arts/sims3/game/bin...) so i did so and the screen would turn black and I would get the message " it looks like you've installed the unofficial..." the forums suggested to just click continue, which I did, but the screen would remain black and nothing would happen. After waiting for 10 min, and repeating the problem several times I got an error message saying "service initialization failed 0x039e8474".

Ive read the forums and seen people with one of these problems but rarely all at once, also im not sure what could be the issue because im fairly certain that I put all the crack files in the right places, please help im quite confused.

//EDIT


redprospect51
Beginner
Beginner

Posts : 5
Points : 2338
Reputation : 0
Join date : 2011-07-30

View user profile

Back to top Go down

Re: Multiple problems ending with service initialization error

Post by ☠ ~ Aɳɳ ~ ☠ on Sat 30 Jul 2011, 09:55

Hello,
There is a typo in the installationguide that came with the fix, so please reapply the fix, and for step 11 do this:
11. For The Sims 3 - Town Life Stuff: open the "Town Life Stuff" folder in this .rar file and drag & drop both files in there to: C:\Program Files (x86)\Electronic Arts\The Sims 3\Game\Bin and choose "Replace" on the pop-up that appears, telling you the files already exist.
From your screenshot, it also looks like you made a mistake copying some of the original files. I'm looking at the original files from World Adventures (TS3EP01) and Ambitions (TS3EP02) in your "base game" folder. These should be in their own folders, only the files from the "Generations" and "Town Life Stuff" go to C:\Program Files (x86)\Electronic Arts\The Sims 3\Game\Bin
So please reapply the fix, read carefully until you get to step 11, which should read as I typed at the beginning of my post, and then try again!
I hope this helps, please let us know if it does and don't hesitate to post if you run into anything else!

_________________
"Under sun and sky, we greet you warmly"
avatar
☠ ~ Aɳɳ ~ ☠
Forum Administratrix
First Lady of the Forum
Forum Administratrix First Lady of the Forum

Windows version :
  • Windows 8
  • Windows XP
  • Windows 10

System architecture :
  • 32 bits (x86)
  • 64 bits (x64)

Female Posts : 15118
Points : 20171
Reputation : 1460
Join date : 2011-05-31

View user profile

Back to top Go down

Re: Multiple problems ending with service initialization error

Post by Adwomin on Sat 30 Jul 2011, 19:39

Lady ElDi wrote:Hello,
There is a typo in the installationguide that came with the fix, so please reapply the fix, and for step 11 do this:
11. For The Sims 3 - Town Life Stuff: open the "Town Life Stuff" folder in this .rar file and drag & drop both files in there to: C:\Program Files (x86)\Electronic Arts\The Sims 3\Game\Bin and choose "Replace" on the pop-up that appears, telling you the files already exist.
From your screenshot, it also looks like you made a mistake copying some of the original files. I'm looking at the original files from World Adventures (TS3EP01) and Ambitions (TS3EP02) in your "base game" folder. These should be in their own folders, only the files from the "Generations" and "Town Life Stuff" go to C:\Program Files (x86)\Electronic Arts\The Sims 3\Game\Bin
So please reapply the fix, read carefully until you get to step 11, which should read as I typed at the beginning of my post, and then try again!
I hope this helps, please let us know if it does and don't hesitate to post if you run into anything else!
Hello,

And don't forget to delete the files which shouldn't be in that folder.

_________________
Bonsoir, friend.


~ Nobody's gril. ~
avatar
Adwomin
free society
free society

Windows version :
  • Windows 8
  • Windows 7

System architecture :
  • 32 bits (x86)
  • 64 bits (x64)

Favourite games : GTA Series, Cities: Skylines, Prison Architect, Borderlands series
Female Posts : 19210
Points : 1026481
Reputation : 2259
Join date : 2010-03-12
Age : 16
Location : Del Perro Heights

View user profile https://www.games4theworld.org

Back to top Go down

Re: Multiple problems ending with service initialization error

Post by redprospect51 on Sun 31 Jul 2011, 07:43

Well gentelemen I aplaud your quickness and percision but unfortunately still no result, never the less a different one though. I did as you said replaced all the cracks and following your new step 13 ( also made sure to delete the extra files) my first question is: I noticed that the file in my fix it generations folder is labeled TS3W, and in the town life stuff crack its is also TS3W. So when im doing step 12 and 13 i end up replacing the same file twice first i replace it with the generations crack, and then in the next step i replace that with the town life stuff crack- was wondering if thats supposed work out.
As for the result of your advice, I ended up trying to start sims 3 from the bin folder and got the error shown in the pic below, so no result. Then i clicked on the TS3W.exe in the bin folder and Generations loaded up succesfully only to present me with a message saying something allong the lines of "no disc found..." and ultimately forcing me to quit. Just to make sure im reposting a pic f what my bin folder looks like now


//EDIT

I couldn't track down the pic of the error message but it was the service initialization failed 0x039e8474 error. This same error also appeared whenever i tried to open up any of the other sims games through their bin folders. So far the only thing to even open and start running is the TS3W app in the pic above.

redprospect51
Beginner
Beginner

Posts : 5
Points : 2338
Reputation : 0
Join date : 2011-07-30

View user profile

Back to top Go down

Re: Multiple problems ending with service initialization error

Post by ☠ ~ Aɳɳ ~ ☠ on Sun 31 Jul 2011, 09:24

Hello,
Essentially what you're saying about the 2 TS3W files (they are not cracks) is correct, but rather than making things more complicating, Admin has chosen to instruct people to just copy both files to the Bin folder instead of "do this if you have that but do that if you have this".
Your screenshot looks good, though you still seem to have a few files I'm unsure about, but I'll leave it up to Admin or another mod to say.

_________________
"Under sun and sky, we greet you warmly"
avatar
☠ ~ Aɳɳ ~ ☠
Forum Administratrix
First Lady of the Forum
Forum Administratrix First Lady of the Forum

Windows version :
  • Windows 8
  • Windows XP
  • Windows 10

System architecture :
  • 32 bits (x86)
  • 64 bits (x64)

Female Posts : 15118
Points : 20171
Reputation : 1460
Join date : 2011-05-31

View user profile

Back to top Go down

Re: Multiple problems ending with service initialization error

Post by redprospect51 on Sun 31 Jul 2011, 11:25

im stumped

redprospect51
Beginner
Beginner

Posts : 5
Points : 2338
Reputation : 0
Join date : 2011-07-30

View user profile

Back to top Go down

Re: Multiple problems ending with service initialization error

Post by Adwomin on Sun 31 Jul 2011, 14:07

@redprospect51 wrote:Well gentelemen I aplaud your quickness and percision but unfortunately still no result, never the less a different one though. I did as you said replaced all the cracks and following your new step 13 ( also made sure to delete the extra files) my first question is: I noticed that the file in my fix it generations folder is labeled TS3W, and in the town life stuff crack its is also TS3W. So when im doing step 12 and 13 i end up replacing the same file twice first i replace it with the generations crack, and then in the next step i replace that with the town life stuff crack- was wondering if thats supposed work out.
As for the result of your advice, I ended up trying to start sims 3 from the bin folder and got the error shown in the pic below, so no result. Then i clicked on the TS3W.exe in the bin folder and Generations loaded up succesfully only to present me with a message saying something allong the lines of "no disc found..." and ultimately forcing me to quit. Just to make sure im reposting a pic f what my bin folder looks like now


//EDIT

I couldn't track down the pic of the error message but it was the service initialization failed 0x039e8474 error. This same error also appeared whenever i tried to open up any of the other sims games through their bin folders. So far the only thing to even open and start running is the TS3W app in the pic above.
Hello,

Did you copy the files from the "# Crack" > "Town Life Stuff" folder to the game's directory? (This is where you just took a screenshot of)

_________________
Bonsoir, friend.


~ Nobody's gril. ~
avatar
Adwomin
free society
free society

Windows version :
  • Windows 8
  • Windows 7

System architecture :
  • 32 bits (x86)
  • 64 bits (x64)

Favourite games : GTA Series, Cities: Skylines, Prison Architect, Borderlands series
Female Posts : 19210
Points : 1026481
Reputation : 2259
Join date : 2010-03-12
Age : 16
Location : Del Perro Heights

View user profile https://www.games4theworld.org

Back to top Go down

Re: Multiple problems ending with service initialization error

Post by redprospect51 on Mon 01 Aug 2011, 01:31

at first I took it out of the ultimate fix/town life folder, then I tried using the file from the #crack folder and what do you know we have some results! so when i start sims by going to my game/bin, and clicking on TS3W- town life stuff opens up and plays, everything works! BUT!, all the other games do not, even if i click TS3 to get to the base game- nothing, every time i get the same error"service initialization failed 0x039e8474" something strange is going on here though, because I get this error for everything except town life stuff, and Generations which when clicked for some reason opens up town life stuff.
Since the generations folder and the Town life folder have the same title .exe i don't think my computer can tell the difference- so thus far town life stuff works and everything else doesn't

redprospect51
Beginner
Beginner

Posts : 5
Points : 2338
Reputation : 0
Join date : 2011-07-30

View user profile

Back to top Go down

Re: Multiple problems ending with service initialization error

Post by ☠ ~ Aɳɳ ~ ☠ on Mon 01 Aug 2011, 09:33

Hello,
What you're describing isn't an error. The game always shows you the latest loadingscreen so if you install Generations, but not Town Life Stuff, you get the Generations loading screen, and when the "pets" expansion comes out this fall you'll get the "pets" loadingscreen.
That you can only start your game using the Gen or TLS shortcuts is probably because EA made some changes in the .exe files, before these packs it was indeed possible to start the game using any of the shortcuts.
The expansions are not stand-alone options, so all of your expansions are working once you start the game. The expansion's options are integrated in your existing game once installed.
In other words: Your game is working perfectly. Have fun playing!

_________________
"Under sun and sky, we greet you warmly"
avatar
☠ ~ Aɳɳ ~ ☠
Forum Administratrix
First Lady of the Forum
Forum Administratrix First Lady of the Forum

Windows version :
  • Windows 8
  • Windows XP
  • Windows 10

System architecture :
  • 32 bits (x86)
  • 64 bits (x64)

Female Posts : 15118
Points : 20171
Reputation : 1460
Join date : 2011-05-31

View user profile

Back to top Go down

Re: Multiple problems ending with service initialization error

Post by redprospect51 on Fri 05 Aug 2011, 07:10

OK so now what ends up happening is the game loads I play for about 10 min and then the game freezes, at that point i have to ctrl alt dlt, and get your standard the sims 3 has stopped working error message.

redprospect51
Beginner
Beginner

Posts : 5
Points : 2338
Reputation : 0
Join date : 2011-07-30

View user profile

Back to top Go down

Re: Multiple problems ending with service initialization error

Post by ☠ ~ Aɳɳ ~ ☠ on Fri 05 Aug 2011, 09:19


_________________
"Under sun and sky, we greet you warmly"
avatar
☠ ~ Aɳɳ ~ ☠
Forum Administratrix
First Lady of the Forum
Forum Administratrix First Lady of the Forum

Windows version :
  • Windows 8
  • Windows XP
  • Windows 10

System architecture :
  • 32 bits (x86)
  • 64 bits (x64)

Female Posts : 15118
Points : 20171
Reputation : 1460
Join date : 2011-05-31

View user profile

Back to top Go down

Re: Multiple problems ending with service initialization error

Post by Sponsored content


Sponsored content


Back to top Go down

View previous topic View next topic Back to top


Permissions in this forum:
You cannot reply to topics in this forum