I just can't play Sims 3, no matter what I do or not. Please HELP

View previous topic View next topic Go down

I just can't play Sims 3, no matter what I do or not. Please HELP

Post by Argaria on Wed 28 May 2014, 13:12

Hi to all the skillful admins of this page. 

First, thank you for all you are doing and all the games you are keeping playable for us.

In the last few months I have been having problems with Sims 3 almost always - it was very slow, it was crashing from time to time or it just didn't start. That was also my latest problem, so I decided to solve everything (or at least so I hoped) by following exactly only the instruction on G4TW (before that I tried everything I could find through Google). 

So I uninstalled everything and deleted all the registry keys related to Sims. Then I installed the game and 3 expansions (Late Night, Pets, Seasons) one by one, applied the manual patch and files from the Ultimate Fix - everything as described. The game did start, but only once - after I put back the older saves and CC, the only thing I got was a black screen with a blinking cursor (the ingame loading one) and game music playing. Also the logo once flashed for a second, but that was all - no menu or anything. 

Of course I got rid of all the saves and sorted the CC folder to categories, then I launched Process Monitor to see what is the part of CC which conflicts with the game. Found one, deleted it and the game started. But after logging into Dragon Valley and creating a family, I couldn't move it into any house. Everything is okay till the loading - then the "game stopped working" error occurs. Everytime. 

Well, at least everytime I get to this point, because sometimes the game won't start at all. I copied my older saves to the Documents EA folder and I couldn't even see if the game "accepted" them. All I got was a black screen with a flashing cursor (the ingame loading one).

I searched this forum and tried anything what seemed a bit useful - tweaking the graphics card settings, updating its driver, adding the executables to DEP and so on... Please, give me a working advice once and for all.  Help I used to play this game without major problems, it was just a bit slow, but now it's getting worse all the more I long to play it.  Crying or Very sad 

By the way, as mentioned - I have Late Night, Pets and Seasons installed, no other EP or store content except Dragon Valley and Hidden Springs neighbourhoods. Just quite a lot of downloaded stuff (thought about trying to combine it through S3PE or whatever was the program). And I'm running the game on Win XP SP3. 

In advance - thank you for any effort to help!  Rolling Eyes

EDIT: Forgot to mention: after a few unsuccesful attempts to start the game (sometimes only one is enough) it seems to put down the functionality of a graphic card < the error "device 0 unable to run this title" appear on startup and then some of the other games report "no 3D device" as well. However I have a decent graphic card, GeForce GT 9600, which is well-known to be able to deal even with modern games even on 512MB - and as I said, in the past it had no problems either with Sims 3.


Last edited by Argaria on Wed 28 May 2014, 13:32; edited 1 time in total (Reason for editing : Forgot to mention something.)

Argaria
Beginner
Beginner

Posts : 2
Points : 1243
Reputation : 0
Join date : 2014-05-27

View user profile

Back to top Go down

Re: I just can't play Sims 3, no matter what I do or not. Please HELP

Post by The_gh0stm4n on Sat 31 May 2014, 06:28

Argaria wrote:Hi to all the skillful admins of this page. 

First, thank you for all you are doing and all the games you are keeping playable for us.

In the last few months I have been having problems with Sims 3 almost always - it was very slow, it was crashing from time to time or it just didn't start. That was also my latest problem, so I decided to solve everything (or at least so I hoped) by following exactly only the instruction on G4TW (before that I tried everything I could find through Google). 

So I uninstalled everything and deleted all the registry keys related to Sims. Then I installed the game and 3 expansions (Late Night, Pets, Seasons) one by one, applied the manual patch and files from the Ultimate Fix - everything as described. The game did start, but only once - after I put back the older saves and CC, the only thing I got was a black screen with a blinking cursor (the ingame loading one) and game music playing. Also the logo once flashed for a second, but that was all - no menu or anything. 

Of course I got rid of all the saves and sorted the CC folder to categories, then I launched Process Monitor to see what is the part of CC which conflicts with the game. Found one, deleted it and the game started. But after logging into Dragon Valley and creating a family, I couldn't move it into any house. Everything is okay till the loading - then the "game stopped working" error occurs. Everytime. 

Well, at least everytime I get to this point, because sometimes the game won't start at all. I copied my older saves to the Documents EA folder and I couldn't even see if the game "accepted" them. All I got was a black screen with a flashing cursor (the ingame loading one).

I searched this forum and tried anything what seemed a bit useful - tweaking the graphics card settings, updating its driver, adding the executables to DEP and so on... Please, give me a working advice once and for all.  Help I used to play this game without major problems, it was just a bit slow, but now it's getting worse all the more I long to play it.  Crying or Very sad 

By the way, as mentioned - I have Late Night, Pets and Seasons installed, no other EP or store content except Dragon Valley and Hidden Springs neighbourhoods. Just quite a lot of downloaded stuff (thought about trying to combine it through S3PE or whatever was the program). And I'm running the game on Win XP SP3. 

In advance - thank you for any effort to help!  Rolling Eyes

EDIT: Forgot to mention: after a few unsuccesful attempts to start the game (sometimes only one is enough) it seems to put down the functionality of a graphic card < the error "device 0 unable to run this title" appear on startup and then some of the other games report "no 3D device" as well. However I have a decent graphic card, GeForce GT 9600, which is well-known to be able to deal even with modern games even on 512MB - and as I said, in the past it had no problems either with Sims 3.

Hello,

Have you actually tried playing without your old saves ? Try renaming the folder "The Sims 3" (in My Documents/Electronic Arts) into anything you like. Now start the game and see if you are actually able to play on for a while...after that, we'll see about putting your old saves back in, and maybe your CC too.


As for the blackscreen issue, chek out the following topics on here if you haven't done so yet:

http://games4theworld.bestgoo.com/t16586-black-screen-at-startup-other-possible-fixes


http://games4theworld.bestgoo.com/t4860-dark-screen-fixes



That's all I can suggest for now. Good luck, and keep me updated ! Smile  

_________________
Respectfully,

The_gh0stm4n
G4TW Forum Gatekeeper



avatar
The_gh0stm4n
VETERAN Moderator
Inspector General & Forum O.G.
VETERAN Moderator Inspector General & Forum O.G.

Windows version :
  • Windows 8
  • Windows 7
  • Windows XP
  • Windows 10

System architecture :
  • 32 bits (x86)
  • 64 bits (x64)

Favourite games : The Sims 3, L.A. Noire, Saints Row, Red Faction, Minecraft, Plants vs. Zombies: Garden Warfare, Titanfall, Team Fortress 2, Darkest Hour, GTA V, GTA: San Andreas, S.W.A.T. 4, Counter-Strike, Hitman, Borderlands, Fallout, Dishonored, Call of Duty, Battlefield, The Binding of Isaac: Afterbirth†, Enter the Gungeon.
Male Posts : 14433
Points : 19156
Reputation : 2037
Join date : 2012-11-02
Location : The Situation Room

View user profile

Back to top Go down

Re: I just can't play Sims 3, no matter what I do or not. Please HELP

Post by Argaria on Sun 08 Jun 2014, 21:03

Hello and thank you.

I tried your suggestions (those in the first link I tested even before), but even though Sims started after renaming the folder in Documents, after a short minimizing and maximizing again it got stuck at the black screen. I also tried to run the game with no other processes going, but it just won't load - all I get is a music and a black screen with no cursor now, or a white screen with some colourful vertical lines. In the middle of the game startup the monitor has no problem to report "No signal, going to sleep" and back off, minimising the game solves it but doesn't make the game to start. 
It's making me quite sad now, I realized that I could have some fun even without all the CC but it just won't run anyway.

I think of the possibility of my graphic card getting old and needing replacement, but usually it still can manage all of my other games, so I'm not sure at all.

Argaria
Beginner
Beginner

Posts : 2
Points : 1243
Reputation : 0
Join date : 2014-05-27

View user profile

Back to top Go down

View previous topic View next topic Back to top


Permissions in this forum:
You cannot reply to topics in this forum