Missing sims and can't click on anything after returning to present

View previous topic View next topic Go down

Missing sims and can't click on anything after returning to present

Post by Vertimyst on Tue 01 Jul 2014, 03:11

Hi all,

UPDATE:  I might have got it working again, by going into Edit Town (which, oddly, forces the game into 'new game' mode), and selecting my household again.  I tried it before and it messed up (described below), but it seems to be okay this time.  But if anyone knows of a proper fix, that'd be great (just in case).

I'm having a really annoying issue with Into the Future.  I'm trying to get my sims to go back to the present, but every time I do, after my town loads, I can't do anything except click the options button and control the speed, and the only sims that appear are my female sim and her husband.  Their twin babies and simbot never make the journey, and several UI elements are missing as well - the sim portraits, all my sims simoleons, lifetime wishes, etc. are gone, and I can't enter buy or build mode, or open the panel with the sims' information (bladder, hunger, etc.)  - the button does nothing.

I've tried reloading, and I installed NRaas' Traveler, Overwatch and Error Trap mods.  Those didn't help, though, and Error Trap reports 18 errors, Traveler reports 3 (which explains my missing twins and simbot).

I also tried entering edit town mode, and going back to my lot, but that resets the game into new game mode, and after selecting my lot all the sims are there, but the husband's name changes, as though he's a different sim, and the real husband appears in the relationships panel, but appears as though he's in a foreign country (I can have my other sim invite him to visit).

Is there anything I can do, or do my sims have to go on living in the future forever?

I'm running the latest version of the game (1.67), all with expansions and stuff packs downloaded from here.  I followed your ultimate fix guide to the letter, this is the first time I've had any issue like this.

Also, I'm running Windows 8.1 Pro, if that matters.

Here's a screenshot of what my game looks like after traveling back to the present: 


Last edited by Vertimyst on Tue 01 Jul 2014, 03:20; edited 2 times in total (Reason for editing : More information)

Vertimyst
Beginner
Beginner

Posts : 2
Points : 1146
Reputation : 0
Join date : 2014-07-01

View user profile

Back to top Go down

Re: Missing sims and can't click on anything after returning to present

Post by The_gh0stm4n on Sun 06 Jul 2014, 17:51

Hello and sorry for the late reply,


No, there is no "proper" fix for that glitch. Thanks to EA, who managed to break something (namely the travelling system) which worked perfectly fine until some point.

One workaround could be to use the NRAAS_MasterController mod and reset the whole future world, by clicking on the town hall logo in map view and choosing NRAAS -> MasterController -> Town - Reset everything.

After the reset is done (can take a while !), use the option "Save as" and choose a new name for the save. Then exit the game, and re-load it.

Now, you choose your new savefile (the one for which you just chose a new name) and load it. See if you now can travel home safely.
avatar
The_gh0stm4n
VETERAN Moderator
Inspector General & Forum O.G.
VETERAN Moderator Inspector General & Forum O.G.

Windows version :
  • Windows 8
  • Windows 7
  • Windows XP
  • Windows 10

System architecture :
  • 32 bits (x86)
  • 64 bits (x64)

Favourite games : The Sims 3, L.A. Noire, Saints Row, Red Faction, Minecraft, Plants vs. Zombies: Garden Warfare, Titanfall, Team Fortress 2, Darkest Hour, GTA: San Andreas, S.W.A.T. 4, Counter-Strike, Hitman, Borderlands, Fallout, Dishonored, Call of Duty, Battlefield, The Binding of Isaac: Afterbirth†
Male Posts : 14068
Points : 18664
Reputation : 1982
Join date : 2012-11-02
Age : 30
Location : San Fierro

View user profile

Back to top Go down

Re: Missing sims and can't click on anything after returning to present

Post by Vertimyst on Sun 06 Jul 2014, 19:32

Thanks Carlos.

I've managed to get it working again (for now) by travelling home, and going into edit town mode and back into my lot, which seems to have reset things back to normal.  If I run into the issue again, I'll try your suggestion though.  Thanks!

Vertimyst
Beginner
Beginner

Posts : 2
Points : 1146
Reputation : 0
Join date : 2014-07-01

View user profile

Back to top Go down

Re: Missing sims and can't click on anything after returning to present

Post by The_gh0stm4n on Mon 07 Jul 2014, 22:37

@Vertimyst wrote:Thanks Carlos.

I've managed to get it working again (for now) by travelling home, and going into edit town mode and back into my lot, which seems to have reset things back to normal.  If I run into the issue again, I'll try your suggestion though.  Thanks!


Sure, no problem. Smile  I'll leave this topic open, so that you can return here any time you want. Just use the posting history function in your profile, should you decide to come here later. Go to your profile, and to "Statistics". Then go to "Find all messages posted by Vertimyst"...

Have fun !
avatar
The_gh0stm4n
VETERAN Moderator
Inspector General & Forum O.G.
VETERAN Moderator Inspector General & Forum O.G.

Windows version :
  • Windows 8
  • Windows 7
  • Windows XP
  • Windows 10

System architecture :
  • 32 bits (x86)
  • 64 bits (x64)

Favourite games : The Sims 3, L.A. Noire, Saints Row, Red Faction, Minecraft, Plants vs. Zombies: Garden Warfare, Titanfall, Team Fortress 2, Darkest Hour, GTA: San Andreas, S.W.A.T. 4, Counter-Strike, Hitman, Borderlands, Fallout, Dishonored, Call of Duty, Battlefield, The Binding of Isaac: Afterbirth†
Male Posts : 14068
Points : 18664
Reputation : 1982
Join date : 2012-11-02
Age : 30
Location : San Fierro

View user profile

Back to top Go down

View previous topic View next topic Back to top


Permissions in this forum:
You cannot reply to topics in this forum