Sims 3 Crashing In Buy/Build mode. [SOLVED]

View previous topic View next topic Go down

Sims 3 Crashing In Buy/Build mode. [SOLVED]

Post by radiated101 on Mon 15 Aug 2011, 05:46

Well, I'm just going to list all the steps I took. The sims 3 + all expansions were downloaded here, from Games4TheWorld. No, I do not have any modifications for the game, either.

1. Installed Sims 3 (did not apply crack, as I was going to install all expansions.)
2. Installed Town Life Stuff (updated game, as the Installer said to)
3. Installed Generations
4. Installed World Adventures
5. Installed High-End Loft Stuff
6. Installed Ambitions
7. Installed Fast Lane Stuff
8. Installed Late Night
9. Installed Outdoor Living Stuff.
10. I did not apply any cracks for the game, instead I went to the fix. Put all the files into the correct directories, and then updated the game (which was successful, no problems there.)
11. Afterwords, I applied the crack for Town Life Stuff only, as it said in the instructions. No, I did not put the stuff into the Town Life Stuff's directory, I put it into the main Sims 3 directory, said yes, to replace the files, and then started the game from the All Programs menu. After I did this, the game started like normal, it did not minimize and give me the modification message, which I know what looks like, since I put a crack on my sister's laptop for the Sims 3, and I got that message. Game just starts like normal. After I created a few Sims, I go into buy/build mode, edit, and it crashes, having to manually pull the plug on my computer. I was reading about why this happens, and apparently it has to do with EA catching you as a pirate. I'm not certain what I did wrong, since, as you said in your post, to follow all of the instructions 100% exactly, which I did. My operating system is Windows XP (don't hate), and it meets the minimum requirments for the game. I installed the game once before on the computer, but I didn't install it correctly, so I uninstalled everything, and used CCleaner to remove all the bull crap from my PC, including the registry errors. I don't think I deleted the folder in My Documents, though, since I forgot to. Don't know if that would effect my Sims 3 game that I installed here. Any help would be appreciated, thanks.

TL;DR: Installed game, applied crack, don't work.

radiated101
Beginner
Beginner

Posts : 2
Points : 2267
Reputation : 0
Join date : 2011-08-15

View user profile

Back to top Go down

Re: Sims 3 Crashing In Buy/Build mode. [SOLVED]

Post by Adwomin on Mon 15 Aug 2011, 13:16

Hello,

Seems like you did all the steps correctly. Although, you say the game gives you the "Unofficial game modification" error, right? If you use the latest version of the Ultimate Fix, you won't get that error. So first please download and apply the latest version of the Ultimate Fix and see if it makes a difference.

If not, also try these steps: http://games4theworld.bestgoo.com/t857-the-sims-3-crashes-freezes-to-desktop-fix-update-8-06-2011

I don't think it's that EA is "catching" you. As far as I know, something like that isn't possible.

_________________
Bonsoir, friend.


~ Nobody's gril. ~
avatar
Adwomin
free society
free society

Windows version :
  • Windows 8
  • Windows 7

System architecture :
  • 32 bits (x86)
  • 64 bits (x64)

Favourite games : GTA Series, Cities: Skylines, Prison Architect, Borderlands series
Female Posts : 19211
Points : 1026425
Reputation : 2253
Join date : 2010-03-12
Age : 16
Location : Del Perro Heights

View user profile https://www.games4theworld.org

Back to top Go down

Re: Sims 3 Crashing In Buy/Build mode. [SOLVED]

Post by radiated101 on Mon 15 Aug 2011, 21:20

Yes, I know. Just some crap I read online. Of course they aren't literally "catching" you. Razz I'll fill you in if this works.

//EDIT

Alright, well, I manually uninstalled the game + all expansions, deleted all traces of Sims 3 from my system, reinstalled it the exact same way I did before, then set DEP for all files with the .exe extension in my Sims folders, ran the game in Windowed mode, and it's now working flawlessly.. Well, atleast it now works. Thanks for the instructions, Admin.

Mod edit: Problem solved, topic closed.

- LadyElDi

radiated101
Beginner
Beginner

Posts : 2
Points : 2267
Reputation : 0
Join date : 2011-08-15

View user profile

Back to top Go down

View previous topic View next topic Back to top


Permissions in this forum:
You cannot reply to topics in this forum