Custom Content/Mods Not Showing Up in Game [SOLVED]

View previous topic View next topic Go down

Custom Content/Mods Not Showing Up in Game [SOLVED]

Post by jiae on Sun 09 Nov 2014, 03:18

My mods are all in the package file inside of the 1 sims 4 Mods folder, but it doesnt show my mods in the create a sims or anything. I dont see any of the custom content I added to the game. I've made sure all of my custom content are for the Sims 4 only.

Is it because my custom  content is inside of Documents>Electronic Arts>The Sims 4>Mods>Package
Should I put a copy of my Mods folder into Program Files (86)>Electronic Arts>The Sims 4>Game>Bin

???
avatar
jiae
Posting Nerd
Posting Nerd

Windows version :
  • Windows 10

System architecture :
  • 64 bits (x64)

Female Posts : 31
Points : 1694
Reputation : 2
Join date : 2013-02-22

View user profile

Back to top Go down

Re: Custom Content/Mods Not Showing Up in Game [SOLVED]

Post by The_gh0stm4n on Sun 09 Nov 2014, 03:40

@jiae wrote:
My mods are all in the package file inside of the 1 sims 4 Mods folder, but it doesnt show my mods in the create a sims or anything. I dont see any of the custom content I added to the game. I've made sure all of my custom content are for the Sims 4 only.

Is it because my custom  content is inside of Documents>Electronic Arts>The Sims 4>Mods>Package
Should I put a copy of my Mods folder into Program Files (86)>Electronic Arts>The Sims 4>Game>Bin

???


Hello Jiae and welcome,


Yes, your location is correct, I think. See this here too:
http://games4theworld.bestgoo.com/t18175-how-to-install-custom-content-in-ts4-package-files-script-mods-custom-sims-lots


I'm not sure about your CC, but if you have scripting mods, you must enable them in your options menu, in-game, and then re-start the game.


Please do post back about your progress and we'll see further about that; good luck ! Smile 
avatar
The_gh0stm4n
VETERAN Moderator
Inspector General & Forum O.G.
VETERAN Moderator Inspector General & Forum O.G.

Windows version :
  • Windows 8
  • Windows 7
  • Windows XP
  • Windows 10

System architecture :
  • 32 bits (x86)
  • 64 bits (x64)

Favourite games : The Sims 3, L.A. Noire, Saints Row, Red Faction, Minecraft, Plants vs. Zombies: Garden Warfare, Titanfall, Team Fortress 2, Darkest Hour, GTA: San Andreas, S.W.A.T. 4, Counter-Strike, Hitman, Borderlands, Fallout, Dishonored, Call of Duty, Battlefield, The Binding of Isaac: Afterbirth†
Male Posts : 14087
Points : 18692
Reputation : 1988
Join date : 2012-11-02
Age : 30
Location : San Fierro

View user profile

Back to top Go down

Re: Custom Content/Mods Not Showing Up in Game [SOLVED]

Post by jiae on Sun 09 Nov 2014, 08:55

From the link you gave, it appearance I've done it the correct way. 
I only have like 2 script mods and I did have to acivate it in the game, but Im still not seeing the mods WhatDidUJustCallMe?
Here are some screen caps of my folders if that helps:




Here is a file I downloaded that is a script mod, I think?? Ive never used them before so idk if I did it right. I just dragged the zip folder into the packages file without extracting anything. And this is what it looks like when I open it.

avatar
jiae
Posting Nerd
Posting Nerd

Windows version :
  • Windows 10

System architecture :
  • 64 bits (x64)

Female Posts : 31
Points : 1694
Reputation : 2
Join date : 2013-02-22

View user profile

Back to top Go down

Re: Custom Content/Mods Not Showing Up in Game [SOLVED]

Post by SeoY on Sun 09 Nov 2014, 15:30

Hi there! Smile

All of the files are in the correct location. The problem you're having is that you are nesting the files too many subfolders deep. The resource.cfg that you have at the moment only allows to have one subfolder inside the Mods folder. As you have more subfolders deep, the game won't read any of those files. 

What you need to do is edit your resource.cfg file, using any text editor like Notepad or Wordpad. When you open it, edit it so it looks like this:

Priority 500
PackedFile *.package
PackedFile */*.package
PackedFile */*/*.package
PackedFile */*/*/*.package
PackedFile */*/*/*/*.package
PackedFile */*/*/*/*/*.package

Close and save the file. Make sure that when you save it doesn't add a .txt at the name of the file. It should be named exactly as it was before you edited it. 

This will allow you to have up to 5 subfolders deep. In your screenshots I couldn't really see how many nested subfolders you have, but they seem like a lot (in every screenshot there's at least one more subfolder inside). You need to organize your CC and Mods accordingly.

Good luck, and please let us know how it goes! Wink

_________________
"The capital lies before us my friend. What a sombre place it seems and one that holds the answers to many a mystery." - Quirrel.


"Isn't this a wonderful spot for a rest? I so love the sound of the rain upon glass."
avatar
SeoY
Minecraft Moderator
MC Wizard & Keeper of the Realm
Minecraft Moderator MC Wizard & Keeper of the Realm

Windows version :
  • Windows 8
  • Windows 7
  • Windows 10

System architecture :
  • 32 bits (x86)
  • 64 bits (x64)

Favourite games : Hollow Knight, Dishonored, Bioshock Infinite, Bioshock 1-2, The Sims series, Terraria, Metro 2033, Metro: Last Light, Batman: Arkham series, Ōkami, Metal Gear Solid series, The Binding of Isaac, Silent Hill, Ace Attorney, Civilization V, Portal 2, Minecraft
Male Posts : 1726
Points : 3642
Reputation : 298
Join date : 2013-10-12
Age : 21
Location : City of Tears

View user profile

Back to top Go down

Re: Custom Content/Mods Not Showing Up in Game [SOLVED]

Post by jiae on Sun 09 Nov 2014, 17:08

Like this?
avatar
jiae
Posting Nerd
Posting Nerd

Windows version :
  • Windows 10

System architecture :
  • 64 bits (x64)

Female Posts : 31
Points : 1694
Reputation : 2
Join date : 2013-02-22

View user profile

Back to top Go down

Re: Custom Content/Mods Not Showing Up in Game [SOLVED]

Post by Shamrock on Sun 09 Nov 2014, 18:24

I'm not sure you need so many lines...

6 like instructed by SeoY should be enough! Wink

_________________
Have some tea, and take care!
Best regards,

Shamrock  





Please PM or e-mail me for any help or advice!
avatar
Shamrock
Forum Moderator
Taking care of the Forum
Forum Moderator Taking care of the Forum

Windows version :
  • Windows 8
  • Windows 7

System architecture :
  • 64 bits (x64)

Favourite games : The Sims 3 (series), Warcraft III, Civilization V, Vampire Bloodlines, Football Manager 2012, Pokemon games
Male Posts : 3265
Points : 5881
Reputation : 381
Join date : 2012-03-06
Location : On the slim border between sane and insane

View user profile

Back to top Go down

Re: Custom Content/Mods Not Showing Up in Game [SOLVED]

Post by The_gh0stm4n on Sun 09 Nov 2014, 23:06

Yes, that should be fine, jiae. However, theoretically, you do not even need any "sub-sub-folders". If you like to have only one sub-folder for each category, inside "Mods", then you don't need to edit the file.

Yes, that's a weakness in the guide I linked to, above. It only shows one sub-folder for each category under "Mods", like Hair, Test, Clothing and so on. But I personally don't need an elaborate system with many sub-folders. Laughing 
avatar
The_gh0stm4n
VETERAN Moderator
Inspector General & Forum O.G.
VETERAN Moderator Inspector General & Forum O.G.

Windows version :
  • Windows 8
  • Windows 7
  • Windows XP
  • Windows 10

System architecture :
  • 32 bits (x86)
  • 64 bits (x64)

Favourite games : The Sims 3, L.A. Noire, Saints Row, Red Faction, Minecraft, Plants vs. Zombies: Garden Warfare, Titanfall, Team Fortress 2, Darkest Hour, GTA: San Andreas, S.W.A.T. 4, Counter-Strike, Hitman, Borderlands, Fallout, Dishonored, Call of Duty, Battlefield, The Binding of Isaac: Afterbirth†
Male Posts : 14087
Points : 18692
Reputation : 1988
Join date : 2012-11-02
Age : 30
Location : San Fierro

View user profile

Back to top Go down

Re: Custom Content/Mods Not Showing Up in Game [SOLVED]

Post by jiae on Mon 10 Nov 2014, 00:16

Well, Ive deleted my sub-sub folders and just put one sub folder per-category now.
 I like to have it organized WhatDidUJustCallMe? in case I need to find and delete something
So I just copied my old packages folder to the desktop 

But anyways, the game is working fine and my mods are finally showing up in the game! Smile

The only thing now is it wouldnt work with the ultimate fix. I ALWAYS have issues with applying the Ultimate fixes. Even with my many Sims 3 downloads. it seems to work better w/o them

i dont know what Im doing wrong. So this time I tried to follow the instructions, but the result was that I couldnt run the game bc it said something like, My game is missing data. 

So, I just re-installed the game yet again, this time w/o the Ultimate fix, and its running fine with my mods and stuff..
avatar
jiae
Posting Nerd
Posting Nerd

Windows version :
  • Windows 10

System architecture :
  • 64 bits (x64)

Female Posts : 31
Points : 1694
Reputation : 2
Join date : 2013-02-22

View user profile

Back to top Go down

Re: Custom Content/Mods Not Showing Up in Game [SOLVED]

Post by SeoY on Mon 10 Nov 2014, 02:46

@jiae wrote:
Well, Ive deleted my sub-sub folders and just put one sub folder per-category now.
 I like to have it organized WhatDidUJustCallMe? in case I need to find and delete something
So I just copied my old packages folder to the desktop 

But anyways, the game is working fine and my mods are finally showing up in the game! Smile

The only thing now is it wouldnt work with the ultimate fix. I ALWAYS have issues with applying the Ultimate fixes. Even with my many Sims 3 downloads. it seems to work better w/o them

i dont know what Im doing wrong. So this time I tried to follow the instructions, but the result was that I couldnt run the game bc it said something like, My game is missing data. 

So, I just re-installed the game yet again, this time w/o the Ultimate fix, and its running fine with my mods and stuff..

Most of the time keeping the organization simple in the Mods folder is beneficial too. The game could take time loading the files from so many subfolders, making the loading times longer. Wink

About the Ultimate Fix, I replied in your other topic here:
http://games4theworld.bestgoo.com/t18307-can-t-run-installation-for-sims-4#127400

As that problem is more Downloads related, I'll close this topic now. Please continue updating us in your other topic. Good luck! Very Happy

_________________
"The capital lies before us my friend. What a sombre place it seems and one that holds the answers to many a mystery." - Quirrel.


"Isn't this a wonderful spot for a rest? I so love the sound of the rain upon glass."
avatar
SeoY
Minecraft Moderator
MC Wizard & Keeper of the Realm
Minecraft Moderator MC Wizard & Keeper of the Realm

Windows version :
  • Windows 8
  • Windows 7
  • Windows 10

System architecture :
  • 32 bits (x86)
  • 64 bits (x64)

Favourite games : Hollow Knight, Dishonored, Bioshock Infinite, Bioshock 1-2, The Sims series, Terraria, Metro 2033, Metro: Last Light, Batman: Arkham series, Ōkami, Metal Gear Solid series, The Binding of Isaac, Silent Hill, Ace Attorney, Civilization V, Portal 2, Minecraft
Male Posts : 1726
Points : 3642
Reputation : 298
Join date : 2013-10-12
Age : 21
Location : City of Tears

View user profile

Back to top Go down

View previous topic View next topic Back to top


Permissions in this forum:
You cannot reply to topics in this forum