Sims 4 stop working after create character.

View previous topic View next topic Go down

Sims 4 stop working after create character.

Post by prestongirlz on Fri 14 Nov 2014, 23:08

Hello all !


I have downloaded the game there for a week. Now I installed it , and I also installed the latest updates by following everything literally.

When I start the game, I can create the character but when I want to start the game, the sims 4 stop working.

I put my drivers up to date, I quit avast, I removed the "online" mode, I run the game in administrator mode ... nothing works.

I just saw your solution with the mods in My Documents / Electronic Arts. I delete the folder Sims 4, but when I launch the game with TS4.exe, mods are recreated automatically. So they are automatically included in your installation? How can I do to not create them?

The problem perhaps does not come from?

I also installed the vcredist_x64.exe and vcredist_x86.exe

(vcredist_arm.exe don't work because it's not a valide win32 application)

I have applied the DEP and the 4GB patch, they work fine, but when I run TS4.exe, I have this error "The dynamic library "rld.dll" failed to initialize (E0). So I tried with all of these solutions, without the 4GB patch, and the game stops working when I validate my character and I have to save in the "library".

Sorry for my english, I'm french.

Thank you !


//EDIT


Sorry for double post, nobody has had this problem and found a solution ?

thank you very much !

prestongirlz
Beginner
Beginner

Posts : 3
Points : 1288
Reputation : 0
Join date : 2014-11-14

View user profile

Back to top Go down

Re: Sims 4 stop working after create character.

Post by The_gh0stm4n on Sun 23 Nov 2014, 20:15

@prestongirlz wrote:Hello all !


I have downloaded the game there for a week. Now I installed it , and I also installed the latest updates by following everything literally.

When I start the game, I can create the character but when I want to start the game, the sims 4 stop working.

I put my drivers up to date, I quit avast, I removed the "online" mode, I run the game in administrator mode ... nothing works.

I just saw your solution with the mods in My Documents / Electronic Arts. I delete the folder Sims 4, but when I launch the game with TS4.exe, mods are recreated automatically. So they are automatically included in your installation? How can I do to not create them?

The problem perhaps does not come from?

I also installed the vcredist_x64.exe and vcredist_x86.exe

(vcredist_arm.exe don't work because it's not a valide win32 application)

I have applied the DEP and the 4GB patch, they work fine, but when I run TS4.exe, I have this error "The dynamic library "rld.dll" failed to initialize (E0). So I tried with all of these solutions, without the 4GB patch, and the game stops working when I validate my character and I have to save in the "library".

Sorry for my english, I'm french.

Thank you !


//EDIT


Sorry for double post, nobody has had this problem and found a solution ?

thank you very much !


Hello prestongirlz and welcome,


I'm sorry for the very late reply, and also for the fact that none of the other Helpers/Mods got back to you. As for me, I've been pretty busy as of lately, so I can't get back to all posts (anymore). If you see that nobody is replying, feel free to contact one of the ACTIVE team members (those with recent posting activity) via private messaging, if you don't get a reply within 24 hours of your post. Or use the search function on the forum.

As for your issue, is your computer strong enough for the game ?


//EDIT

Also, it could be that you simply misconfigured your antivirus program or other stuff. Feel free to read up on this tutorial here:
http://games4theworld.bestgoo.com/t18501-unable-to-start-initialization-error-at-startup-fix-2


After you did all of that, please re-apply the latest Ultimate fix for Sims 4, here:
http://games4theworld.bestgoo.com/t18086-the-sims-4-ultimate-fix



Good luck !



//EDIT

And assuming you REALLY followed "literally everything", and your computer IS strong enough, there really isn't much else left to suggest. However, I have avast (Internet Security) myself, and if you configure it correctly, everything should go smooth. Also, I just installed TS4 yesterday on someone else's computer, which had avast too, again with no issues (because I configured it correctly).

The only things left then are that you either missed something or you have other "security"-software too, which interferes with your game.

_________________



Forum Rules // Forum FAQ // All G4TW Downloads // G4TW The Sims 4 Gallery Collection // How YOU can help us seeding!

How to install The Sims Medieval // The Sims 2 overview ! // How to install The Sims 3 // TS3 Expansion install checklist // How to install The Sims 4



You can E-MAIL me about general questions & site navigation. Also, after 24 hours of you posting a topic on the Forum and NOT getting a reply, you can e-mail me for Support as well!



avatar
The_gh0stm4n
VETERAN Moderator
Inspector General & Forum O.G.
VETERAN Moderator Inspector General & Forum O.G.

Windows version :
  • Windows 8
  • Windows 7
  • Windows XP
  • Windows 10

System architecture :
  • 32 bits (x86)
  • 64 bits (x64)

Favourite games : The Sims 3, L.A. Noire, Saints Row, Red Faction, Minecraft, PvZ: Garden Warfare, Team Fortress 2, Overwatch, GTA: San Andreas, GTA V, S.W.A.T. 4, Counter-Strike, Hitman, Borderlands, Fallout, COD, Battlefield, The Binding of Isaac, Military strategy games (Darkest Hour, Hearts of Iron, Arsenal of Democracy, etc.), Enter the Gungeon.
Male Posts : 15864
Points : 21104
Reputation : 2261
Join date : 2012-11-02
Location : Bellisarius Hall

View user profile

Back to top Go down

View previous topic View next topic Back to top


Permissions in this forum:
You cannot reply to topics in this forum