Sims 4 has stopped working

View previous topic View next topic Go down

Sims 4 has stopped working

Post by euggodoy on Mon 22 Dec 2014, 00:25

So, my game was working fine and suddenly one day it started crashing. I have cc and mods so I took them out but the game still crashes, I also tried using the ultimate fix to solve the problem but it still crashes. This is recent btw I've always been playing without problems, I don't know what to do anymore.

euggodoy
Beginner
Beginner

Posts : 4
Points : 1172
Reputation : 0
Join date : 2014-09-13

View user profile

Back to top Go down

Re: Sims 4 has stopped working

Post by stabitha666 on Mon 22 Dec 2014, 02:58

Hello.
Lets see if we can narrow down to the main issue and nip it in the pixelated butt.

- Q: Besides what you have done to your game, have you done anything new to your computer as a whole? Example: Install new games or programs, upgrade something? Downgrade something? Uninstall something?

-Q: Have you updated your graphics card recently from your computers' manufacturer?

Lastly: If you try going here, Someone else had the same issue and it was due to where they installed the Ultimate Fix.
Sims 4 Start up Problems
avatar
stabitha666
Posting Lord
Posting Lord

Windows version :
  • Windows 8
  • Windows 7

System architecture :
  • 64 bits (x64)

Favourite games : Sims 1, 2, & 3, Diablo 1, 2, & 3, Soul Caliber, Mortal Kombat, Super Mario Bros., America Mcgee's Alice, Alice: Madness Returns, Okamiden,Magic: The Gathering,...and other stuffs
Female Posts : 263
Points : 2355
Reputation : 64
Join date : 2012-07-24
Age : 32
Location : San Antonio, Texas

View user profile

Back to top Go down

Re: Sims 4 has stopped working

Post by euggodoy on Mon 22 Dec 2014, 15:49

I haven't touched my computer, I haven't installed anything, it just magically started crashing. By graphic cards you refer to vcredist_x86 and to vp6? Because I already had them installed. The thing is that I don't think that the ultimate fix is the problem because I installed it when the pools came out and it worked fine and when it started crashing I tried installing it again to see if it fixed the problem but it didn't.

euggodoy
Beginner
Beginner

Posts : 4
Points : 1172
Reputation : 0
Join date : 2014-09-13

View user profile

Back to top Go down

Re: Sims 4 has stopped working

Post by The_gh0stm4n on Sun 28 Dec 2014, 21:30

@euggodoy wrote:I haven't touched my computer, I haven't installed anything, it just magically started crashing. By graphic cards you refer to vcredist_x86 and to vp6? Because I already had them installed. The thing is that I don't think that the ultimate fix is the problem because I installed it when the pools came out and it worked fine and when it started crashing I tried installing it again to see if it fixed the problem but it didn't.


//MOVED


Sorry for the late reply, Sad  but see this here:

http://games4theworld.bestgoo.com/t857-the-sims-3-crashes



This here is written for Sims 3, but can you do step #2, and apply the steps to your TS4.exe, in your base game location of Sims 4 ? The file is located in C:\Program files(x86)\Electronic Arts\The Sims 4\Game\Bin. Or C:\Program files(x86)\Origin Games\The Sims 4\Game\Bin if you have a legit game.

After you added that file to the "DEP exceptions", try this:
If your Windows is a 64-bit version AND if your computer has 4 GB of RAM or more, then focus on step #3 of the above guide in particular. Download the "4 GB patch" from here.

http://www.ntcore.com/4gb_patch.php

After downloading, double-click on that 4 GB patch and in the next prompt, choose the TS4.exe in your base game location. Usually, that's C:\Program files(x86)\Electronic Arts\The Sims 4\Game\Bin. Wait for the message "executable successfully patched" and close the 4 GB patch.

If you don't have 4GB of RAM and/or a 32-bit Windows, forget the step.

Now try the game again. Good luck !
avatar
The_gh0stm4n
VETERAN Moderator
Inspector General & Forum O.G.
VETERAN Moderator Inspector General & Forum O.G.

Windows version :
  • Windows 8
  • Windows 7
  • Windows XP
  • Windows 10

System architecture :
  • 32 bits (x86)
  • 64 bits (x64)

Favourite games : The Sims 3, L.A. Noire, Saints Row, Red Faction, Minecraft, Plants vs. Zombies: Garden Warfare, Titanfall, Team Fortress 2, Darkest Hour, GTA V, GTA: San Andreas, S.W.A.T. 4, Counter-Strike, Hitman, Borderlands, Fallout, Dishonored, Call of Duty, Battlefield, The Binding of Isaac: Afterbirth†, Enter the Gungeon.
Male Posts : 14765
Points : 19573
Reputation : 2078
Join date : 2012-11-02
Location : The Situation Room

View user profile

Back to top Go down

Re: Sims 4 has stopped working

Post by euggodoy on Thu 01 Jan 2015, 23:50

Thank you! I'll try it and see what happens!

//EDIT

So I did step 2 and I'm pretty sure I did it okay because I even checked on the video of the Sims 3 to see if I was doing it right. And then I applied the patch to the base game but now I can't even play, when I start it it says "The dynamic library rld.dll failed to initialize (E0)". Maybe I did some of the steps wrong?

(Update) I applied the ultimate fix again and the game worked fine but the problem's still there, after 10 minutes aprox it crashes.

euggodoy
Beginner
Beginner

Posts : 4
Points : 1172
Reputation : 0
Join date : 2014-09-13

View user profile

Back to top Go down

Re: Sims 4 has stopped working

Post by The_gh0stm4n on Tue 20 Jan 2015, 05:07

@euggodoy wrote:Thank you! I'll try it and see what happens!

//EDIT

So I did step 2 and I'm pretty sure I did it okay because I even checked on the video of the Sims 3 to see if I was doing it right. And then I applied the patch to the base game but now I can't even play, when I start it it says "The dynamic library rld.dll failed to initialize (E0)". Maybe I did some of the steps wrong?

(Update) I applied the ultimate fix again and the game worked fine but the problem's still there, after 10 minutes aprox it crashes.


Sorry for the late reply; I've been away for a while. Do you still need help on that ? I don't know why so many people can't get the 4GB patch working - they all get that rld.dll error. Maybe I will look into that issue later on. For now: is your computer strong enough for the game ? Have you heard from the tool "GameBooster" too ? Read up here:

http://dl.razerzone.com/master-guides/RazerGameBooster/GameBoosterOMG-ENG.pdf



Also, try reducing some graphics settings in the options menu (in the game). And try playing in "windowed mode" too !
avatar
The_gh0stm4n
VETERAN Moderator
Inspector General & Forum O.G.
VETERAN Moderator Inspector General & Forum O.G.

Windows version :
  • Windows 8
  • Windows 7
  • Windows XP
  • Windows 10

System architecture :
  • 32 bits (x86)
  • 64 bits (x64)

Favourite games : The Sims 3, L.A. Noire, Saints Row, Red Faction, Minecraft, Plants vs. Zombies: Garden Warfare, Titanfall, Team Fortress 2, Darkest Hour, GTA V, GTA: San Andreas, S.W.A.T. 4, Counter-Strike, Hitman, Borderlands, Fallout, Dishonored, Call of Duty, Battlefield, The Binding of Isaac: Afterbirth†, Enter the Gungeon.
Male Posts : 14765
Points : 19573
Reputation : 2078
Join date : 2012-11-02
Location : The Situation Room

View user profile

Back to top Go down

View previous topic View next topic Back to top


Permissions in this forum:
You cannot reply to topics in this forum