Long loading times and slow/laggy gameplay even after trying numerous fixes

View previous topic View next topic Go down

Long loading times and slow/laggy gameplay even after trying numerous fixes

Post by Hardcoremixer on Sun 01 Feb 2015, 15:55

Hello everyone,

I'm Hardcoremixer and I have a problem with the Sims 3. I've always had a few speed issues with it, because I tried to install too much on my laptop than I should, but never ever were my problems as bad with worlds other than Isla Paradiso than they are now. A few months ago, I decided to uninstall the game completely and only install the base game and 2 expansions, to save some space for other programs (I had about 100GB on my system partition left). The initial loading screen took about 10 - 15 minutes and to load a city took about 45 minutes and there was really, really heavy lagging in-game. 
Of course I tried all things you can read up on online: deleting cache, reducing settings, cleaning the PC out and defragment, make backups and uninstall/reinstall stuff, etc. It reduced the loading time for about 5 to 10 minutes, but that was it. I unsintalled the game completely and simply went on with my life.

2 weeks ago I decided to go back to my previous build (sort of), installing virtually everything I had. I applied all the fixes, deleted what could be deleted, etc. And now the total loading time for both screens, to load up Twinbrook, is always 30 minutes. 5 For the first loading screen and 25 for the second. And although the lag is not AS bad, it's still pretty bad. Almost no animation goes smoothly. Maybe 1 out of 10 do. That bad. CAS loading times are horrible (that may just be the amount of content) and somestimes it takes more than a mniute for textures in my house to load. Everything simply remains white for that long. Sims pop up into the screen after long times, too. The game is pretty much unplayable that way. I was wondering if there's anything else I can do. I heard that merging packages doesnt necessarily work, so I havent tried that solution yet.
My laptop is only 1.5 years old and it hasnt got bad specs imo. It's and MSI, running windows 8.0 (i didnt upgrade), A10-4600M CPU (I believe thats got 4 cores), AMD Radeon HD 7970M 2 GB GDDR5 video card, plus a second video card I dont know the specifics from, only that it doesnt come with its own memory, like the 7970. 2x 4GB RAM and a 750GB 7200rpm HDD. No SSD, sadly. 
Could it be that the computer is already getting too old? It runs modded Skyrim while filming with bandicam in HD pretty well, using the heavy sharpshooters ENB on high quality settings, but it has problems with sims 3?? And not just problems, but pretty bad ones, too. I don't understand how that can be possible.

I was thinking of heat... it seems to heat up more easily than it previously did, but that cant be the only thing wrong. Can it? So basically, I'm at a loss here, I have no idea what the problem is. Maybe you guys can help me out. I will try defragmenting and all that again, though Ido that pretty regularly, so that cant be the problem either. I'll also try removing all my mods, store content and stuff like that and see how it runs then. But I did that before and only installed the core game with 2 expansions back then (late night and university), so Im pretty sceptic. But we'll see. If you guys have any ideas, that'd be awesome Wink

Thanks! 
- Hardcoremixer

Hardcoremixer
Beginner
Beginner

Posts : 3
Points : 1197
Reputation : 0
Join date : 2013-08-29

View user profile

Back to top Go down

Re: Long loading times and slow/laggy gameplay even after trying numerous fixes

Post by The_gh0stm4n on Sun 01 Feb 2015, 17:53

@Hardcoremixer wrote:Hello everyone,

I'm Hardcoremixer and I have a problem with the Sims 3. I've always had a few speed issues with it, because I tried to install too much on my laptop than I should, but never ever were my problems as bad with worlds other than Isla Paradiso than they are now. A few months ago, I decided to uninstall the game completely and only install the base game and 2 expansions, to save some space for other programs (I had about 100GB on my system partition left). The initial loading screen took about 10 - 15 minutes and to load a city took about 45 minutes and there was really, really heavy lagging in-game. 
Of course I tried all things you can read up on online: deleting cache, reducing settings, cleaning the PC out and defragment, make backups and uninstall/reinstall stuff, etc. It reduced the loading time for about 5 to 10 minutes, but that was it. I unsintalled the game completely and simply went on with my life.

2 weeks ago I decided to go back to my previous build (sort of), installing virtually everything I had. I applied all the fixes, deleted what could be deleted, etc. And now the total loading time for both screens, to load up Twinbrook, is always 30 minutes. 5 For the first loading screen and 25 for the second. And although the lag is not AS bad, it's still pretty bad. Almost no animation goes smoothly. Maybe 1 out of 10 do. That bad. CAS loading times are horrible (that may just be the amount of content) and somestimes it takes more than a mniute for textures in my house to load. Everything simply remains white for that long. Sims pop up into the screen after long times, too. The game is pretty much unplayable that way. I was wondering if there's anything else I can do. I heard that merging packages doesnt necessarily work, so I havent tried that solution yet.
My laptop is only 1.5 years old and it hasnt got bad specs imo. It's and MSI, running windows 8.0 (i didnt upgrade), A10-4600M CPU (I believe thats got 4 cores), AMD Radeon HD 7970M 2 GB GDDR5 video card, plus a second video card I dont know the specifics from, only that it doesnt come with its own memory, like the 7970. 2x 4GB RAM and a 750GB 7200rpm HDD. No SSD, sadly. 
Could it be that the computer is already getting too old? It runs modded Skyrim while filming with bandicam in HD pretty well, using the heavy sharpshooters ENB on high quality settings, but it has problems with sims 3?? And not just problems, but pretty bad ones, too. I don't understand how that can be possible.

I was thinking of heat... it seems to heat up more easily than it previously did, but that cant be the only thing wrong. Can it? So basically, I'm at a loss here, I have no idea what the problem is. Maybe you guys can help me out. I will try defragmenting and all that again, though Ido that pretty regularly, so that cant be the problem either. I'll also try removing all my mods, store content and stuff like that and see how it runs then. But I did that before and only installed the core game with 2 expansions back then (late night and university), so Im pretty sceptic. But we'll see. If you guys have any ideas, that'd be awesome Wink

Thanks! 
- Hardcoremixer


Hello Hardcoremixer and welcome to the forum,


Just to be sure, look again at this post here, and delete the cache files I mentioned there:
http://games4theworld.bestgoo.com/t17208-sims-3-has-stopped-working#118442


Beyond that, I experienced the same, before my old HDD died. Everything was laggy as hell, but that was because my hard-drive (and the computer) were a bit old. I eventually scrambled to back up as much as I could from my old data, and then ended up replacing the HDD. Now everything works fine again.


It may be the same for yours too, but let's see. Are you getting similar lag issues in other games/software ? If something was wrong hardware-wise, you would get the lag everywhere probably.

_________________
Regards, The_gh0stm4n




The_gh0stm4n
VETERAN Moderator
Inspector General & Forum O.G.
VETERAN ModeratorInspector General & Forum O.G.

Windows version :
  • Windows 8
  • Windows 7
  • Windows XP
  • Windows 10

System architecture :
  • 32 bits (x86)
  • 64 bits (x64)

Favourite games : The Sims 3, L.A. Noire, Saints Row, Red Faction, Minecraft, Plants vs. Zombies: Garden Warfare, Team Fortress 2, Darkest Hour, GTA: San Andreas, GTA IV, S.W.A.T. 4, Titanfall, Counter-Strike, Hitman: Absolution, Borderlands, Fallout 3 & New Vegas, Dishonored, COD, Battlefield, The Binding of Isaac: Afterbirth.
Male Posts : 12285
Points : 16215
Reputation : 1700
Join date : 2012-11-02
Age : 29
Location : The Situation Room

View user profile

Back to top Go down

Re: Long loading times and slow/laggy gameplay even after trying numerous fixes

Post by Hardcoremixer on Tue 03 Feb 2015, 22:57



Hello Hardcoremixer and welcome to the forum,


Just to be sure, look again at this post here, and delete the cache files I mentioned there:
http://games4theworld.bestgoo.com/t17208-sims-3-has-stopped-working#118442


Beyond that, I experienced the same, before my old HDD died. Everything was laggy as hell, but that was because my hard-drive (and the computer) were a bit old. I eventually scrambled to back up as much as I could from my old data, and then ended up replacing the HDD. Now everything works fine again.


It may be the same for yours too, but let's see. Are you getting similar lag issues in other games/software ? If something was wrong hardware-wise, you would get the lag everywhere probably.

Hello and thank you! I'm pretty busy, so sorry for my late reply. I'll check that page again tomorrow, but scanning the text quickly, it seems like I've tried everything listed there. We'll know for sure tomorrow, though... If I find the time to go through it. But I just cleaned my harddiscs again, scanned for errors, defragmented, scanned for malware, virusses etc and even cleaned the registry (not before I made a backup of it). Also I cooled my laptop a bit extra the entire time and then started the game - while cooling. And Im not sure, but the loading time seemed to only be 20 minutes now, not 30 and the animations were a lot smoother. More like... 7 or 8 out of 10 were great, in stead of 1 out of 10 animations... tested it for 20 minutes only, though. And the rendering of the textures was still kinda slow, but not AS slow as it was before. So it may be heat, it may have been some corrupted registry entries, I'm not sure. Maybe something else entirely. I had 2 PUP malware files on my computer, too. Not sure if they can cause slow-downs. Anyway, sorry for this unstructurized and incorrect-English message, but its quite late in the evening now so I have a sort of an excuse :p Thanks for your help, I will try to get the performance up. I'm thinking it can definately be heat from built up dust as well. It seems to heat up faster than before, too, so it could be A cause. Maybe there are several. I'm just happy that it ran a bit smoother already Very Happy 

Good night!

Hardcoremixer
Beginner
Beginner

Posts : 3
Points : 1197
Reputation : 0
Join date : 2013-08-29

View user profile

Back to top Go down

Re: Long loading times and slow/laggy gameplay even after trying numerous fixes

Post by Sim Architect on Wed 04 Feb 2015, 02:44

Hi! Also, if you'd like, try renaming your Documents\Electronic Arts\The Sims 3 into something else (you can undo this later to have your saves and custom content back) while you are NOT running the game, then open the game and try it, see what happens and let us know.

_________________
Kind regards!

The Sim Architect

It was nice being here. I will be away for a while...


Sim Architect
(A) Child of God (A)
(A) Child of God (A)

Windows version :
  • Windows 10

System architecture :
  • 64 bits (x64)

Male Posts : 1853
Points : 3999
Reputation : 162
Join date : 2012-03-10

View user profile

Back to top Go down

View previous topic View next topic Back to top


Permissions in this forum:
You cannot reply to topics in this forum