Build Item Removed

View previous topic View next topic Go down

Build Item Removed

Post by Valaquent on Thu 19 Mar 2015, 03:01

I am having this error every time I try to load a specific lot in my current save:

Items Removed
One or more items may not be installed on your computer or the Origin account that is currently logged in does not own these items. One build item has been removed.

I am not sure how or why I am getting it, or for that matter what the offending build item is. I'm not very familiar with this lot (he's a minor sim I don't play that often, I don't know his house well), and nothing seems obviously missing.

I did go into Gallery mode just before this happened as well, but I did so from within the game, and I stayed offline the whole time. I wanted to add a different lot to the world that I had gotten from The Sims Resource and had to check the Custom Content box in the advanced menu. This was the first time I have ever done that.

I didn't even log into an Origin account at all, I don't even have Origin installed on this machine, it never has been. I just formatted a few weeks ago, and have had no desire to install it.

I am using the G4tW install; I was running version 1.3.32.1010, and I had just updated my game to version 1.4.83.1010 just before this happened.

I have very little CC, mostly build items and a few articles of clothing and hair, and I don't have any mods.

Am I perhaps misunderstanding this error? What exactly does this mean?

Valaquent
Beginner
Beginner

Windows version :
  • Windows 10

System architecture :
  • 64 bits (x64)

Favourite games : Changes with the wind
Male Posts : 6
Points : 1381
Reputation : 1
Join date : 2014-01-19

View user profile

Back to top Go down

Re: Build Item Removed

Post by The_gh0stm4n on Thu 19 Mar 2015, 06:40

Valaquent wrote:(...)

I did go into Gallery mode just before this happened as well, but I did so from within the game, and I stayed offline the whole time. I wanted to add a different lot to the world that I had gotten from The Sims Resource and had to check the Custom Content box in the advanced menu. This was the first time I have ever done that.

I didn't even log into an Origin account at all, I don't even have Origin installed on this machine, it never has been. I just formatted a few weeks ago, and have had no desire to install it.


Hello and welcome,


I underlined two sentences in my quote. Smile  How can you "go into the gallery from within the game" and at the same time don't have an actual Origin account ? Is that even (technically) possible ? Normally (from my own experiences) it isn't, but OK: I'll take that as it is.

Also, you are only supposed to access the gallery from the main menu, and not from within an actual savegame. Because it will screw up your savefile. See this guide here for more details on that:
http://games4theworld.bestgoo.com/t18195-connecting-to-the-gallery-in-the-sims-4


Next, after you downloaded stuff from the gallery, you should also make sure to completely exit Origin, but since you say you don't even have Origin, let's forget about this for now.

I'm actually unsure what to suggest in your case. But at first, try deleting the folder "The Sims 4", which is located in C:\Users\(your username)\My Documents\Electronic Arts. After that, you un-install the game, and then re-boot the computer.


Next, start over again and re-install the game and re-apply the Ultimate fix. And for the future, keep in mind the gallery guide written by SeoY, which I linked to, before. That is all I can say. Good luck !

_________________
Respectfully,

The_gh0stm4n
G4TW Forum Gatekeeper



avatar
The_gh0stm4n
VETERAN Moderator
Inspector General & Forum O.G.
VETERAN Moderator Inspector General & Forum O.G.

Windows version :
  • Windows 8
  • Windows 7
  • Windows XP
  • Windows 10

System architecture :
  • 32 bits (x86)
  • 64 bits (x64)

Favourite games : The Sims 3, L.A. Noire, Saints Row, Red Faction, Minecraft, Plants vs. Zombies: Garden Warfare, Titanfall, Team Fortress 2, Darkest Hour, GTA V, GTA: San Andreas, S.W.A.T. 4, Counter-Strike, Hitman, Borderlands, Fallout, Dishonored, Call of Duty, Battlefield, The Binding of Isaac: Afterbirth†, Enter the Gungeon.
Male Posts : 14419
Points : 19139
Reputation : 2036
Join date : 2012-11-02
Location : The Situation Room

View user profile

Back to top Go down

Re: Build Item Removed

Post by Valaquent on Thu 19 Mar 2015, 22:40

I didn't log in as I didn't have any need to. I didn't download anything through the gallery, I just used it to be able to access the toggles in the Advanced menu of the My Library section, which you can access without being logged in.

Just to double-check I followed the same steps while writing this. Without being logged into an Origin account, or having Origin installed, and clicking "Stay Offline" you can open the Gallery. Both the Home and My Library tabs are available, but if you click on the Community tab it will come up with a Connection Required box that you can "Stay Offline" out of.

I then toggled off the "Online Access" toggle in the Other section of the Game Options. Then, I shut down the game, and I even double-checked my System Tray and checked my current running Applications and Processes in the Task Manager on the very odd off-chance that somehow, without me knowing it, Origin had been installed on my machine and was running, before restarting my game.

In the end, after I restarted, I didn't have access to the lot in my in-game library when I finally did load my save, and I haven't even placed it as a result. I am assuming I cannot place it without having the Online Access toggled, so I didn't do that.

The downloaded lot came from the TSR site, but would not show up in the in-game Library. All I wanted to be able to do was to allow it to show up so that I could place it.

And, I did access it from the Main Menu, I was following that guide when I did this. When I said "from within the game", I was meaning from the main menu. I was assuming that one can also access it from Origin when I made that statement, but as I haven't used Origin in a couple of years I don't know.

Which brings me back to my last question, am I misunderstanding the reason the message showed up in the first place? None of the DLC I am familiar with seems to be gone, and I still have Granite Falls.

Valaquent
Beginner
Beginner

Windows version :
  • Windows 10

System architecture :
  • 64 bits (x64)

Favourite games : Changes with the wind
Male Posts : 6
Points : 1381
Reputation : 1
Join date : 2014-01-19

View user profile

Back to top Go down

Re: Build Item Removed

Post by The_gh0stm4n on Fri 20 Mar 2015, 20:50

Valaquent wrote:I didn't log in as I didn't have any need to. I didn't download anything through the gallery, I just used it to be able to access the toggles in the Advanced menu of the My Library section, which you can access without being logged in.

Just to double-check I followed the same steps while writing this. Without being logged into an Origin account, or having Origin installed, and clicking "Stay Offline" you can open the Gallery. Both the Home and My Library tabs are available, but if you click on the Community tab it will come up with a Connection Required box that you can "Stay Offline" out of.

I then toggled off the "Online Access" toggle in the Other section of the Game Options. Then, I shut down the game, and I even double-checked my System Tray and checked my current running Applications and Processes in the Task Manager on the very odd off-chance that somehow, without me knowing it, Origin had been installed on my machine and was running, before restarting my game.

In the end, after I restarted, I didn't have access to the lot in my in-game library when I finally did load my save, and I haven't even placed it as a result. I am assuming I cannot place it without having the Online Access toggled, so I didn't do that.

The downloaded lot came from the TSR site, but would not show up in the in-game Library. All I wanted to be able to do was to allow it to show up so that I could place it.

And, I did access it from the Main Menu, I was following that guide when I did this. When I said "from within the game", I was meaning from the main menu. I was assuming that one can also access it from Origin when I made that statement, but as I haven't used Origin in a couple of years I don't know.

Which brings me back to my last question, am I misunderstanding the reason the message showed up in the first place? None of the DLC I am familiar with seems to be gone, and I still have Granite Falls.


Please provide a link to that TSR lot, so that I may test it myself...


//EDIT

Indeed, you must have the "online access"-box ticked, in order for the custom lots (that were putinside the "Tray"-folder) to show up. But I now tried myself a random lot from TSR, and I successfully placed it in the world, without getting any error message whatsoever. I'll keep on looking into this though. 

_________________
Respectfully,

The_gh0stm4n
G4TW Forum Gatekeeper



avatar
The_gh0stm4n
VETERAN Moderator
Inspector General & Forum O.G.
VETERAN Moderator Inspector General & Forum O.G.

Windows version :
  • Windows 8
  • Windows 7
  • Windows XP
  • Windows 10

System architecture :
  • 32 bits (x86)
  • 64 bits (x64)

Favourite games : The Sims 3, L.A. Noire, Saints Row, Red Faction, Minecraft, Plants vs. Zombies: Garden Warfare, Titanfall, Team Fortress 2, Darkest Hour, GTA V, GTA: San Andreas, S.W.A.T. 4, Counter-Strike, Hitman, Borderlands, Fallout, Dishonored, Call of Duty, Battlefield, The Binding of Isaac: Afterbirth†, Enter the Gungeon.
Male Posts : 14419
Points : 19139
Reputation : 2036
Join date : 2012-11-02
Location : The Situation Room

View user profile

Back to top Go down

Re: Build Item Removed

Post by Valaquent on Fri 20 Mar 2015, 23:44

This was the lot, though it sounds like you figured out what you were after already:
http://www.thesimsresource.com/downloads/details/category/sims4-lots-community/title/st.-sim-cathedral/id/1275973/

It may be that it was actually unrelated. As I said, I had just also updated to 1.4.83.1010, and I think that may have been the first time I logged that lot in since. It could have been related to something that happened during the update.

That, and after doing some digging I don't seem to be missing any DLC that I can determine.

Just toggling the Online Access button shouldn't connect to EA, should it?

Oh, and with regard to houses installed the Tray, some will and some won't show up without the Online Access toggled. I think any that don't have any CC will show up either way, but I'm not sure.

Valaquent
Beginner
Beginner

Windows version :
  • Windows 10

System architecture :
  • 64 bits (x64)

Favourite games : Changes with the wind
Male Posts : 6
Points : 1381
Reputation : 1
Join date : 2014-01-19

View user profile

Back to top Go down

View previous topic View next topic Back to top


Permissions in this forum:
You cannot reply to topics in this forum