The play button won't start? On the sims 3

View previous topic View next topic Go down

The play button won't start? On the sims 3

Post by wrolvm3 on Mon 06 Apr 2015, 03:08

Hi, The I recently downloaded a few expansion packs, that were university, island paradise, showtime, supernatural, and into the future...and I already have the base game on origin, and pets, generations, seasons on origin as well. When I open the sims 3 to play it..The start button isnt working..No maps are showing up it wont let me click a new game..All the logos on the sign in frames don't look right...What did I do wrong... Please help  thank you  Smile

wrolvm3
Beginner
Beginner

Posts : 2
Points : 935
Reputation : 0
Join date : 2015-04-05

View user profile

Back to top Go down

Re: The play button won't start? On the sims 3

Post by ☠ ~ Aɳɳ ~ ☠ on Mon 06 Apr 2015, 10:55

Hello,

Have you reinstalled the manual patch? Try thios first.
Dopn't forget to reapply the crack from the fix as well.

_________________
"Under sun and sky, we greet you warmly"

avatar
☠ ~ Aɳɳ ~ ☠
Forum Administratrix
First Lady of the Forum
Forum Administratrix First Lady of the Forum

Windows version :
  • Windows 8
  • Windows XP
  • Windows 10

System architecture :
  • 32 bits (x86)
  • 64 bits (x64)

Female Posts : 15112
Points : 20087
Reputation : 1437
Join date : 2011-05-31

View user profile

Back to top Go down

View previous topic View next topic Back to top


Permissions in this forum:
You cannot reply to topics in this forum