Search Function not Working Properly

View previous topic View next topic Go down

Search Function not Working Properly

Post by D' Eradicated on Sun 03 May 2015, 19:00

This is my first post here, so be gentle. Laughing

As I was trying to search the forums about "silent install", I noticed that the links to the 2nd and the rest of the results page are not working. It leads to a link like this "http://games4theworld.bestgoo.com/search?search_keywords=\".

Dunno if it's just me or it's not yet fully working.

D' Eradicated
Quartermaster Rookie
Making your wishes come true
Quartermaster Rookie Making your wishes come true

Windows version :
  • Windows 10

System architecture :
  • 64 bits (x64)

Favourite games : The Sims Series, Minecraft, Counter-Strike 1.6, The Escapists, I Am Bread, Besiege, SimCity 2000, DotA 1, Dota 2
Male Posts : 205
Points : 1068
Reputation : 69
Join date : 2015-05-03
Age : 21
Location : Philippines

View user profile

Back to top Go down

Re: Search Function not Working Properly

Post by Adwomin on Sun 03 May 2015, 19:46

Hello D' Eradicated,

Thanks for your message.
I checked to see if the same happens to me. I get to this page: http://games4theworld.bestgoo.com/search?search_keywords=silent+install

I checked the first 7 links, and they all work fine for me. Can you give one example of an URL you get redirected too?

_________________
Bonsoir, friend.


~ Nobody's gril. ~
avatar
Adwomin
free society
free society

Windows version :
  • Windows 8
  • Windows 7

System architecture :
  • 32 bits (x86)
  • 64 bits (x64)

Favourite games : GTA Series, Cities: Skylines, Prison Architect, Borderlands series
Female Posts : 19214
Points : 1026294
Reputation : 2242
Join date : 2010-03-12
Age : 15
Location : Del Perro Heights

View user profile https://www.games4theworld.org

Back to top Go down

Re: Search Function not Working Properly

Post by The_gh0stm4n on Mon 04 May 2015, 01:24

@D' Eradicated wrote:This is my first post here, so be gentle. Laughing

As I was trying to search the forums about "silent install", I noticed that the links to the 2nd and the rest of the results page are not working. It leads to a link like this "http://games4theworld.bestgoo.com/search?search_keywords=\".

Dunno if it's just me or it's not yet fully working.

I replied to your other message here:
http://games4theworld.bestgoo.com/t20008-the-sims-3-silent-installation-possible



If you seem to encounter problems with any of the forum's functions, check your internet browser plug-ins or add-ons. Disable them one-by-one and see if that improves anything. Also, try deleting the cookies and/or cache of your browser. Then close the browser and after a little while, re-start it.

Beyond that, the "other links" in the search work fine for me (they don't deal with the question you are having, though). I actually only found one (1) topic about this, and that's the one you made. Keep in mind that in order to use the search function more effectively, try alternative wordings or phrasings of the stuff you are looking for.

"Silent install" is not a very widespread term; most people usually say something different, like "modified installer" or "easy installer". But that is already off-topic I guess...


Tea 5
avatar
The_gh0stm4n
VETERAN Moderator
Inspector General & Forum O.G.
VETERAN Moderator Inspector General & Forum O.G.

Windows version :
  • Windows 8
  • Windows 7
  • Windows XP
  • Windows 10

System architecture :
  • 32 bits (x86)
  • 64 bits (x64)

Favourite games : The Sims 3, L.A. Noire, Saints Row, Red Faction, Minecraft, Plants vs. Zombies: Garden Warfare, Team Fortress 2, Darkest Hour, GTA: San Andreas, S.W.A.T. 4, Titanfall, Counter-Strike, Hitman: Absolution, Borderlands, Fallout, Dishonored, COD, Battlefield, The Binding of Isaac: Afterbirth†
Male Posts : 13760
Points : 18247
Reputation : 1921
Join date : 2012-11-02
Age : 30
Location : San Fierro

View user profile

Back to top Go down

Re: Search Function not Working Properly

Post by D' Eradicated on Mon 04 May 2015, 02:10

It seems like I found a loophole.  Laughing

If you try to search "silent install" (including quotation marks, since I tried to search Google style), the other pages other than the first doesn't work.



At the bottom-left corner of the image, you can see the link when I hover over the number "2" link.

POSSIBLE SOLUTION: Always strip special characters from search boxes because it sometimes screws up querying from the database. Carlos is tha man!!!

_________________

Programmer, Gamer, Anime Lover, Sims Player
Having problems with your The Sims installation, etc? Post a thread so that we can fix it together.
Have you requested a game here? Check here if I fulfilled your request. No promises, though.

D' Eradicated
Quartermaster Rookie
Making your wishes come true
Quartermaster Rookie Making your wishes come true

Windows version :
  • Windows 10

System architecture :
  • 64 bits (x64)

Favourite games : The Sims Series, Minecraft, Counter-Strike 1.6, The Escapists, I Am Bread, Besiege, SimCity 2000, DotA 1, Dota 2
Male Posts : 205
Points : 1068
Reputation : 69
Join date : 2015-05-03
Age : 21
Location : Philippines

View user profile

Back to top Go down

Re: Search Function not Working Properly

Post by Adwomin on Mon 04 May 2015, 12:58

Hi there,

Conclusion: don't try to search Google style on the Games4theworld Forum. Razz
I've tried "silent install" (with quotation marks) myself, and the links I checked worked just fine.
Try clearing all your Forum cookies: http://games4theworld.bestgoo.com/?mode=delete_cookies , and then try the "silent install" with quotation marks again.
I'd like to know if that helps.

_________________
Bonsoir, friend.


~ Nobody's gril. ~
avatar
Adwomin
free society
free society

Windows version :
  • Windows 8
  • Windows 7

System architecture :
  • 32 bits (x86)
  • 64 bits (x64)

Favourite games : GTA Series, Cities: Skylines, Prison Architect, Borderlands series
Female Posts : 19214
Points : 1026294
Reputation : 2242
Join date : 2010-03-12
Age : 15
Location : Del Perro Heights

View user profile https://www.games4theworld.org

Back to top Go down

Re: Search Function not Working Properly

Post by The_gh0stm4n on Wed 06 May 2015, 00:54

@D' Eradicated wrote:(...) since I tried to search Google style.


Interesting, if it's really a glitch (though I can't be bothered right now to test it myself), but why would you want to search "Google style" anyway here ? Smile  From a practical viewpoint, there is no need for that. Unless of course, you are doing this for some sort of research project or something...
avatar
The_gh0stm4n
VETERAN Moderator
Inspector General & Forum O.G.
VETERAN Moderator Inspector General & Forum O.G.

Windows version :
  • Windows 8
  • Windows 7
  • Windows XP
  • Windows 10

System architecture :
  • 32 bits (x86)
  • 64 bits (x64)

Favourite games : The Sims 3, L.A. Noire, Saints Row, Red Faction, Minecraft, Plants vs. Zombies: Garden Warfare, Team Fortress 2, Darkest Hour, GTA: San Andreas, S.W.A.T. 4, Titanfall, Counter-Strike, Hitman: Absolution, Borderlands, Fallout, Dishonored, COD, Battlefield, The Binding of Isaac: Afterbirth†
Male Posts : 13760
Points : 18247
Reputation : 1921
Join date : 2012-11-02
Age : 30
Location : San Fierro

View user profile

Back to top Go down

Re: Search Function not Working Properly

Post by D' Eradicated on Wed 06 May 2015, 15:45

Carlos wrote:
@D' Eradicated wrote:(...) since I tried to search Google style.


Interesting, if it's really a glitch (though I can't be bothered right now to test it myself), but why would you want to search "Google style" anyway here ? Smile  From a practical viewpoint, there is no need for that. Unless of course, you are doing this for some sort of research project or something...

Because searching 'silent install' without quotes gives me threads about installation problems.  Very Happy

Either way, tried searching other terms enclosed in quotation marks. The links to the 2nd, 3rd, etc. pages are still broken.

D' Eradicated
Quartermaster Rookie
Making your wishes come true
Quartermaster Rookie Making your wishes come true

Windows version :
  • Windows 10

System architecture :
  • 64 bits (x64)

Favourite games : The Sims Series, Minecraft, Counter-Strike 1.6, The Escapists, I Am Bread, Besiege, SimCity 2000, DotA 1, Dota 2
Male Posts : 205
Points : 1068
Reputation : 69
Join date : 2015-05-03
Age : 21
Location : Philippines

View user profile

Back to top Go down

Re: Search Function not Working Properly

Post by Adwomin on Thu 07 May 2015, 17:38

Hi there,

Have you tried clearing your Forum cookies, as suggested?
I've searched for 'silent install' and the pages and topics seems to load just fine when I click them.
Try this for page 2: http://games4theworld.bestgoo.com/search?search_keywords=silent%20install&start=50
And page 3: http://games4theworld.bestgoo.com/search?search_keywords=silent%20install&start=100
Page 4: http://games4theworld.bestgoo.com/search?search_keywords=silent%20install&start=150
(As you can see from the link/database, each page has 50 results - not that it matters)

But from what I understand, it works for you without the quotation marks? If so, then the solutions are as follows:

1. Don't use "Google style".
2. Report bug here: http://help.forumotion.com/f46-other-problems

_________________
Bonsoir, friend.


~ Nobody's gril. ~
avatar
Adwomin
free society
free society

Windows version :
  • Windows 8
  • Windows 7

System architecture :
  • 32 bits (x86)
  • 64 bits (x64)

Favourite games : GTA Series, Cities: Skylines, Prison Architect, Borderlands series
Female Posts : 19214
Points : 1026294
Reputation : 2242
Join date : 2010-03-12
Age : 15
Location : Del Perro Heights

View user profile https://www.games4theworld.org

Back to top Go down

Re: Search Function not Working Properly

Post by The_gh0stm4n on Sat 09 May 2015, 05:04

@D' Eradicated wrote:(...) because searching 'silent install' without quotes gives me threads about installation problems.   


What I actually meant before was why you would want to use the internet browser URL mask for searching stuff, if you can also use the built-in search form...? Smile  See this here:










Also note that if you want to be more precise about your query, use the appropriate option under Search for keywords. If you use the option "Search for any terms or use query as entered", the query will seemingly pick up all results that contain either "silent" or "install"

If you accordingly choose "Search for all terms", you will get results that contain both "silent" and "install". Which is what you wanted in the first place. And yes, you will only get general installation problems in that whole search because - as I hinted before - "silent install" is a very unusual term for the thing that you mean. Most people will refer to the issue as modified installer, or something similar.

But OK, in the event you really want do to a "Google style" search, you'll need to do it this way:


1)
http://games4theworld.bestgoo.com/search?search_keywords=silent+install&search_terms=any

This URL 'command' will bring up results for either "silent" or "install".



2)
http://games4theworld.bestgoo.com/search?search_keywords=silent+install&search_terms=all

And this one will bring up BOTH "silent" and "install", which is what you wanted originally. Here you won't get any results because nobody has seemingly used this specific term on the forum yet. I can't tell why you need to add the &search_terms=* but I guess this is the way the forum software here works (I never tried that in Google though, nor can I be bothered, lol). Of course, you could still fine-tune the search further by adding additional search parameters in the URL search mask, by adding & plus the appropriate search filter command, in the URL mask. But at that point, I do not need to tell you (hopefully) that this way of searching is highly unpractical. The only relevance I see in that is - again as I hinted before - if you want to do research for some computer science course or something like that. 

Back to topic: as you can see, you are NOT supposed to enclose the search terms in quotation marks. Probably this is just how the forum software works.


Hope this clears things up a bit. Smile 
avatar
The_gh0stm4n
VETERAN Moderator
Inspector General & Forum O.G.
VETERAN Moderator Inspector General & Forum O.G.

Windows version :
  • Windows 8
  • Windows 7
  • Windows XP
  • Windows 10

System architecture :
  • 32 bits (x86)
  • 64 bits (x64)

Favourite games : The Sims 3, L.A. Noire, Saints Row, Red Faction, Minecraft, Plants vs. Zombies: Garden Warfare, Team Fortress 2, Darkest Hour, GTA: San Andreas, S.W.A.T. 4, Titanfall, Counter-Strike, Hitman: Absolution, Borderlands, Fallout, Dishonored, COD, Battlefield, The Binding of Isaac: Afterbirth†
Male Posts : 13760
Points : 18247
Reputation : 1921
Join date : 2012-11-02
Age : 30
Location : San Fierro

View user profile

Back to top Go down

View previous topic View next topic Back to top


Permissions in this forum:
You cannot reply to topics in this forum