Problems Getting GTW to 'activate'.

View previous topic View next topic Go down

Problems Getting GTW to 'activate'.

Post by LunaticLenny on Fri 12 Jun 2015, 22:33

I terribly sorry for starting a thread to ask this, but I've searched all over the fourm and haven't found a solution.

So whenever I start up my game after I've transferred the files in the correct folder I see there's no evidence of the expansion pack being 'installed'. 
I made sure my anti virus programs were shut off and that orgin wasn't running, but still the game says I have to activate my game in order to play GTW expansion.

I've tried applying the ultimate fix too, but no changes I can see.

There's probably something i'm not doing correctly and such, but I have no idea.

Thank you for any help you can provide.

Edit: I case it's a problem, I didn't download any of the other expansion packs.

LunaticLenny
Beginner
Beginner

Posts : 5
Points : 721
Reputation : 0
Join date : 2015-06-12

View user profile

Back to top Go down

Re: Problems Getting GTW to 'activate'.

Post by SeoY on Sat 13 Jun 2015, 00:52

Hi there, @LunaticLenny, and welcome to the Games4theworld Forum! Very Happy

Sorry, but what does the error you are getting say exactly? Some screenshots would help us understand what you mean.
Have you tried applying the Ultimate Fix and see if there's any improvements? You can find it here:
http://games4theworld.bestgoo.com/t18086-the-sims-4-ultimate-fix#

Instructions are included. Please, apply it and let us know how it goes. Good luck!

_________________
"The capital lies before us my friend. What a sombre place it seems and one that holds the answers to many a mystery." - Quirrel.


"Isn't this a wonderful spot for a rest? I so love the sound of the rain upon glass."
avatar
SeoY
Minecraft Moderator
MC Wizard & Keeper of the Realm
Minecraft Moderator MC Wizard & Keeper of the Realm

Windows version :
  • Windows 8
  • Windows 7
  • Windows 10

System architecture :
  • 32 bits (x86)
  • 64 bits (x64)

Favourite games : Hollow Knight, Dishonored, Bioshock Infinite, Bioshock 1-2, The Sims series, Terraria, Metro 2033, Metro: Last Light, Batman: Arkham series, Ōkami, Metal Gear Solid series, The Binding of Isaac, Silent Hill, Ace Attorney, Civilization V, Portal 2, Minecraft
Male Posts : 1724
Points : 3548
Reputation : 298
Join date : 2013-10-12
Age : 21
Location : City of Tears

View user profile

Back to top Go down

Re: Problems Getting GTW to 'activate'.

Post by LunaticLenny on Sat 13 Jun 2015, 19:08

@SeoY wrote:Hi there, @LunaticLenny, and welcome to the Games4theworld Forum! Very Happy

Sorry, but what does the error you are getting say exactly? Some screenshots would help us understand what you mean.
Have you tried applying the Ultimate Fix and see if there's any improvements? You can find it here:
http://games4theworld.bestgoo.com/t18086-the-sims-4-ultimate-fix#

Instructions are included. Please, apply it and let us know how it goes. Good luck!
I haven't been getting any error messages at all, just whenever i open the game after inserting the GTW files into the sims 4 folder it doesn't show any changes that have been made except that the sims pack button at the top of the screen starts flashing and stuff.
So when I click the button they say I have to be online to active the expansion, I click the button to go online and then it says that I have to register the game in order to access online.
Here's the screenshots: 
So first I click this flashing button: 

Then this appears:

Then when i hit connect this happens:


So am I not supposed to do that? If so then what is the proper way to install it? Im pretty sure followed all the steps correctly.

LunaticLenny
Beginner
Beginner

Posts : 5
Points : 721
Reputation : 0
Join date : 2015-06-12

View user profile

Back to top Go down

Re: Problems Getting GTW to 'activate'.

Post by SeoY on Sat 13 Jun 2015, 19:34

@LunaticLenny wrote:I haven't been getting any error messages at all, just whenever i open the game after inserting the GTW files into the sims 4 folder it doesn't show any changes that have been made except that the sims pack button at the top of the screen starts flashing and stuff.
So when I click the button they say I have to be online to active the expansion, I click the button to go online and then it says that I have to register the game in order to access online.
Here's the screenshots: 
So first I click this flashing button: 

Then this appears:

Then when i hit connect this happens:


So am I not supposed to do that? If so then what is the proper way to install it? Im pretty sure followed all the steps correctly.

Hi again!

Indeed, there's no need to do what you are doing. The Expansion Packs (or any Packs in the game for that matter) don't need to be 'activated' in any form. You just have to install the Expansion Pack properly, apply the Ultimate Fix and make sure that Origin is completely closed (as it will remove all of the DLC from the game). The Expansion Pack content should appear properly in your game now without any more steps.

Are you sure that the Expansion Pack is not appearing in your game, and that Origin is closed (not even in Offline mode)? You may want to try installing the Expansion Pack again and re-applying the Ultimate Fix to see if anything changes. Please, let us know how it goes. Good luck! Very Happy

_________________
"The capital lies before us my friend. What a sombre place it seems and one that holds the answers to many a mystery." - Quirrel.


"Isn't this a wonderful spot for a rest? I so love the sound of the rain upon glass."
avatar
SeoY
Minecraft Moderator
MC Wizard & Keeper of the Realm
Minecraft Moderator MC Wizard & Keeper of the Realm

Windows version :
  • Windows 8
  • Windows 7
  • Windows 10

System architecture :
  • 32 bits (x86)
  • 64 bits (x64)

Favourite games : Hollow Knight, Dishonored, Bioshock Infinite, Bioshock 1-2, The Sims series, Terraria, Metro 2033, Metro: Last Light, Batman: Arkham series, Ōkami, Metal Gear Solid series, The Binding of Isaac, Silent Hill, Ace Attorney, Civilization V, Portal 2, Minecraft
Male Posts : 1724
Points : 3548
Reputation : 298
Join date : 2013-10-12
Age : 21
Location : City of Tears

View user profile

Back to top Go down

Re: Problems Getting GTW to 'activate'.

Post by LunaticLenny on Sat 13 Jun 2015, 22:19

@SeoY wrote:
Hi again!

Indeed, there's no need to do what you are doing. The Expansion Packs (or any Packs in the game for that matter) don't need to be 'activated' in any form. You just have to install the Expansion Pack properly, apply the Ultimate Fix and make sure that Origin is completely closed (as it will remove all of the DLC from the game). The Expansion Pack content should appear properly in your game now without any more steps.

Are you sure that the Expansion Pack is not appearing in your game, and that Origin is closed (not even in Offline mode)? You may want to try installing the Expansion Pack again and re-applying the Ultimate Fix to see if anything changes. Please, let us know how it goes. Good luck! Very Happy
Ok, so i cut off my internet connection and reinstalled the pack and applied the ultimate fix again, but nothing has changed. I closed Origin completely as well.When i launch the game it takes longer than usual to load, but it still shows the normal menu and there's no new content in game.

LunaticLenny
Beginner
Beginner

Posts : 5
Points : 721
Reputation : 0
Join date : 2015-06-12

View user profile

Back to top Go down

Re: Problems Getting GTW to 'activate'.

Post by LunaticLenny on Mon 15 Jun 2015, 01:56

So rather than deleting my posts can you please answer me?

LunaticLenny
Beginner
Beginner

Posts : 5
Points : 721
Reputation : 0
Join date : 2015-06-12

View user profile

Back to top Go down

Re: Problems Getting GTW to 'activate'.

Post by SeoY on Mon 15 Jun 2015, 03:36

@LunaticLenny wrote:So rather than deleting my posts can you please answer me?

I'm sorry, but I haven't deleted anything. Please don't assume things, especially when there is no reason for anyone to delete any posts that you have made here (if you have exclusively posted here about this problem).

Now, how exactly did you install the Expansion Pack? Where did you copy the files exactly? And did you make sure to extract the RAR file using WinRAR only? Any other programs may damage the files and cause problems.
Look into your installation folder, and check that the EP01 folder is indeed there. All of the files should be the same from the one inside the RAR file.

Please, let us know how it goes. Good luck!

_________________
"The capital lies before us my friend. What a sombre place it seems and one that holds the answers to many a mystery." - Quirrel.


"Isn't this a wonderful spot for a rest? I so love the sound of the rain upon glass."
avatar
SeoY
Minecraft Moderator
MC Wizard & Keeper of the Realm
Minecraft Moderator MC Wizard & Keeper of the Realm

Windows version :
  • Windows 8
  • Windows 7
  • Windows 10

System architecture :
  • 32 bits (x86)
  • 64 bits (x64)

Favourite games : Hollow Knight, Dishonored, Bioshock Infinite, Bioshock 1-2, The Sims series, Terraria, Metro 2033, Metro: Last Light, Batman: Arkham series, Ōkami, Metal Gear Solid series, The Binding of Isaac, Silent Hill, Ace Attorney, Civilization V, Portal 2, Minecraft
Male Posts : 1724
Points : 3548
Reputation : 298
Join date : 2013-10-12
Age : 21
Location : City of Tears

View user profile

Back to top Go down

Re: Problems Getting GTW to 'activate'.

Post by LunaticLenny on Sun 21 Jun 2015, 13:15

@SeoY wrote:
I'm sorry, but I haven't deleted anything. Please don't assume things, especially when there is no reason for anyone to delete any posts that you have made here (if you have exclusively posted here about this problem).

Now, how exactly did you install the Expansion Pack? Where did you copy the files exactly? And did you make sure to extract the RAR file using WinRAR only? Any other programs may damage the files and cause problems.
Look into your installation folder, and check that the EP01 folder is indeed there. All of the files should be the same from the one inside the RAR file.

Please, let us know how it goes. Good luck!

Sorry, I apologize for getting a bit testy. 

I installed the expansion pack in the Electron Arts folder within the Program Files(x86) folder, I did use WinRaR to extract them, and the EP01 folder is there.

LunaticLenny
Beginner
Beginner

Posts : 5
Points : 721
Reputation : 0
Join date : 2015-06-12

View user profile

Back to top Go down

Re: Problems Getting GTW to 'activate'.

Post by The_gh0stm4n on Wed 24 Jun 2015, 03:13

@LunaticLenny wrote:
Sorry, I apologize for getting a bit testy. 

I installed the expansion pack in the Electron Arts folder within the Program Files(x86) folder, I did use WinRaR to extract them, and the EP01 folder is there.


Are you absolutely sure that you applied the files from "Get to Work" AT FIRST ? And then you should apply the files from the latest available "Ultimate fix". This order of installation is very crucial, and it seems that a lot of people mess up on that.

Also, do not just copy individual files or folders from the downloads. Again, take the WHOLE "Get to Work" expansion, and copy ALL files & folders from there to the game install location. When prompted, replace all existing files/folders. After you did that, repeat the procedure, with the latest Ultimate fix.

Good luck !


P.S. if you find that messages of you were getting deleted, there is ALWAYS a reason behind it. Mostly it's because people double-post/bump, or they posted in a forum section where questions are not allowed, like the "Fixes"-sections. Did you do any of these ?
avatar
The_gh0stm4n
VETERAN Moderator
Inspector General & Forum O.G.
VETERAN Moderator Inspector General & Forum O.G.

Windows version :
  • Windows 8
  • Windows 7
  • Windows XP
  • Windows 10

System architecture :
  • 32 bits (x86)
  • 64 bits (x64)

Favourite games : The Sims 3, L.A. Noire, Saints Row, Red Faction, Minecraft, Plants vs. Zombies: Garden Warfare, Team Fortress 2, Darkest Hour, GTA: San Andreas, GTA IV, S.W.A.T. 4, Titanfall, Counter-Strike, Hitman: Absolution, Borderlands, Fallout, Dishonored, COD, Battlefield, The Binding of Isaac: Antibirth & Afterbirth†
Male Posts : 13689
Points : 18101
Reputation : 1906
Join date : 2012-11-02
Age : 30
Location : The Situation Room

View user profile

Back to top Go down

View previous topic View next topic Back to top


Permissions in this forum:
You cannot reply to topics in this forum