Sims 4 Mods Question

View previous topic View next topic Go down

Sims 4 Mods Question

Post by Keyenpeydee on Sun 28 Jun 2015, 03:15

Okay after 1 or 2 months not asking a Question (and luckily I haven't encountered any problems from the game)


So here is my Question, 


Is an updated mod (The Mod which is updated to the latest version of the game) can work without having your game updated to the latest game version? I mean They created it with patch 1.8 and we have 1.7 of the game, do you think it will work?


Yes I know, some custom contents are made with the latest game version and I can see that they didn't work for the outdated game version. But are this cc are similar to some mod which is made with the latest game version? 


Thank you and Goodbye.
avatar
Keyenpeydee
Posting Lord
Posting Lord

Windows version :
  • Windows 10

System architecture :
  • 64 bits (x64)

Favourite games : The Sims 4, The Sims 3, The Sims 4, The Sims 3, The Sims 4, The Sims 3, The Sims 4, The Sims 3,
Male Posts : 242
Points : 1265
Reputation : 2
Join date : 2015-01-28
Age : 24

View user profile

Back to top Go down

Re: Sims 4 Mods Question

Post by The_gh0stm4n on Sun 28 Jun 2015, 03:20

@Keyenpeydee wrote:Okay after 1 or 2 months not asking a Question (and luckily I haven't encountered any problems from the game)


So here is my Question, 


Is an updated mod (The Mod which is updated to the latest version of the game) can work without having your game updated to the latest game version? I mean They created it with patch 1.8 and we have 1.7 of the game, do you think it will work?


Yes I know, some custom contents are made with the latest game version and I can see that they didn't work for the outdated game version. But are this cc are similar to some mod which is made with the latest game version? 


Thank you and Goodbye.


Hello,


Unless the creator of the mod has explicitly stated that the mod is "backward compatible" (i.e. you can use it for an "earlier" patch level too), you should ONLY use the mod for the patch level that is given in the description.


Maybe you are lucky and the mod will still work for the older patch level somehow, but I cannot recommend you doing that. Of course, everything else is up to you, in the end. Good luck !
avatar
The_gh0stm4n
VETERAN Moderator
Inspector General & Forum O.G.
VETERAN Moderator Inspector General & Forum O.G.

Windows version :
  • Windows 8
  • Windows 7
  • Windows XP
  • Windows 10

System architecture :
  • 32 bits (x86)
  • 64 bits (x64)

Favourite games : The Sims 3, L.A. Noire, Saints Row, Red Faction, Minecraft, Plants vs. Zombies: Garden Warfare, Titanfall, Team Fortress 2, Darkest Hour, GTA: San Andreas, S.W.A.T. 4, Counter-Strike, Hitman, Borderlands, Fallout, Dishonored, Call of Duty, Battlefield, The Binding of Isaac: Afterbirth†
Male Posts : 14101
Points : 18708
Reputation : 1989
Join date : 2012-11-02
Age : 30
Location : San Fierro

View user profile

Back to top Go down

View previous topic View next topic Back to top


Permissions in this forum:
You cannot reply to topics in this forum