Graphics Problem : Sims Medieval Pirates and Nobles. [SOLVED]

View previous topic View next topic Go down

Graphics Problem : Sims Medieval Pirates and Nobles. [SOLVED]

Post by rainbowdork on Sun 18 Sep 2011, 21:27

First of all, I have searched the topics before posting. I thought I had found what was wrong but in the end it didn't help.

The scenario:

I downloaded the Sims Medieval from here when it first came out and I've never had any problems. Today I downloaded the expansion, also from here. When I play the game, and get past the ambition screen everything is brown. You can make out the click-able "bubbles" for all the building hubs but everything else is just brown.

At first I thought it was an error in how I had downloaded or cracked the games. I found a thread that told someone to uninstall everything, then install the base game without cracking and also the expansion, then update and THEN crack with the latest fix.

I did this thinking it would help but when I went back in game everything was the same. I thought perhaps it would go away if I actually decided to do a quest. On starting a quest it shows the building my sim is in but nothing else, no hills or background, trees or anything just brown Smile

What is wrong with my game? Razz I can't figure out what I have done wrong!! Please help Smile

rainbowdork
Beginner
Beginner

Posts : 3
Points : 2229
Reputation : 0
Join date : 2011-09-18

View user profile

Back to top Go down

Re: Graphics Problem : Sims Medieval Pirates and Nobles. [SOLVED]

Post by ☠ ~ Aɳɳ ~ ☠ on Mon 19 Sep 2011, 11:36

Hello,
Is your graphicscard up to date?

_________________
"Under sun and sky, we greet you warmly"

avatar
☠ ~ Aɳɳ ~ ☠
Forum Administratrix
First Lady of the Forum
Forum Administratrix First Lady of the Forum

Windows version :
  • Windows 8
  • Windows XP
  • Windows 10

System architecture :
  • 32 bits (x86)
  • 64 bits (x64)

Female Posts : 15112
Points : 20087
Reputation : 1437
Join date : 2011-05-31

View user profile

Back to top Go down

Re: Graphics Problem : Sims Medieval Pirates and Nobles. [SOLVED]

Post by rainbowdork on Mon 19 Sep 2011, 20:58

I went and updated my driver and its still the same Sad

rainbowdork
Beginner
Beginner

Posts : 3
Points : 2229
Reputation : 0
Join date : 2011-09-18

View user profile

Back to top Go down

Re: Graphics Problem : Sims Medieval Pirates and Nobles. [SOLVED]

Post by ☠ ~ Aɳɳ ~ ☠ on Tue 20 Sep 2011, 09:33

Hello,
What about changing the video options, try lowering the quality settings, the screen resolution, or playing in windowed mode.
What strikes me as odd is that your game worked fine before installing the expansion. Maybe Admin can also give you some suggestions.

_________________
"Under sun and sky, we greet you warmly"

avatar
☠ ~ Aɳɳ ~ ☠
Forum Administratrix
First Lady of the Forum
Forum Administratrix First Lady of the Forum

Windows version :
  • Windows 8
  • Windows XP
  • Windows 10

System architecture :
  • 32 bits (x86)
  • 64 bits (x64)

Female Posts : 15112
Points : 20087
Reputation : 1437
Join date : 2011-05-31

View user profile

Back to top Go down

Re: Graphics Problem : Sims Medieval Pirates and Nobles. [SOLVED]

Post by rainbowdork on Tue 20 Sep 2011, 11:35

Yes that's what I found so strange. I might uninstall everything and try playing with the base game to see - then we can rule out that its that.

But yes I will try the options, I already play in windowed mode - it's just strange because my computer is quite high spec.


EDIT: It seems to be fixed. I changed the resolution and for some reason that seems to have done it. It now works in windowed and normal mode as long as the resolution is higher.

Thanks for all the help Smile

Mod edit: Problem solved, topic closed.
You're welcome!!

- Lady ElDi

rainbowdork
Beginner
Beginner

Posts : 3
Points : 2229
Reputation : 0
Join date : 2011-09-18

View user profile

Back to top Go down

View previous topic View next topic Back to top


Permissions in this forum:
You cannot reply to topics in this forum