TS4 not working, solutions?

View previous topic View next topic Go down

TS4 not working, solutions?

Post by qkrwndud on Wed 12 Aug 2015, 16:59

Hi, I downloaded TS4 couple days ago from PB. After the setup was completed I went ahead to launch the game but i got the "rld.dll" failed to load problem so I went to go dld the Sims 4 Ultimate fix, but after that installation process, I am still getting that error.

I've excluded the sims 4 files from Norton and everything but it still won't work Sad

Is there another solution to this problem or should I uninstall the game and re-download the game from this site?

qkrwndud
Beginner
Beginner

Posts : 4
Points : 661
Reputation : 0
Join date : 2015-08-12

View user profile

Back to top Go down

Re: TS4 not working, solutions?

Post by SeoY on Wed 12 Aug 2015, 23:38

Hi there, @qkrwndud, and welcome to the Games4theworld Forum! Very Happy

What exactly is the error that you are getting? Is it E0, E1103 or E1104?
Did you make sure to add all of the folders mentioned on this topic here?
http://games4theworld.bestgoo.com/t18422-the-dynamic-library-rld-dll-failed-to-initialize-e0-error-fix#

What version of Norton do you have exactly? And are you sure you don't have any other security programs installed on your PC?

There's no need to re-download the game, but it may be good to re-download and re-apply the Ultimate Fix with your antivirus temporarily disabled.

Please, let us know how it goes. Good luck!

_________________
"The capital lies before us my friend. What a sombre place it seems and one that holds the answers to many a mystery." - Quirrel.


"Isn't this a wonderful spot for a rest? I so love the sound of the rain upon glass."
avatar
SeoY
Minecraft Moderator
MC Wizard & Keeper of the Realm
Minecraft Moderator MC Wizard & Keeper of the Realm

Windows version :
  • Windows 8
  • Windows 7
  • Windows 10

System architecture :
  • 32 bits (x86)
  • 64 bits (x64)

Favourite games : Hollow Knight, Dishonored, Bioshock Infinite, Bioshock 1-2, The Sims series, Terraria, Metro 2033, Metro: Last Light, Batman: Arkham series, Ōkami, Metal Gear Solid series, The Binding of Isaac, Silent Hill, Ace Attorney, Civilization V, Portal 2, Minecraft
Male Posts : 1724
Points : 3550
Reputation : 298
Join date : 2013-10-12
Age : 21
Location : City of Tears

View user profile

Back to top Go down

Re: TS4 not working, solutions?

Post by qkrwndud on Thu 13 Aug 2015, 18:26

Thank you for replying to me!

I think it's the E0 error since it's saying "the antivirus software is not false-detecting the file" I have disabled my Norton (which is the latest version I think!) and checked if there are other antivirus, also I have re-downloaded and reapplied the ultimate fix but it is still giving me the same error T_T

But I think there is one problem that I encountered though; in the installation guide of the Ultimate Fix, in step 2 I can't seem to find "vc/vc2013redist" navigation in the "_Installer" folder WhatDidUJustCallMe? So I skipped that step .. could that be the cause of the problem? ><

qkrwndud
Beginner
Beginner

Posts : 4
Points : 661
Reputation : 0
Join date : 2015-08-12

View user profile

Back to top Go down

Re: TS4 not working, solutions?

Post by SeoY on Thu 13 Aug 2015, 18:34

@qkrwndud wrote:Thank you for replying to me!

I think it's the E0 error since it's saying "the antivirus software is not false-detecting the file" I have disabled my Norton (which is the latest version I think!) and checked if there are other antivirus, also I have re-downloaded and reapplied the ultimate fix but it is still giving me the same error T_T

But I think there is one problem that I encountered though; in the installation guide of the Ultimate Fix, in step 2 I can't seem to find "vc/vc2013redist" navigation in the "_Installer" folder WhatDidUJustCallMe? So I skipped that step .. could that be the cause of the problem? ><

The error is saying that? Please post the whole error message, it's better for troubleshooting the issue.

And did you disable Norton completely? The real-time protection and automatic scans.

What is the exact path where you are looking for the files? It should be in Program Files (x86)\Electronic Arts\The Sims 4\__Installer\vc\vc2013\redist. It's important that they are installed, yes, and could very be causing the problem.

Please, let us know how it goes. Good luck! Very Happy

_________________
"The capital lies before us my friend. What a sombre place it seems and one that holds the answers to many a mystery." - Quirrel.


"Isn't this a wonderful spot for a rest? I so love the sound of the rain upon glass."
avatar
SeoY
Minecraft Moderator
MC Wizard & Keeper of the Realm
Minecraft Moderator MC Wizard & Keeper of the Realm

Windows version :
  • Windows 8
  • Windows 7
  • Windows 10

System architecture :
  • 32 bits (x86)
  • 64 bits (x64)

Favourite games : Hollow Knight, Dishonored, Bioshock Infinite, Bioshock 1-2, The Sims series, Terraria, Metro 2033, Metro: Last Light, Batman: Arkham series, Ōkami, Metal Gear Solid series, The Binding of Isaac, Silent Hill, Ace Attorney, Civilization V, Portal 2, Minecraft
Male Posts : 1724
Points : 3550
Reputation : 298
Join date : 2013-10-12
Age : 21
Location : City of Tears

View user profile

Back to top Go down

Re: TS4 not working, solutions?

Post by qkrwndud on Fri 14 Aug 2015, 18:10

I've temporary disabled norton for now so I hope it works! but I can't find vc\vc2013\redist... here's a screencap of the __Installer folder 



i've also typed in the \vc\vc2013\redist in the url but the file did not show up >_<

qkrwndud
Beginner
Beginner

Posts : 4
Points : 661
Reputation : 0
Join date : 2015-08-12

View user profile

Back to top Go down

Re: TS4 not working, solutions?

Post by SeoY on Fri 14 Aug 2015, 18:17

@qkrwndud wrote:I've temporary disabled norton for now so I hope it works! but I can't find vc\vc2013\redist... here's a screencap of the __Installer folder 



i've also typed in the \vc\vc2013\redist in the url but the file did not show up >_<

I see. Well, you can also get them directly from Microsoft here:
https://www.microsoft.com/en-us/download/details.aspx?id=40784

If you have a 64 bit computer, be sure to download both vcredist_x86.exe and vcredist_x64.exe. But if it's only 32 bit, then you only need vcredist_x86.exe. There's no need for vcredist_arm.exe, so don't download that one. Then, install them and see how it goes. Good luck! Very Happy

_________________
"The capital lies before us my friend. What a sombre place it seems and one that holds the answers to many a mystery." - Quirrel.


"Isn't this a wonderful spot for a rest? I so love the sound of the rain upon glass."
avatar
SeoY
Minecraft Moderator
MC Wizard & Keeper of the Realm
Minecraft Moderator MC Wizard & Keeper of the Realm

Windows version :
  • Windows 8
  • Windows 7
  • Windows 10

System architecture :
  • 32 bits (x86)
  • 64 bits (x64)

Favourite games : Hollow Knight, Dishonored, Bioshock Infinite, Bioshock 1-2, The Sims series, Terraria, Metro 2033, Metro: Last Light, Batman: Arkham series, Ōkami, Metal Gear Solid series, The Binding of Isaac, Silent Hill, Ace Attorney, Civilization V, Portal 2, Minecraft
Male Posts : 1724
Points : 3550
Reputation : 298
Join date : 2013-10-12
Age : 21
Location : City of Tears

View user profile

Back to top Go down

Re: TS4 not working, solutions?

Post by qkrwndud on Fri 14 Aug 2015, 20:29

Thank you for the link! I've downloaded vcredist and re-downloaded the crack again but once again it did not work T_T this is the error pop-up



I've copied and replaced the fix folder list to the original one.. I'm not sure what the problem is now T_T

qkrwndud
Beginner
Beginner

Posts : 4
Points : 661
Reputation : 0
Join date : 2015-08-12

View user profile

Back to top Go down

Re: TS4 not working, solutions?

Post by SeoY on Fri 14 Aug 2015, 23:01

@qkrwndud wrote:Thank you for the link! I've downloaded vcredist and re-downloaded the crack again but once again it did not work T_T this is the error pop-up



I've copied and replaced the fix folder list to the original one.. I'm not sure what the problem is now T_T

I see. Sorry, but the problem most likely is caused by your antivirus. Norton is known for being very stubborn, and for it's high false-positive rates. Even if you disable it, it's still running in the background and making checks that you have told it not to do. So, it's messing with the crack in the game (and with the rld.dll library), causing this error to appear.

You should check if there is a way to completely close Norton, instead of just disabling it, and try again. Or, you could also change your antivirus for a less intrusive one, that actually listens to your input.

Let us know if you are going to change it, and we can help you getting rid of Norton (uninstalling it is also very cumbersome). Good luck! Very Happy

_________________
"The capital lies before us my friend. What a sombre place it seems and one that holds the answers to many a mystery." - Quirrel.


"Isn't this a wonderful spot for a rest? I so love the sound of the rain upon glass."
avatar
SeoY
Minecraft Moderator
MC Wizard & Keeper of the Realm
Minecraft Moderator MC Wizard & Keeper of the Realm

Windows version :
  • Windows 8
  • Windows 7
  • Windows 10

System architecture :
  • 32 bits (x86)
  • 64 bits (x64)

Favourite games : Hollow Knight, Dishonored, Bioshock Infinite, Bioshock 1-2, The Sims series, Terraria, Metro 2033, Metro: Last Light, Batman: Arkham series, Ōkami, Metal Gear Solid series, The Binding of Isaac, Silent Hill, Ace Attorney, Civilization V, Portal 2, Minecraft
Male Posts : 1724
Points : 3550
Reputation : 298
Join date : 2013-10-12
Age : 21
Location : City of Tears

View user profile

Back to top Go down

View previous topic View next topic Back to top


Permissions in this forum:
You cannot reply to topics in this forum