Sims 3 Expansion Packs "Compatibility error"

View previous topic View next topic Go down

Sims 3 Expansion Packs "Compatibility error"

Post by larajade on Sun 20 Sep 2015, 10:32

Hi guys,

I have the Sims 3 base game and it works fine - the torrent was from the link on the G4TW website seeing as TPB link wasn't working. 

I have also downloaded all of the files for the expansion packs and, following the official sims 3 downloader guide file, put them in dmg. 

However, when I open the installer, I get through the first steps and the serial code works, but then, with every expansion pack I've tried installing, says

"The Sims 3 Compatibility Error
The version of The Sims 3 installed is not updatable and is not compatible."

My version of the sims 3 is 1.0.615.00107 - and it does not say I need to make any more updates.

Thanks for all help Very Happy

larajade
Beginner
Beginner

Posts : 2
Points : 926
Reputation : 0
Join date : 2015-04-09

View user profile

Back to top Go down

Re: Sims 3 Expansion Packs "Compatibility error"

Post by Phoebe on Fri 23 Oct 2015, 21:15

Hello, 

This problem is common but it's really easy to solve. Please download the manual update for the Sims 3 MAC from this site. Then it'll okay to install other expansion packs.

Happy simming!  The Sims Plumbob 1

_________________
avatar
Phoebe
Super Spammer
Super Spammer

Windows version :
  • .

System architecture :
  • 64 bits (x64)

Favourite games : The Sims series, Elder Scrolls Skyrim, The Walking Dead, Sacred I-II, Fables,Vampire Masquerade Bloodlines, Civilization, Don't Starve, Popmundo
Female Posts : 783
Points : 2768
Reputation : 119
Join date : 2012-09-17
Age : 28
Location : Neverland

View user profile

Back to top Go down

View previous topic View next topic Back to top


Permissions in this forum:
You cannot reply to topics in this forum