Sims 3 doesn't work after installing expension pack

View previous topic View next topic Go down

Sims 3 doesn't work after installing expension pack

Post by Blackvampiregirl on Tue 01 Dec 2015, 21:50

Hi everyone.

I've played sims 3 with expensions for months now. Yesterday I tried to install another expension ( from games4theworld ) but after that the launcher didn't work anymore and i could open it any other way. I deleted the expension i installed but after that sims still didn't work. I've tried everything, including delete and install everything again. After that I could open the game but he couldn't find the expensions. I tried to start the game up again but then the launcher didn't work again. I tried to delete everything again but that didn't work.. I ended up resetting my whole laptop.. Now i want to downlaod it again but i'm afraid that the same will happen again. Can anyone help me with this?

Also,

Some of the instuctions say that you have to have the base game from games4theworld to download the expension but i've bought the game. Can I still install them?

Thanks!!

Blackvampiregirl
Beginner
Beginner

Windows version :
  • Windows 8

System architecture :
  • 64 bits (x64)

Favourite games : Sims 3
Female Posts : 2
Points : 749
Reputation : 0
Join date : 2015-10-09
Age : 21

View user profile

Back to top Go down

Re: Sims 3 doesn't work after installing expension pack

Post by Blackvampiregirl on Tue 01 Dec 2015, 23:14

Okay I downlaoded sims 3, and it worked. Then I installed an expension and now sims launcher doesn't work.. Again..

Blackvampiregirl
Beginner
Beginner

Windows version :
  • Windows 8

System architecture :
  • 64 bits (x64)

Favourite games : Sims 3
Female Posts : 2
Points : 749
Reputation : 0
Join date : 2015-10-09
Age : 21

View user profile

Back to top Go down

View previous topic View next topic Back to top


Permissions in this forum:
You cannot reply to topics in this forum