Installation Issue.

View previous topic View next topic Go down

Installation Issue.

Post by CadetKael on Wed 29 Jun 2016, 04:07

I had TS4 installed once before on this PC, but I guarantee that all of the files have been removed. 
As for installing, I keep getting stuck at "Updating component registration," and I have all of my AV/Firewall stuff off.




then after about 7 or 8 minutes it does this






and the cycle continues...

also, does it make a difference that this is where I am installing it from?


I'm installing it to the "Program Filesx86" as it is defaulted to.


Please help bc not only is my game not working, but my blood pressure isn't either now.
avatar
CadetKael
Beginner
Beginner

Windows version :
  • Windows 10

System architecture :
  • 64 bits (x64)

Male Posts : 6
Points : 339
Reputation : 0
Join date : 2016-06-29
Age : 18
Location : NY

View user profile

Back to top Go down

Re: Installation Issue.

Post by simmer_tony on Wed 29 Jun 2016, 11:11

Hello, and welcome to forum,  Very Happy
By chance, are you installing the game from a USB-flashdrive or a similar device ? If yes, try copying the actual installer files onto your system's C: drive. Then resume the installation from there.
Also, are you using WinRAR for extracting the contents of the .RAR download ? You should only use WinRAR. In case you don't have it, you can get it here (install instructions are included):
https://games4theworld.org/downloads.html
Good luck for now !

_________________
Talk to my left hand
Simmer Tony
Trying to be helpful here on forum 
The Sims 3 plumbob HUNGRY? The Sims 3 plumbob 

The Sims Plumbob 1 YELL INCOHERENT LANGUAGE AT THE SKY The Sims Plumbob 1
avatar
simmer_tony
Extreme Poster
Extreme Poster

Windows version :
  • Windows 8
  • Windows 7
  • Windows 10

System architecture :
  • 64 bits (x64)

Favourite games : The Sims series, Just Dance series, Grand Theft Auto series, Tomb Raider Reboot, Telltale Games, Far Cry 3 & 4
Male Posts : 439
Points : 1462
Reputation : 58
Join date : 2014-12-06
Location : Zagreb, Croatia

View user profile

Back to top Go down

Re: Installation Issue.

Post by CadetKael on Wed 29 Jun 2016, 17:41

@simmer_tony wrote:Hello, and welcome to forum,  Very Happy
By chance, are you installing the game from a USB-flashdrive or a similar device ? If yes, try copying the actual installer files onto your system's C: drive. Then resume the installation from there.
Also, are you using WinRAR for extracting the contents of the .RAR download ? You should only use WinRAR. In case you don't have it, you can get it here (install instructions are included):

Good luck for now !

No, I've been installing it from my C: drive & I only have WinRAR.
avatar
CadetKael
Beginner
Beginner

Windows version :
  • Windows 10

System architecture :
  • 64 bits (x64)

Male Posts : 6
Points : 339
Reputation : 0
Join date : 2016-06-29
Age : 18
Location : NY

View user profile

Back to top Go down

Re: Installation Issue.

Post by The_gh0stm4n on Wed 29 Jun 2016, 18:11

@CadetKael wrote:
No, I've been installing it from my C: drive & I only have WinRAR.


Hello,


The image-links aren't working, but what does the error say exactly, especially when you mentioned "after 7-8 minutes it does this here" ? 

If you still have the torrent running in your torrent client under "seeding", try right-clicking on it and choose STOP. Then right-click again and choose "Force re-check". This can take a while to complete. But when it's done, re-extract again all contents of the .RAR, into a fresh folder. See if the installation completes this time.

And no, if you install the game from within your C: drive, it should be working fine, at least normally.
avatar
The_gh0stm4n
VETERAN Moderator
Inspector General & Forum O.G.
VETERAN Moderator Inspector General & Forum O.G.

Windows version :
  • Windows 8
  • Windows 7
  • Windows XP
  • Windows 10

System architecture :
  • 32 bits (x86)
  • 64 bits (x64)

Favourite games : The Sims 3, L.A. Noire, Saints Row, Red Faction, Minecraft, Plants vs. Zombies: Garden Warfare, Team Fortress 2, Darkest Hour, GTA: San Andreas, GTA IV, S.W.A.T. 4, Titanfall, Counter-Strike, Hitman: Absolution, Borderlands, Fallout, Dishonored, COD, Battlefield, The Binding of Isaac: Antibirth & Afterbirth†
Male Posts : 13689
Points : 18101
Reputation : 1906
Join date : 2012-11-02
Age : 30
Location : The Situation Room

View user profile

Back to top Go down

Re: Installation Issue.

Post by CadetKael on Wed 29 Jun 2016, 18:22

@The_gh0stm4n wrote:
@CadetKael wrote:
No, I've been installing it from my C: drive & I only have WinRAR.


Hello,


The image-links aren't working, but what does the error say exactly, especially when you mentioned "after 7-8 minutes it does this here" ? 

If you still have the torrent running in your torrent client under "seeding", try right-clicking on it and choose STOP. Then right-click again and choose "Force re-check". This can take a while to complete. But when it's done, re-extract again all contents of the .RAR, into a fresh folder. See if the installation completes this time.

And no, if you install the game from within your C: drive, it should be working fine, at least normally.

yea, after 7-8 minutes it gives me the "Called RunScript when not marked in progress," then when clicking "OK" the other message pops up, "Called InstallFinalize when no install in progress".

I didn't think to check uTorrent again, but when I opened it up, all the files said "Error: Files missing from job. Please recheck". Awesome. So I'm just going to re-download everything again and see if it works.

Thanks for the help!
avatar
CadetKael
Beginner
Beginner

Windows version :
  • Windows 10

System architecture :
  • 64 bits (x64)

Male Posts : 6
Points : 339
Reputation : 0
Join date : 2016-06-29
Age : 18
Location : NY

View user profile

Back to top Go down

Re: Installation Issue.

Post by The_gh0stm4n on Wed 29 Jun 2016, 18:26

@CadetKael wrote:
yea, after 7-8 minutes it gives me the "Called RunScript when not marked in progress," then when clicking "OK" the other message pops up, "Called InstallFinalize when no install in progress".

I didn't think to check uTorrent again, but when I opened it up, all the files said "Error: Files missing from job. Please recheck". Awesome. So I'm just going to re-download everything again and see if it works.

Thanks for the help!


Now wait a second.


Do you still have the actual .RAR file of the base game ? The one that have over 8GB filesize ? If so, move that .RAR file BACK to the folder location where all your torrent downloads are saved. Then re-download the .torrent file here:
https://games4theworld.org/downloads

Note: I recommend using the .torrent file, instead of the magnet-link in that case. So double-click on the little .torrent file, confirm the next window, and the torrent should show up in your client again, as "checking". This can take a while (again) and when done, it will go into "STOP"-mode, I think. From there you can again use "force re-check" afterwards.
avatar
The_gh0stm4n
VETERAN Moderator
Inspector General & Forum O.G.
VETERAN Moderator Inspector General & Forum O.G.

Windows version :
  • Windows 8
  • Windows 7
  • Windows XP
  • Windows 10

System architecture :
  • 32 bits (x86)
  • 64 bits (x64)

Favourite games : The Sims 3, L.A. Noire, Saints Row, Red Faction, Minecraft, Plants vs. Zombies: Garden Warfare, Team Fortress 2, Darkest Hour, GTA: San Andreas, GTA IV, S.W.A.T. 4, Titanfall, Counter-Strike, Hitman: Absolution, Borderlands, Fallout, Dishonored, COD, Battlefield, The Binding of Isaac: Antibirth & Afterbirth†
Male Posts : 13689
Points : 18101
Reputation : 1906
Join date : 2012-11-02
Age : 30
Location : The Situation Room

View user profile

Back to top Go down

Re: Installation Issue.

Post by CadetKael on Wed 29 Jun 2016, 18:36

@The_gh0stm4n wrote:
@CadetKael wrote:
yea, after 7-8 minutes it gives me the "Called RunScript when not marked in progress," then when clicking "OK" the other message pops up, "Called InstallFinalize when no install in progress".

I didn't think to check uTorrent again, but when I opened it up, all the files said "Error: Files missing from job. Please recheck". Awesome. So I'm just going to re-download everything again and see if it works.

Thanks for the help!


Now wait a second.


Do you still have the actual .RAR file of the base game ? The one that have over 8GB filesize ? If so, move that .RAR file BACK to the folder location where all your torrent downloads are saved. Then re-download the .torrent file here:


Note: I recommend using the .torrent file, instead of the magnet-link in that case. So double-click on the little .torrent file, confirm the next window, and the torrent should show up in your client again, as "checking". This can take a while (again) and when done, it will go into "STOP"-mode, I think. From there you can again use "force re-check" afterwards.

Ok, I moved the file back, I re-downloaded the .torrent from games4theworld, it rechecked in uTorrent and is now downloading.
avatar
CadetKael
Beginner
Beginner

Windows version :
  • Windows 10

System architecture :
  • 64 bits (x64)

Male Posts : 6
Points : 339
Reputation : 0
Join date : 2016-06-29
Age : 18
Location : NY

View user profile

Back to top Go down

Re: Installation Issue.

Post by The_gh0stm4n on Wed 29 Jun 2016, 18:43

@CadetKael wrote:
Ok, I moved the file back, I re-downloaded the .torrent from games4theworld, it rechecked in uTorrent and is now downloading.


Technically it should not be "(re-)downloading", just checking the file integrity, since you actually moved the .RAR back. It should go much quicker than actually re-downloading that file. Smile
avatar
The_gh0stm4n
VETERAN Moderator
Inspector General & Forum O.G.
VETERAN Moderator Inspector General & Forum O.G.

Windows version :
  • Windows 8
  • Windows 7
  • Windows XP
  • Windows 10

System architecture :
  • 32 bits (x86)
  • 64 bits (x64)

Favourite games : The Sims 3, L.A. Noire, Saints Row, Red Faction, Minecraft, Plants vs. Zombies: Garden Warfare, Team Fortress 2, Darkest Hour, GTA: San Andreas, GTA IV, S.W.A.T. 4, Titanfall, Counter-Strike, Hitman: Absolution, Borderlands, Fallout, Dishonored, COD, Battlefield, The Binding of Isaac: Antibirth & Afterbirth†
Male Posts : 13689
Points : 18101
Reputation : 1906
Join date : 2012-11-02
Age : 30
Location : The Situation Room

View user profile

Back to top Go down

Re: Installation Issue.

Post by CadetKael on Wed 29 Jun 2016, 23:50

@The_gh0stm4n wrote:
@CadetKael wrote:
Ok, I moved the file back, I re-downloaded the .torrent from games4theworld, it rechecked in uTorrent and is now downloading.


Technically it should not be "(re-)downloading", just checking the file integrity, since you actually moved the .RAR back. It should go much quicker than actually re-downloading that file. Smile

Still no luck  Sad
avatar
CadetKael
Beginner
Beginner

Windows version :
  • Windows 10

System architecture :
  • 64 bits (x64)

Male Posts : 6
Points : 339
Reputation : 0
Join date : 2016-06-29
Age : 18
Location : NY

View user profile

Back to top Go down

Re: Installation Issue.

Post by The_gh0stm4n on Thu 30 Jun 2016, 16:46

@CadetKael wrote:
Still no luck  Sad


Part of the guide here deals with adding exclusions to Windows Defender:
http://games4theworld.bestgoo.com/t18501-unable-to-start-initialization-error-at-startup-updated-on-11-9-2015


Make sure to add the entire "C:" drive to the exclusions then. After that, try re-downloading the torrent, with a different client, such as "BitComet". That's all I can suggest for now, I'm afraid...
avatar
The_gh0stm4n
VETERAN Moderator
Inspector General & Forum O.G.
VETERAN Moderator Inspector General & Forum O.G.

Windows version :
  • Windows 8
  • Windows 7
  • Windows XP
  • Windows 10

System architecture :
  • 32 bits (x86)
  • 64 bits (x64)

Favourite games : The Sims 3, L.A. Noire, Saints Row, Red Faction, Minecraft, Plants vs. Zombies: Garden Warfare, Team Fortress 2, Darkest Hour, GTA: San Andreas, GTA IV, S.W.A.T. 4, Titanfall, Counter-Strike, Hitman: Absolution, Borderlands, Fallout, Dishonored, COD, Battlefield, The Binding of Isaac: Antibirth & Afterbirth†
Male Posts : 13689
Points : 18101
Reputation : 1906
Join date : 2012-11-02
Age : 30
Location : The Situation Room

View user profile

Back to top Go down

Re: Installation Issue.

Post by CadetKael on Sat 02 Jul 2016, 20:41

@The_gh0stm4n wrote:
@CadetKael wrote:
Still no luck  Sad


Part of the guide here deals with adding exclusions to Windows Defender:
http://games4theworld.bestgoo.com/t18501-unable-to-start-initialization-error-at-startup-updated-on-11-9-2015


Make sure to add the entire "C:" drive to the exclusions then. After that, try re-downloading the torrent, with a different client, such as "BitComet". That's all I can suggest for now, I'm afraid...

It must have been something wrong with the PC I was using. I just tried it on my other PC and it works fine. Thanks for the help, though!
avatar
CadetKael
Beginner
Beginner

Windows version :
  • Windows 10

System architecture :
  • 64 bits (x64)

Male Posts : 6
Points : 339
Reputation : 0
Join date : 2016-06-29
Age : 18
Location : NY

View user profile

Back to top Go down

View previous topic View next topic Back to top


Permissions in this forum:
You cannot reply to topics in this forum