Service Initialization failed 0x0175d824. [SOLVED]

View previous topic View next topic Go down

Service Initialization failed 0x0175d824. [SOLVED]

Post by simmer99 on Fri 09 Dec 2016, 09:12

About 2 weeks ago, I had installed a few extra expansions/stuff packs into my game and everything worked fine. I had played the game just fine and had even closed and reopened the game numerous times just fine. 

3 days ago, I realized that I had a few duplicate files in my CAS since I had some CC package files of clothing that came from stuff packs that I didn't have prior to installing those stuff packs 2 weeks ago, so I deleted them.  I hadn't played since I had made the deletion.  Today, Origin did an update on its client and then, when it finished, I attempted to load The Sims 3. Instead of it loading back up, I received the following error:

Unable to Start Game
Server Initialization Failed (0x0175d824)


The custom content that I removed was just some clothing articles that were originally in the Town Life Stuff pack. Since I installed that pack into my game, I got rid of the CC duplicate versions.  No other changes were made to the game. This is for The Sims 3 v1.67.2.0440xx

Please note that I have googled this issue and have performed the following attempts to fix the problem thus far:

Altered the resolution and fullscreen setting in the options.ini file
Installed the crack for the one expansion that I installed that was before the "rest"
Reinstalled the base game file from the ultimate fix folder, reinstalled the update manually, reinstalled the crack folder file (and yes, they went to the correct base game bin folder, overwriting the originals)
cleared all cache

Nothing worked.

Here's the dxdiag of my system:

------------------
System Information
------------------
Time of this report: 12/9/2016, 01:05:21
       Machine name: REDACTED
   Operating System: Windows 7 Home Premium 64-bit (6.1, Build 7601) Service Pack 1 (7601.win7sp1_ldr.160408-2045)
           Language: English (Regional Setting: English)
System Manufacturer: Acer
       System Model: Aspire 7741-6426
               BIOS: Ver 1.00PARTTBL
          Processor: Intel(R) Core(TM) i5 CPU       M 480  @ 2.67GHz (4 CPUs), ~2.7GHz
             Memory: 8192MB RAM
Available OS Memory: 8052MB RAM
          Page File: 6199MB used, 9903MB available
        Windows Dir: C:\Windows
    DirectX Version: DirectX 11
DX Setup Parameters: Not found
   User DPI Setting: Using System DPI
 System DPI Setting: 96 DPI (100 percent)
    DWM DPI Scaling: Disabled
     DxDiag Version: 6.01.7601.17514 32bit Unicode


---------------
Display Devices
---------------
         Card name: AMD Mobility Radeon HD 5000 Series
       Manufacturer: Advanced Micro Devices, Inc.
          Chip type: AMD Radeon Graphics Processor (0x68C1)
           DAC type: Internal DAC(400MHz)
         Device Key: Enum\PCI\VEN_1002&DEV_68C1&SUBSYS_05171025&REV_00
     Display Memory: 4095 MB
   Dedicated Memory: 1010 MB
      Shared Memory: 3085 MB
       Current Mode: 1600 x 900 (32 bit) (29Hz)
       Monitor Name: Generic PnP Monitor
      Monitor Model: PRI HDMI TV
         Monitor Id: PRI0670
        Native Mode: 1280 x 720(p) (60.000Hz)
        Output Type: HDMI
        Driver Name: aticfx64.dll,aticfx64.dll,aticfx64.dll,aticfx32,aticfx32,aticfx32,atiumd64.dll,atidxx64.dll,atidxx64.dll,atiumdag,atidxx32,atidxx32,atiumdva,atiumd6a.cap,atitmm64.dll
Driver File Version: 8.17.0010.1404 (English)
     Driver Version: 15.200.1062.1004
    
(GPU chipset is actually a 6550M but AMD's drivers no longer identify it as such)

I have a bad feeling that that last origin patch may have done something that caused this to happen because it was working perfectly fine before it occurred.

simmer99
Beginner
Beginner

Posts : 5
Points : 600
Reputation : 0
Join date : 2016-05-04

View user profile

Back to top Go down

Re: Service Initialization failed 0x0175d824. [SOLVED]

Post by ☠ ~ Aɳɳ ~ ☠ on Fri 09 Dec 2016, 15:32

Hello,


Have you tried a clean folder?
If that doesn't work, you may have to reinstall everything Sad

_________________
"Under sun and sky, we greet you warmly"
avatar
☠ ~ Aɳɳ ~ ☠
Forum Administratrix
First Lady of the Forum
Forum Administratrix First Lady of the Forum

Windows version :
  • Windows 8
  • Windows XP
  • Windows 10

System architecture :
  • 32 bits (x86)
  • 64 bits (x64)

Female Posts : 15118
Points : 20174
Reputation : 1460
Join date : 2011-05-31

View user profile

Back to top Go down

Re: Service Initialization failed 0x0175d824. [SOLVED]

Post by simmer99 on Sat 10 Dec 2016, 02:26

Ɛɗιη wrote:Hello,


Have you tried a clean folder?
If that doesn't work, you may have to reinstall everything Sad

Alright, so I did the Clean folder trick and the game loaded up perfectly. Guess I can't blame Origin. lol.

Now it's just a matter of trying to isolate what's causing the problem in my original sims 3 folder.

[2 hours later]

Well damn. That fixed the problem. 

After the game loaded normally with a clean folder, I copied over the backed up ccmerged file from the DCCbackup folder, as well as the content from the Downloads, InstalledWorlds, Library, Mods, SavedSims, & Saves folders back into the main documents folder with intent on narrowing down the problem but the game loaded normally once again. It did install a store content patch that I'm assuming wasn't a part of the folders that I moved back but, yeah.
15-20 minutes of waiting for it to load the saved game later, problem solved!  Thanks for the clean folder tip!

(10 minutes later)
Now I have a minor problem that's not really hampering but it's still a bit odd. I'm assuming that it's the result of how I put everything back in but people's names are showing up oddly.

For example, Adam Birch from Aurora Skies has his name read out like this:
Gameplay/Excel/DOT08_World/Sims:Adam Gameplay/Excel/DOT08_World/Sims:Birch

Looking at all the sims that my sim knows in Aurora Skies, everyone's name is like that in everything. Friends list, opportunities, active sim portraits, everything. The only exceptions seem to be my custom sims & Ghoel Uzboc, my main active sim that's an Alien. She's engaged to Adam Birch.

Upon further examination, I noticed that everyone in town is unemployed...except for the sims that have NPC jobs (like the consignment store job) and my Sim's self-employed position. Even my other custom sim in town, Xander Harris (from Buffy the Vampire Slayer) is no longer employed in the Military as an Astronaut. 

I feel like there's something that I missed when I moved those aformentioned folder contents back into the TS3 documents folder that also needed to be put back...or maybe that's a symptom of something else? I dunno.


Last edited by simmer99 on Sat 10 Dec 2016, 02:46; edited 3 times in total (Reason for editing : New Issue)

simmer99
Beginner
Beginner

Posts : 5
Points : 600
Reputation : 0
Join date : 2016-05-04

View user profile

Back to top Go down

Re: Service Initialization failed 0x0175d824. [SOLVED]

Post by The_gh0stm4n on Sat 10 Dec 2016, 05:37

Did you also move the DCCache-folder "back"? Note: if the initial problem originated with some incompatible .sims3pack you installed at some point in the past, moving the DCCache-folder back can cause again the problem about the "service initialization failed".

You would then need to properly re-install your .sims3pack files...though I'm not 100% sure at this point whether this can cause the issue with the sims you are describing.

Just throwing it out though, still. Very Happy

_________________



G4TW Forum rules // G4TW Forum FAQ // G4TW Downloads // G4TW on ThePiratebay

How to install The Sims Medieval // The Sims 2 overview ! // How to install The Sims 3 // Expansion install checklist for TS3 // How to install The Sims 4



Feel free to e-mail me for general questions about G4TW & site navigation problems. Also, when after 24 hours of you posting a topic on the Forum you have not received a reply and still need help, you can send me an e-mail message as well!



avatar
The_gh0stm4n
VETERAN Moderator
Inspector General & Forum O.G.
VETERAN Moderator Inspector General & Forum O.G.

Windows version :
  • Windows 8
  • Windows 7
  • Windows XP
  • Windows 10

System architecture :
  • 32 bits (x86)
  • 64 bits (x64)

Favourite games : The Sims 3, L.A. Noire, Saints Row, Red Faction, Minecraft, Plants vs. Zombies: Garden Warfare, Titanfall, Team Fortress 2, Darkest Hour, GTA V, GTA: San Andreas, S.W.A.T. 4, Counter-Strike, Hitman, Borderlands, Fallout, Dishonored, Call of Duty, Battlefield, The Binding of Isaac: Afterbirth†, Enter the Gungeon.
Male Posts : 14830
Points : 19695
Reputation : 2095
Join date : 2012-11-02
Location : The Situation Room

View user profile

Back to top Go down

Re: Service Initialization failed 0x0175d824. [SOLVED]

Post by ☠ ~ Aɳɳ ~ ☠ on Sat 10 Dec 2016, 10:08

I think it would be ok to just reinstall your worldfiles at this point. It has to do with the way the worlds were put back into your game. If you reinstall the worlds, it should be working as normal again.

_________________
"Under sun and sky, we greet you warmly"
avatar
☠ ~ Aɳɳ ~ ☠
Forum Administratrix
First Lady of the Forum
Forum Administratrix First Lady of the Forum

Windows version :
  • Windows 8
  • Windows XP
  • Windows 10

System architecture :
  • 32 bits (x86)
  • 64 bits (x64)

Female Posts : 15118
Points : 20174
Reputation : 1460
Join date : 2011-05-31

View user profile

Back to top Go down

Re: Service Initialization failed 0x0175d824. [SOLVED]

Post by simmer99 on Sat 10 Dec 2016, 21:46

Yup, you guys were right. When I looked at the game again, I noticed that all the world files were indeed uninstalled and all the mods installed via the DCCache folder needed to be reinstalled via the launcher. Once everything was installed, the game worked perfectly again. Thank you, everyone!

You can lock this topic now. ^_^

simmer99
Beginner
Beginner

Posts : 5
Points : 600
Reputation : 0
Join date : 2016-05-04

View user profile

Back to top Go down

Re: Service Initialization failed 0x0175d824. [SOLVED]

Post by The_gh0stm4n on Thu 15 Dec 2016, 07:16

@simmer99 wrote:Yup, you guys were right. When I looked at the game again, I noticed that all the world files were indeed uninstalled and all the mods installed via the DCCache folder needed to be reinstalled via the launcher. Once everything was installed, the game worked perfectly again. Thank you, everyone!

You can lock this topic now. ^_^


Cool! Very Happy

Feel free to open a new topic anytime again you need more help. Until then, have fun! Problem solved, topic closed.

_________________



G4TW Forum rules // G4TW Forum FAQ // G4TW Downloads // G4TW on ThePiratebay

How to install The Sims Medieval // The Sims 2 overview ! // How to install The Sims 3 // Expansion install checklist for TS3 // How to install The Sims 4



Feel free to e-mail me for general questions about G4TW & site navigation problems. Also, when after 24 hours of you posting a topic on the Forum you have not received a reply and still need help, you can send me an e-mail message as well!



avatar
The_gh0stm4n
VETERAN Moderator
Inspector General & Forum O.G.
VETERAN Moderator Inspector General & Forum O.G.

Windows version :
  • Windows 8
  • Windows 7
  • Windows XP
  • Windows 10

System architecture :
  • 32 bits (x86)
  • 64 bits (x64)

Favourite games : The Sims 3, L.A. Noire, Saints Row, Red Faction, Minecraft, Plants vs. Zombies: Garden Warfare, Titanfall, Team Fortress 2, Darkest Hour, GTA V, GTA: San Andreas, S.W.A.T. 4, Counter-Strike, Hitman, Borderlands, Fallout, Dishonored, Call of Duty, Battlefield, The Binding of Isaac: Afterbirth†, Enter the Gungeon.
Male Posts : 14830
Points : 19695
Reputation : 2095
Join date : 2012-11-02
Location : The Situation Room

View user profile

Back to top Go down

Re: Service Initialization failed 0x0175d824. [SOLVED]

Post by Sponsored content


Sponsored content


Back to top Go down

View previous topic View next topic Back to top


Permissions in this forum:
You cannot reply to topics in this forum