Sims 3 not working - service initialization failed (0x024e424f)

View previous topic View next topic Go down

Sims 3 not working - service initialization failed (0x024e424f)

Post by Amethyst555 on Wed 09 Nov 2011, 06:06


So basically since downloading Town Life and Pets my game just refuses to work. I have a retail copy of The Sims 3 which I have previously had working with all of the Games4theworld expansions, apart from Generations which was the Reloaded release.

I downloaded the Games4theworld copies of Town Life, and Pets - the fixed version, and installed them after installing but not applying the cracks to Ambitions and Late Night, upon going into the launcher and clicking play the first error message that came up was this:

Unable to start game
Service initialization failed (0x024e424f)

At this point i would click ok, and then it would come up with this:

Exception Raised
Unhandled exception 0x80000003 at address 0x0058a526.
Do you wish to debug?

Here clicking either yes or no did nothing.

Also before attempting to install town life and pets i had already updated to 1.27.

I tried to bypass the launcher in order to start the game after this, but the file is an .exe file so it won't let me open it.

I restarted my computer, and reinstalled The Sims 3, i followed the how to install the games correctly guide, installing generations first, not applying the patch, then Town Life, again not applying the patch. However this time i hadnt updated to 1.27 so when i tried to install Pets it told me that my game was not updated so it could not complete the installation.
After this i applied the Generations, Town Life and Pets patch into the Sims 3 base game folder, to see if it would let me update. However now when i go into the launcher and try to update it comes up with this error:

Exception Raised
Unhandled page fault on write access to 0x00000000 at address 0x7c4713b3.
Do you wish to debug?

Again here pressing either yes or no results in nothing.

I also forgot to mention that before attempting to install the expansions both times i removed all mods and custom content.
And that installing the base game, which i have a retail copy of, I consistently get the error message that the game cannot be started, however it still opens and everything works, and it happens even when there is no custom content installed. I dont know if that may have something to do with it.

So thats about it, sorry for the long message, i just wanted to give as much information as possible. I really want to get this to work Sad

Amethyst555
Beginner
Beginner

Posts : 1
Points : 2178
Reputation : 0
Join date : 2011-11-09

View user profile

Back to top Go down

Re: Sims 3 not working - service initialization failed (0x024e424f)

Post by Crazyjay321 on Mon 05 Dec 2011, 11:51

Same issue here... Hope someone helps us solve it Lol
avatar
Crazyjay321
Beginner
Beginner

Favourite games : Total war games, Cod Games, Zombie Games,
Male Posts : 10
Points : 2174
Reputation : 0
Join date : 2011-11-27
Location : Somewhere in the desert

View user profile

Back to top Go down

Re: Sims 3 not working - service initialization failed (0x024e424f)

Post by jkjk5 on Fri 23 Dec 2011, 02:39

same issue here - please help?

jkjk5
Beginner
Beginner

Posts : 3
Points : 2134
Reputation : 0
Join date : 2011-12-23

View user profile

Back to top Go down

Re: Sims 3 not working - service initialization failed (0x024e424f)

Post by Adwomin on Fri 23 Dec 2011, 14:02

Hello,

Did you guys try using the latest version of the Ultimate Fix?

_________________
Bonsoir, friend.


~ Nobody's gril. ~
avatar
Adwomin
free society
free society

Windows version :
  • Windows 8
  • Windows 7

System architecture :
  • 32 bits (x86)
  • 64 bits (x64)

Favourite games : GTA Series, Cities: Skylines, Prison Architect, Borderlands series
Female Posts : 19211
Points : 1026424
Reputation : 2253
Join date : 2010-03-12
Age : 16
Location : Del Perro Heights

View user profile https://www.games4theworld.org

Back to top Go down

Re: Sims 3 not working - service initialization failed (0x024e424f)

Post by jkjk5 on Fri 23 Dec 2011, 20:59

Yes

jkjk5
Beginner
Beginner

Posts : 3
Points : 2134
Reputation : 0
Join date : 2011-12-23

View user profile

Back to top Go down

Re: Sims 3 not working - service initialization failed (0x024e424f)

Post by Nomplay on Fri 23 Dec 2011, 23:07

It seems the only solution for this problem is downloading and installing a different version of The Sims 3 (i.e not games4theworld's) which seems madness, and sooo annoying with a slow internet connection. Even more annoying since I already have the base game I just can't find it V_V SIGH.

Nomplay
Beginner
Beginner

Posts : 9
Points : 2210
Reputation : 0
Join date : 2011-10-21

View user profile

Back to top Go down

Re: Sims 3 not working - service initialization failed (0x024e424f)

Post by jkjk5 on Sat 24 Dec 2011, 00:15

I used to have a Sim3 version that was not g4tw's...and I got the same problem. So I uninstalled it, re-installed gf4w's. Got pretty close (got the whole game updated and everything) and when I went to apply the No-cd crack after installing late night and the sims 3...thats when all of the sudden I got the error again.

So back to square 1

jkjk5
Beginner
Beginner

Posts : 3
Points : 2134
Reputation : 0
Join date : 2011-12-23

View user profile

Back to top Go down

Re: Sims 3 not working - service initialization failed (0x024e424f)

Post by Nomplay on Sat 24 Dec 2011, 01:16

My game was working fine until one day (nothing had changed) it stopped working T_T Me thinks it's some kind of anti piracy thing. I wouldn't mind if the sims games were actually gd enough that I don't want to demo them first, but they've just been so... boring recently. I think I'm just going to have to find my original base game disk xDD

Nomplay
Beginner
Beginner

Posts : 9
Points : 2210
Reputation : 0
Join date : 2011-10-21

View user profile

Back to top Go down

Re: Sims 3 not working - service initialization failed (0x024e424f)

Post by Armand-de-Brignac on Sun 29 Jan 2012, 23:15

Just applied the latest patch and followed G4TW's patching instructions precisely (even when it seemed I was copying the same thing over in the same step for no reason) and it worked like a charm!

The latest patch works!

I had an old patch that didn't work, uninstalled, installed each expansion, copied each fix as instructed, fully patched via updater, installed the #crack patch, and it worked like a charm.

Armand-de-Brignac
Beginner
Beginner

Posts : 2
Points : 2098
Reputation : 2
Join date : 2012-01-29

View user profile

Back to top Go down

View previous topic View next topic Back to top


Permissions in this forum:
You cannot reply to topics in this forum