Sims Medieval update needed in order to install pirates and nobles

View previous topic View next topic Go down

Sims Medieval update needed in order to install pirates and nobles

Post by Nomplay on Sun 11 Dec 2011, 13:21

Hey!

I've downloaded an installed enough from games4theworld to understand all the cracking stuffs but what do I do about updating sims medieval? When installing pirates and nobles it says you are not updated enough to do this.

Thanks!

Nom

Nomplay
Beginner
Beginner

Posts : 9
Points : 2266
Reputation : 0
Join date : 2011-10-21

View user profile

Back to top Go down

View previous topic View next topic Back to top


Permissions in this forum:
You cannot reply to topics in this forum