CC doesn't work after installing expansion packs, help!

View previous topic View next topic Go down

CC doesn't work after installing expansion packs, help!

Post by alice6 on Sun 19 Mar 2017, 20:24

Hi all,

I'll start by saying that up until yesterday I only had the base game (with update-only fix applied) and tons of CC which I've spent hours building and creating sims with without any issue whatsoever. 
I decided, however, to install the expansion packs because I was getting a bit bored of the base game. Initially I only downloaded Get To Work and City Living and spent an evening installing and reinstalling before I decided to properly read the installation instructions and found out that I needed Get Together for all of it to work. So I did and the game opens and seems to be working fine, all with the exception of my CC not showing up at all.
Which at this point is becoming very frustrating.
To begin with, as said above, it was a fresh install. I copied Mods, Tray and Saves folder before making any changes to the base game just in case. After installing everything properly and running the game to see if it works, I added those folders back. I opened the game again and my sims are missing hair and bodies, even though the CC and mods are showing on the list at startup.
I looked up what to do and moved the content to a different folder and deleted the Mods folder along with the resource file, then opened the game again to let it create a new one. Added all content back, and nothing. Repeated, adding only a set of skins from TSR which I downloaded specifically to test it. Again, nothing. Disabled and enabled cc from game options, numerous times, nothing. I don't even have the option to filter only cc in-game, so it's not a case of it being a recolour under a default item swatch. My CC houses and lots in the Tray folder are showing in the gallery, which is fine but everything else - hair, skins, clothes, etc. is missing, again, even though it shows up on the startup list. 
I've ran every possible fix in Sims4Studio in attempt to fix this and it still isn't working. I'm starting to think that I'm missing something ridiculously obvious and I'm completely stuck in looking for a solution because I've tried literally everything to the letter. All expansion packs are from games4theworld and the base game is from RELOADED. 

If anyone has a solution, please, please let me know.
Thanks.

UPDATE: I don't know if this helps at all, but I just played one of my saved households and as soon as it loaded, I got the "Items removed" message saying it's removed however many items from build and buy mode (posted below). Quite a few of my cc build mode items are there, but when I went to CAS from in-game my CAS cc was still missing. 

avatar
alice6
Beginner
Beginner

Windows version :
  • Windows 10

System architecture :
  • 32 bits (x86)
  • 64 bits (x64)

Favourite games : The Sims 4
Female Posts : 3
Points : 195
Reputation : 0
Join date : 2017-03-19
Age : 23

View user profile

Back to top Go down

Re: CC doesn't work after installing expansion packs, help!

Post by alice6 on Mon 20 Mar 2017, 01:25

MAJOR UPDATE: I just reinstalled the game again, hoping to be able to troubleshoot along the way. I tried a few things, I won't explain in detail, instead I'll say what I think actually worked. When installing before and getting the game to run, I always used Reloaded's crack that came with the base game straight after installing it. This time (after uninstalling, deleting the Electronic Arts folder in Documents, restarting PC and doing a disk cleanup), I installed Reloaded's base game, then immediately added Get To Work, Get Together and City Living in that order without using the base game crack. Beforehand I'd deleted all the expansion pack folders in case I'd damaged any files and extracted them from the original downloads. 
I haven't added my saves yet, but I added my CC and Tray content to the newly generated folders and my CC now shows up in CAS.

So there it is, in case anyone ever gets it as wrong as I do.


avatar
alice6
Beginner
Beginner

Windows version :
  • Windows 10

System architecture :
  • 32 bits (x86)
  • 64 bits (x64)

Favourite games : The Sims 4
Female Posts : 3
Points : 195
Reputation : 0
Join date : 2017-03-19
Age : 23

View user profile

Back to top Go down

Re: CC doesn't work after installing expansion packs, help!

Post by The_gh0stm4n on Tue 21 Mar 2017, 12:51

Welcome to the Forum and sorry for the belated reply,


The "update-only-fix" gives your base game the 1.25 patch, minus the DLC of course. You really have to install the Base game -> Get to Work -> Get together -> City Living in this and ONLY this order, to get the patch plus the DLC.

If you did a wrong step, you can start again by copying and pasting the Get to Work-stuff first (replacing the existing files of course), and continuing to do the same with Get together and City Living.

Was there anything else you wanted to ask for now? Smile

_________________
Respectfully,

The_gh0stm4n
G4TW Forum Gatekeeper



avatar
The_gh0stm4n
VETERAN Moderator
Inspector General & Forum O.G.
VETERAN Moderator Inspector General & Forum O.G.

Windows version :
  • Windows 8
  • Windows 7
  • Windows XP
  • Windows 10

System architecture :
  • 32 bits (x86)
  • 64 bits (x64)

Favourite games : The Sims 3, L.A. Noire, Saints Row, Red Faction, Minecraft, Plants vs. Zombies: Garden Warfare, Titanfall, Team Fortress 2, Darkest Hour, GTA V, GTA: San Andreas, S.W.A.T. 4, Counter-Strike, Hitman, Borderlands, Fallout, Dishonored, Call of Duty, Battlefield, The Binding of Isaac: Afterbirth†, Enter the Gungeon.
Male Posts : 14333
Points : 19019
Reputation : 2024
Join date : 2012-11-02
Location : The Situation Room

View user profile

Back to top Go down

Re: CC doesn't work after installing expansion packs, help!

Post by alice6 on Sun 26 Mar 2017, 04:34

Ahh, talk about a late reply! 
Everything's been fine since, thanks. So many new things to try out in the EPs! 
Some mods haven't been showing since but they might not be compatible, so it's not a big deal and I can't be bothered to weed them out. 
I haven't risked loading my old saves yet but I might these next couple of days.
avatar
alice6
Beginner
Beginner

Windows version :
  • Windows 10

System architecture :
  • 32 bits (x86)
  • 64 bits (x64)

Favourite games : The Sims 4
Female Posts : 3
Points : 195
Reputation : 0
Join date : 2017-03-19
Age : 23

View user profile

Back to top Go down

Re: CC doesn't work after installing expansion packs, help!

Post by The_gh0stm4n on Sun 26 Mar 2017, 17:36

alice6 wrote:I haven't risked loading my old saves yet but I might these next couple of days.


Make sure to create regular backups of your savefiles (in a safe location like an USB-flash or something), so in case "something happens" you can restore the saves without losing too much game progress.

alien

_________________
Respectfully,

The_gh0stm4n
G4TW Forum Gatekeeper



avatar
The_gh0stm4n
VETERAN Moderator
Inspector General & Forum O.G.
VETERAN Moderator Inspector General & Forum O.G.

Windows version :
  • Windows 8
  • Windows 7
  • Windows XP
  • Windows 10

System architecture :
  • 32 bits (x86)
  • 64 bits (x64)

Favourite games : The Sims 3, L.A. Noire, Saints Row, Red Faction, Minecraft, Plants vs. Zombies: Garden Warfare, Titanfall, Team Fortress 2, Darkest Hour, GTA V, GTA: San Andreas, S.W.A.T. 4, Counter-Strike, Hitman, Borderlands, Fallout, Dishonored, Call of Duty, Battlefield, The Binding of Isaac: Afterbirth†, Enter the Gungeon.
Male Posts : 14333
Points : 19019
Reputation : 2024
Join date : 2012-11-02
Location : The Situation Room

View user profile

Back to top Go down

View previous topic View next topic Back to top


Permissions in this forum:
You cannot reply to topics in this forum