Sims 3 loads but no picture after intro

View previous topic View next topic Go down

Sims 3 loads but no picture after intro

Post by rybo on Mon 02 Jan 2012, 20:15

I installed the base game and the all of the expansions and stuff packs. Updated the patch to 1.29, and did the ultimate fix. Game loads fine, but once I get past the intro the game doesn't output video. I can still hear the game running through my speakers, but my monitor says check video connections. Any help is appreciated.

rybo
Beginner
Beginner

Posts : 5
Points : 2067
Reputation : 0
Join date : 2012-01-02

View user profile

Back to top Go down

Re: Sims 3 loads but no picture after intro

Post by Adwomin on Mon 02 Jan 2012, 21:05

Hello,

This is weird. Do you experience the same problem with other games / programs too?
This is worth trying: http://games4theworld.bestgoo.com/t857-the-sims-3-crashes-freezes-to-desktop-fix-update-22-12-2011

_________________
Bonsoir, friend.


~ Nobody's gril. ~
avatar
Adwomin
free society
free society

Windows version :
  • Windows 8
  • Windows 7

System architecture :
  • 32 bits (x86)
  • 64 bits (x64)

Favourite games : GTA Series, Cities: Skylines, Prison Architect, Borderlands series
Female Posts : 19211
Points : 1026351
Reputation : 2242
Join date : 2010-03-12
Age : 15
Location : Del Perro Heights

View user profile https://www.games4theworld.org

Back to top Go down

Re: Sims 3 loads but no picture after intro

Post by rybo on Mon 02 Jan 2012, 21:23

Ill give that a shot, but skyrim, and the old republic work perfect.

//EDIT

Tried everything in the link, but nothing worked. Gah

rybo
Beginner
Beginner

Posts : 5
Points : 2067
Reputation : 0
Join date : 2012-01-02

View user profile

Back to top Go down

Re: Sims 3 loads but no picture after intro

Post by Adwomin on Tue 03 Jan 2012, 02:01

Hello,

Please see if your PC can run the game: http://www.systemrequirementslab.com/cyri/

_________________
Bonsoir, friend.


~ Nobody's gril. ~
avatar
Adwomin
free society
free society

Windows version :
  • Windows 8
  • Windows 7

System architecture :
  • 32 bits (x86)
  • 64 bits (x64)

Favourite games : GTA Series, Cities: Skylines, Prison Architect, Borderlands series
Female Posts : 19211
Points : 1026351
Reputation : 2242
Join date : 2010-03-12
Age : 15
Location : Del Perro Heights

View user profile https://www.games4theworld.org

Back to top Go down

Re: Sims 3 loads but no picture after intro

Post by rybo on Tue 03 Jan 2012, 03:16

Im running a 3.2ghz i7 16 gigs of ram and three nvida gtx570's, so the system requirements are not an issue. I think I might have messed up in the install somewhere, but I'm not sure. Ill have to uninstall and try again tomorrow.

rybo
Beginner
Beginner

Posts : 5
Points : 2067
Reputation : 0
Join date : 2012-01-02

View user profile

Back to top Go down

Re: Sims 3 loads but no picture after intro

Post by Aɾყα on Tue 03 Jan 2012, 13:10

Hello,
The Sims 3 Pets is known for its issues with videocard, even if you're using a card that is supposed to be compatible, it could cause crashes.
Make sure your drivers are up to date.

_________________




"Under sun and sky, we greet you warmly"

avatar
Aɾყα
Forum Administratrix
First Lady of the Forum
Forum Administratrix First Lady of the Forum

Windows version :
  • Windows 8
  • Windows XP
  • Windows 10

System architecture :
  • 32 bits (x86)
  • 64 bits (x64)

Female Posts : 15105
Points : 20014
Reputation : 1430
Join date : 2011-05-31

View user profile

Back to top Go down

Re: Sims 3 loads but no picture after intro

Post by rybo on Tue 03 Jan 2012, 20:01

All my drivers are up to date. However my graphics card isn't officially supported list, but I have used it to play TS3 before I installed the expansions.

rybo
Beginner
Beginner

Posts : 5
Points : 2067
Reputation : 0
Join date : 2012-01-02

View user profile

Back to top Go down

Re: Sims 3 loads but no picture after intro

Post by Aɾყα on Tue 03 Jan 2012, 20:12

Hello,
That does make sense, however weird it may sound. Pets came with a whole lot of nasty graphicscard issues.

_________________




"Under sun and sky, we greet you warmly"

avatar
Aɾყα
Forum Administratrix
First Lady of the Forum
Forum Administratrix First Lady of the Forum

Windows version :
  • Windows 8
  • Windows XP
  • Windows 10

System architecture :
  • 32 bits (x86)
  • 64 bits (x64)

Female Posts : 15105
Points : 20014
Reputation : 1430
Join date : 2011-05-31

View user profile

Back to top Go down

Re: Sims 3 loads but no picture after intro

Post by rybo on Tue 03 Jan 2012, 20:35

I uninstalled Pets, Generations, and Town Life and now it works perfect. Im just wondering if its worth trying to reinstall. Thanks for all the help!

rybo
Beginner
Beginner

Posts : 5
Points : 2067
Reputation : 0
Join date : 2012-01-02

View user profile

Back to top Go down

Re: Sims 3 loads but no picture after intro

Post by Adwomin on Tue 03 Jan 2012, 20:39

@rybo wrote:I uninstalled Pets, Generations, and Town Life and now it works perfect. Im just wondering if its worth trying to reinstall. Thanks for all the help!
Hello,

Try reinstalling Generations and Town Life Stuff and see if the problem still persists. If not, then it's certainly caused by Pets and your GPU probably doesn't support it.

_________________
Bonsoir, friend.


~ Nobody's gril. ~
avatar
Adwomin
free society
free society

Windows version :
  • Windows 8
  • Windows 7

System architecture :
  • 32 bits (x86)
  • 64 bits (x64)

Favourite games : GTA Series, Cities: Skylines, Prison Architect, Borderlands series
Female Posts : 19211
Points : 1026351
Reputation : 2242
Join date : 2010-03-12
Age : 15
Location : Del Perro Heights

View user profile https://www.games4theworld.org

Back to top Go down

View previous topic View next topic Back to top


Permissions in this forum:
You cannot reply to topics in this forum