Trouble with starting the actual game

View previous topic View next topic Go down

Trouble with starting the actual game

Post by emliche on Thu 25 May 2017, 09:19

Hello everyone. I'm new to the forum and really appreciate everything you do. Anyway for the past couple of days I haven't been able to play the sims 4 latest version. I have followed the how to install properly guide, applied the temporary fix for infinite loading screens. Redownloaded everything multiple times etc. 
My issue is that when I try to open a game I get an error saying if this is your first time opening the game try to run it as an administrator and make sure origin is open. Then after 10 minutes or so the game launches but then as soon as the sims 4 logo disappears it infinitly loads. Seriously I left my laptop on a night one time and it loaded for 8 hours straight. I don't know if the two issues are connected because I was playing the game perfectly fine 2 days ago. Nothing has changed

emliche
Beginner
Beginner

Favourite games : Sims 4, Stellaris, Ck2, Tyranny
Posts : 6
Points : 94
Reputation : 0
Join date : 2017-05-25

View user profile

Back to top Go down

Re: Trouble with starting the actual game

Post by Loonieloose on Thu 25 May 2017, 09:59

Are you running it as an administrator? right mouse click and then run as administrator. AND did you do all this


http://games4theworld.bestgoo.com/t18501-unable-to-start-initialization-error-at-startup-updated-on-11-9-2015#


Last edited by Loonieloose on Thu 25 May 2017, 10:00; edited 1 time in total (Reason for editing : add text)

Loonieloose
Extreme Poster
Extreme Poster

Windows version :
  • Windows 10

System architecture :
  • 64 bits (x64)

Favourite games : Sims 4
Female Posts : 363
Points : 1101
Reputation : 64
Join date : 2015-10-21
Location : Somewhere in Southern Africa

View user profile

Back to top Go down

Re: Trouble with starting the actual game

Post by emliche on Thu 25 May 2017, 21:37

Yes I have done all of that as part of the guide I completely turned off my antivirus and firewall. Furthermore I always run the game as an administrator. I've also moved the sims 4 folder to programme files. It's also on my antivirus exclusion list.

emliche
Beginner
Beginner

Favourite games : Sims 4, Stellaris, Ck2, Tyranny
Posts : 6
Points : 94
Reputation : 0
Join date : 2017-05-25

View user profile

Back to top Go down

Re: Trouble with starting the actual game

Post by Ageha on Fri 26 May 2017, 16:33

@emliche wrote:Yes I have done all of that as part of the guide I completely turned off my antivirus and firewall. Furthermore I always run the game as an administrator. I've also moved the sims 4 folder to programme files. It's also on my antivirus exclusion list.

Hi!  Very Happy


This is indeed an odd problem. I myself did encounter "please run the game as administrator" but after awhile the game runs. Are you using the TS4_x64.exe or just the TS4.exe? If you use the x64, how about just running the TS4 shortcut instead. Also, have you tried re-installing the game, completely clean of everything and one-by-one test the base game first? How about mods/CCs?

_________________
If you're lost you can look and you will find me, time after time. 
(GMT+0800 Timezone)
avatar
Ageha
Quartermaster Rookie
The Sims 4 Mod
Quartermaster Rookie The Sims 4 Mod

Windows version :
  • Windows 8
  • Windows 7
  • Windows 10

System architecture :
  • 32 bits (x86)
  • 64 bits (x64)

Favourite games : Assassin's Creed Series, Mass Effect + Dragon Age Series, The Sims Series, Saints Row: The Third/IV, Mirror's Edge/Catalyst
Female Posts : 1174
Points : 2120
Reputation : 173
Join date : 2015-09-09
Age : 25
Location : Skyhold

View user profile

Back to top Go down

Re: Trouble with starting the actual game

Post by emliche on Sat 27 May 2017, 05:56

I've tried both x64 and the normal one. And it's only with the vampire and toddler patch added on that I get these errors. I made a separate copy for city living and I can play that perfectly without any issues. Furthermore, I don't have any mods as I thought that might be an issue so when I reinstalled multiple times I deleted them. The issue persists. It's definitely something to do with the latest release, I just don't know what.

emliche
Beginner
Beginner

Favourite games : Sims 4, Stellaris, Ck2, Tyranny
Posts : 6
Points : 94
Reputation : 0
Join date : 2017-05-25

View user profile

Back to top Go down

Re: Trouble with starting the actual game

Post by Ageha on Sat 27 May 2017, 13:54

@emliche wrote:Then after 10 minutes or so the game launches but then as soon as the sims 4 logo disappears it infinitly loads. Seriously I left my laptop on a night one time and it loaded for 8 hours straight.

Sorry, I need to re-check this. Does this mean that even when the 'please run as administrator' pop-ups, the sims 4 will load BUT it got stuck at the infinite loading loop? Or does it not load at all now? If it's at the infinite loading, you can try using this Game folder and paste it to your Sims 4 file. You can download it here.


If it won't load at all however, I'm sorry that at this moment I don't think there's much I can do. You could try using Tarac's ZLOrigin if you wanted to play the latest update (Vampire/Toddler) or you could search for FitGirl repack online.  Smile

_________________
If you're lost you can look and you will find me, time after time. 
(GMT+0800 Timezone)
avatar
Ageha
Quartermaster Rookie
The Sims 4 Mod
Quartermaster Rookie The Sims 4 Mod

Windows version :
  • Windows 8
  • Windows 7
  • Windows 10

System architecture :
  • 32 bits (x86)
  • 64 bits (x64)

Favourite games : Assassin's Creed Series, Mass Effect + Dragon Age Series, The Sims Series, Saints Row: The Third/IV, Mirror's Edge/Catalyst
Female Posts : 1174
Points : 2120
Reputation : 173
Join date : 2015-09-09
Age : 25
Location : Skyhold

View user profile

Back to top Go down

Re: Trouble with starting the actual game

Post by emliche on Sun 28 May 2017, 03:57

It's half and half. Sometimes it loads and then gets stuck on the start screen. Sometimes it doesn't even do that. I've already applied the fix so that won't help. I'll try the other stuff. Thanks

emliche
Beginner
Beginner

Favourite games : Sims 4, Stellaris, Ck2, Tyranny
Posts : 6
Points : 94
Reputation : 0
Join date : 2017-05-25

View user profile

Back to top Go down

View previous topic View next topic Back to top


Permissions in this forum:
You cannot reply to topics in this forum