Custom Content not showing up in my Library/Gallery

View previous topic View next topic Go down

Custom Content not showing up in my Library/Gallery

Post by Nivixi on Sat 05 Aug 2017, 19:42

I didn't want to hi-jack dvbkedee's similar post and my issue may be slightly different. I downloaded a lot and custom furniture/design elements from TSR and I'm not able to see them in my gallery. I downloaded and installed your version of TS4 plus all the DLC and as far as I can tell I followed the instructions correctly. The game loads and plays fine but in order to stop getting the 'Origin is not running' error,' I moved all the contents of The Sims 4 folder out of the Electronic Arts folder in order to get the game to play. This was one of the suggested fixes in a thread I saw here. And it worked!

So, in order to start the game I go here:  C:>Program Files(x86)>The Sims 4>Game>Bin>TS4_x64

I ended up having to create a Mods folder and a Tray folder under C:>Program Files(x86)>The Sims 4> even after running the game as administrator for the first time. I've been putting the lot files in the Tray folder and the package files in Mods but they're not showing up under Custom Content ingame with CC enabled. What am I missing or doing wrong?

Thanks in advance for any assistance!
Nivixi
avatar
Nivixi
Beginner
Beginner

Windows version :
  • Windows 7
  • Windows 10

System architecture :
  • 64 bits (x64)

Favourite games : Planescape: Torment; The Neverhood; Fallout Series; Baldur's Gate 1 & 2; The Sims 3; The Sims 4; Hearthstone; Endless Legend; FTL; Gods Will Be Watching; Kentucky Route Zero; Papers, Please; Portal; Portal 2; RimWorld; This War of Mine; Town of Salem.
Female Posts : 2
Points : 96
Reputation : 0
Join date : 2017-05-21
Age : 35
Location : All around the world statues crumble for me.

View user profile

Back to top Go down

Re: Custom Content not showing up in my Library/Gallery

Post by Loonieloose on Sat 05 Aug 2017, 22:27

Hi, you have made a big mistake. The mods folder and Tray folder should be under My documents/ electronic arts/ the sims 4. That is where all the cc and mods go. Just copy paste all the cc you put into your created mods folder under c: program files and paste them into the mods folder under My documents/ electronic Arts/the sims 4.Do the same with the tray folder. Remember to have move Ovjects on cheat activated before placing any lots.
Then delete the tray and mods folder from Program files/the sims 4.
Hope this sorts your problem out.
Good luck

Loonieloose
Extreme Poster
Extreme Poster

Windows version :
  • Windows 10

System architecture :
  • 64 bits (x64)

Favourite games : Sims 4
Female Posts : 363
Points : 1104
Reputation : 64
Join date : 2015-10-21
Location : Somewhere in Southern Africa

View user profile

Back to top Go down

Re: Custom Content not showing up in my Library/Gallery

Post by The_gh0stm4n on Sun 06 Aug 2017, 00:55

@Nivixi wrote:I didn't want to hi-jack dvbkedee's similar post and my issue may be slightly different. I downloaded a lot and custom furniture/design elements from TSR and I'm not able to see them in my gallery. I downloaded and installed your version of TS4 plus all the DLC and as far as I can tell I followed the instructions correctly. The game loads and plays fine but in order to stop getting the 'Origin is not running' error,' I moved all the contents of The Sims 4 folder out of the Electronic Arts folder in order to get the game to play. This was one of the suggested fixes in a thread I saw here. And it worked!

So, in order to start the game I go here:  C:>Program Files(x86)>The Sims 4>Game>Bin>TS4_x64

I ended up having to create a Mods folder and a Tray folder under C:>Program Files(x86)>The Sims 4> even after running the game as administrator for the first time. I've been putting the lot files in the Tray folder and the package files in Mods but they're not showing up under Custom Content ingame with CC enabled. What am I missing or doing wrong?

Thanks in advance for any assistance!
Nivixi


Welcome to the Forum,

Adding to what the previous poster said, it's a good idea if - in the long run - you try familiarizing yourself with these folder paths...

-> C:\Users\(your username)\My Documents...that's usually where your personalized game data (custom content, savefiles, in-game settings, etc.) is saved, not just for Sims games, but many if not most other PC games use the same location. 

-> C:\Program files (x86)...that is where the game's installation data is saved. You usually don't need to do anything there, unless you want to uninstall/install a game.
avatar
The_gh0stm4n
VETERAN Moderator
Inspector General & Forum O.G.
VETERAN Moderator Inspector General & Forum O.G.

Windows version :
  • Windows 8
  • Windows 7
  • Windows XP
  • Windows 10

System architecture :
  • 32 bits (x86)
  • 64 bits (x64)

Favourite games : The Sims 3, L.A. Noire, Saints Row, Red Faction, Minecraft, Plants vs. Zombies: Garden Warfare, Titanfall, Team Fortress 2, Darkest Hour, GTA: San Andreas, S.W.A.T. 4, Counter-Strike, Hitman, Borderlands, Fallout, Dishonored, Call of Duty, Battlefield, The Binding of Isaac: Afterbirth†
Male Posts : 14087
Points : 18688
Reputation : 1985
Join date : 2012-11-02
Age : 30
Location : San Fierro

View user profile

Back to top Go down

Re: Custom Content not showing up in my Library/Gallery

Post by Nivixi on Sun 06 Aug 2017, 17:29

Thank you both for your responses and AHA! I don't normally use the C:\Users\myusername\My Documents path to find things so I did not think to check there. And wouldn't you know it? There be the actual Mods and Tray folders.

I copy/pasted all my downloaded mods and tray files from the two folders I had created into these two correct folders and everything is now showing up ingame. I feel dumb for having not known about Users\username\My Docutments but smarter now that I know to use that pathway in the future.

Thank you both so much!
avatar
Nivixi
Beginner
Beginner

Windows version :
  • Windows 7
  • Windows 10

System architecture :
  • 64 bits (x64)

Favourite games : Planescape: Torment; The Neverhood; Fallout Series; Baldur's Gate 1 & 2; The Sims 3; The Sims 4; Hearthstone; Endless Legend; FTL; Gods Will Be Watching; Kentucky Route Zero; Papers, Please; Portal; Portal 2; RimWorld; This War of Mine; Town of Salem.
Female Posts : 2
Points : 96
Reputation : 0
Join date : 2017-05-21
Age : 35
Location : All around the world statues crumble for me.

View user profile

Back to top Go down

Re: Custom Content not showing up in my Library/Gallery

Post by Loonieloose on Sun 06 Aug 2017, 20:05

Glad it works now. And that I could be of help. Happy simming!

Loonieloose
Extreme Poster
Extreme Poster

Windows version :
  • Windows 10

System architecture :
  • 64 bits (x64)

Favourite games : Sims 4
Female Posts : 363
Points : 1104
Reputation : 64
Join date : 2015-10-21
Location : Somewhere in Southern Africa

View user profile

Back to top Go down

Re: Custom Content not showing up in my Library/Gallery

Post by The_gh0stm4n on Sun 06 Aug 2017, 20:54

@Nivixi wrote:I don't normally use the C:\Users\myusername\My Documents path to find things (...)


Where do you normally look? Very Happy
avatar
The_gh0stm4n
VETERAN Moderator
Inspector General & Forum O.G.
VETERAN Moderator Inspector General & Forum O.G.

Windows version :
  • Windows 8
  • Windows 7
  • Windows XP
  • Windows 10

System architecture :
  • 32 bits (x86)
  • 64 bits (x64)

Favourite games : The Sims 3, L.A. Noire, Saints Row, Red Faction, Minecraft, Plants vs. Zombies: Garden Warfare, Titanfall, Team Fortress 2, Darkest Hour, GTA: San Andreas, S.W.A.T. 4, Counter-Strike, Hitman, Borderlands, Fallout, Dishonored, Call of Duty, Battlefield, The Binding of Isaac: Afterbirth†
Male Posts : 14087
Points : 18688
Reputation : 1985
Join date : 2012-11-02
Age : 30
Location : San Fierro

View user profile

Back to top Go down

View previous topic View next topic Back to top


Permissions in this forum:
You cannot reply to topics in this forum