Sims 1 Complete Collection-Open game, EA logo full screen, then 1/4th of screen with corrupted pink and green loading

View previous topic View next topic Go down

Sims 1 Complete Collection-Open game, EA logo full screen, then 1/4th of screen with corrupted pink and green loading

Post by CatGoat on Wed 23 Aug 2017, 21:00

I have installed the game, patched the crack correctly (via replacement), and can open the game without the "no-CD" error.  I then see the game begin fullscreen, the EA logo animating.  Next it cuts down to about a 1/4th of my screen and shows a corrupted version of the standard loading screen.  By this I mean it is pixelated randomly in pink and green, and the scrolling phrases are flying past at a moderate speed.  This lasts about three seconds before crashing to desktop.  During this time, I cannot see the desktop, so it acts as in fullscreen mode; everything but the loading screen is black.

I am using Windows 7, 64-Bit, have tried opening the game as an administrator, and in both resolutions, and in various compatibility modes.

Who else has had this problem?  How can I fix this?

This was torrented through Games4TheWorld on The Pirate Bay.

CatGoat

CatGoat
Beginner
Beginner

Favourite games : Dark Souls, Dragon Age, Elder Scolls, The Sims, The Legend of Zelda, Metroid
Posts : 2
Points : 59
Reputation : 0
Join date : 2017-08-23

View user profile

Back to top Go down

Re: Sims 1 Complete Collection-Open game, EA logo full screen, then 1/4th of screen with corrupted pink and green loading

Post by Tarac on Thu 24 Aug 2017, 13:08

Did you extract the download with Winrar of did you use another extractor ?
Winrar is the correct one.

Did you execute DirectX8a ? (In the folder DirectX8a -> dxsetup.exe)
avatar
Tarac
=D Child of Admin =D
=D Child of Admin =D

Windows version :
  • Windows 8
  • Windows 7
  • Windows Vista
  • Windows XP
  • Windows 98
  • Windows 95
  • Windows 10

System architecture :
  • 64 bits (x64)

Favourite games : Card games
Male Posts : 2267
Points : 4203
Reputation : 363
Join date : 2013-09-14
Age : 74
Location : The Netherlands

View user profile http://www.tarac.nl

Back to top Go down

Tried...

Post by CatGoat on Thu 24 Aug 2017, 17:15

Tarac wrote:Did you extract the download with Winrar of did you use another extractor ?
Winrar is the correct one.

Did you execute DirectX8a ? (In the folder DirectX8a -> dxsetup.exe)
I tried what you said and I removed all files beyond the compressed WinRAR Archive, then extracted with WinRAR.  It extracted after a couple of minutes, then I tried to install the game.  Now I get an error message along the lines of "Unknown error encountered.  Aborting setup."  This happens when going through the launcher, the setup.exe and English setup.exe files.

I next tried the dxsetup.exe file.  It said it was successful.

I then retried installation.  No dice with the launcher or setup files again.

I found a solution to the installation problem here: http://games4theworld.bestgoo.com/t22742-the-sims-1-installation-unknown-error-encountered-aborting-setup?highlight=Unknown+error+encountered+Aborting+setup#

The game installed normally through the launcher, this time providing me with the previously missing registration message.

I'll update in a minute after attempting to play.

Edit:  I got the crack patched, launched the game (through both the start.exe and the sims.exe), then the original problem happened again: pink and green loading screen.

Is there anything else I can try?  I haven't found any other people on these forums with this particular problem.

CatGoat
Beginner
Beginner

Favourite games : Dark Souls, Dragon Age, Elder Scolls, The Sims, The Legend of Zelda, Metroid
Posts : 2
Points : 59
Reputation : 0
Join date : 2017-08-23

View user profile

Back to top Go down

View previous topic View next topic Back to top


Permissions in this forum:
You cannot reply to topics in this forum