Lag/freeze issues

View previous topic View next topic Go down

Lag/freeze issues

Post by MintyChew on Sun 12 Feb 2012, 10:10

So everything was working fine until about 2 days ago when the game starts to freeze/lag for a few seconds. I did installed some CC and always on the "testingcheatsenabled true" cheat when I'm in game. What happened was, when my sim is moving or doing something, my game would freeze/lag. My sim would stop moving, the background music still running, can't click on any interactions, can't do the edge scrolling, for a few seconds. The time in game would also stop.

I have totally no idea what's happening because everything seems to be working until 2 days ago. I tried searching for solutions online, and they suggest removing any CC/mod and caches. I'd done that but it still doesn't seem to work. I'd also went to the systemrequirementslab website and check if I met the minimum requirements for the game and I passed the test.


To summarize,

- I have all the expansions installed together with the base game. (including the Master Suite Stuff)
- Everything is working fine until a few days ago.
- My sim would stop moving, background music still running, can't click on anything, no interactions, time stopped for a few seconds.
- I removed all my CC/mods, caches.
- And I also tried to play the game without enabling the cheat. All doesn't work.


Computer Specs:

- I'm using Windows XP
- Graphic Card: ATI Radeon HD 4800 Series (with the latest drivers)


Could it be that my base game is corrupted? Appreciate any help offered.

MintyChew
Beginner
Beginner

Windows version :
  • Windows 7

System architecture :
  • 64 bits (x64)

Female Posts : 10
Points : 2099
Reputation : 0
Join date : 2012-01-30
Age : 23
Location : Singapore

View user profile

Back to top Go down

Re: Lag/freeze issues

Post by ☠ ~ Aɳɳ ~ ☠ on Sun 12 Feb 2012, 10:39

Hello,
No I don't think so, lagging/freezing could be caused by a number of things, mods and cc being one of them. But in this case I doubt that they are the cause, since the problem started out of the blue and you tried without your mods/cc.
It can be caused by outdated graphicsdrivers or an unsupported card, but your card is on the (supported cards) list and up to date.
Its most commonly caused by simply being Sims though. As we all know, the game is pretty buggy and this is a classic case. I believe that your problem is caused by bad routing and/or Sims that get stuck or are lost/invisible, in addition to a large number of abandoned vehicles.
The easiest way to test this is to reset all your sims at once by opening the console and typing resetSim. Note that this will cancel any actions your sims were doing.

You also said you were using a lot of mods/cc. Since you're using WinXP, I'm going to assume you're on a low(er) end pc. You may want to look at your mods file, if you're using a lot of complicated mods or a lot of packages, this may also cause lag. I'm on a pretty low-end pc myself and my game starts having all kinds of problems when I use too many mods, which is why I've limited myself to the must-have mods. In my case: Nraas' StoryProgression, overwatch, error trap, master controller and traveller. I'm pushing it now, and am considering removing one. I could live without mastercontroller. In addition to this I also have a few small mods that shouldn't make much of a difference though: no intro and clean house for everyone.

Anyway, Overwatch helps prevent game lag so if the reset sim command solves or lessens your problem, I recommend getting that mod here. It manages the entire neighbourhood by periodically cleaning up vehicles and problem sims.

_________________
"Under sun and sky, we greet you warmly"

avatar
☠ ~ Aɳɳ ~ ☠
Forum Administratrix
First Lady of the Forum
Forum Administratrix First Lady of the Forum

Windows version :
  • Windows 8
  • Windows XP
  • Windows 10

System architecture :
  • 32 bits (x86)
  • 64 bits (x64)

Female Posts : 15112
Points : 20086
Reputation : 1437
Join date : 2011-05-31

View user profile

Back to top Go down

Re: Lag/freeze issues

Post by MintyChew on Sun 12 Feb 2012, 10:57


Omg! Yes, you reminded me! I did see a few Sims(when I attend their parties) having things stuck onto them like cereal bowls, plate of food. Perhaps that could be the problem! I shall try out the command first to see if it works. Thanks for your reply! I will update you if the problem is solved or still persists! (:

MintyChew
Beginner
Beginner

Windows version :
  • Windows 7

System architecture :
  • 64 bits (x64)

Female Posts : 10
Points : 2099
Reputation : 0
Join date : 2012-01-30
Age : 23
Location : Singapore

View user profile

Back to top Go down

Re: Lag/freeze issues

Post by ☠ ~ Aɳɳ ~ ☠ on Sun 12 Feb 2012, 11:14

Hello,
I hope it works!

_________________
"Under sun and sky, we greet you warmly"

avatar
☠ ~ Aɳɳ ~ ☠
Forum Administratrix
First Lady of the Forum
Forum Administratrix First Lady of the Forum

Windows version :
  • Windows 8
  • Windows XP
  • Windows 10

System architecture :
  • 32 bits (x86)
  • 64 bits (x64)

Female Posts : 15112
Points : 20086
Reputation : 1437
Join date : 2011-05-31

View user profile

Back to top Go down

Re: Lag/freeze issues

Post by MintyChew on Sun 12 Feb 2012, 11:31

I have not used any mods to date, just a couple of CCs (with I removed prior to posting here). Currently the only mod I have installed is Overwatch. The problem is still not solved/does not lessen. In fact, the frequency of the lag/freeze increase (the character ran for about 2-3 steps before the lag/freeze came, it happens repeatedly). Do you have any recommended/preferred settings for Overwatch?

MintyChew
Beginner
Beginner

Windows version :
  • Windows 7

System architecture :
  • 64 bits (x64)

Female Posts : 10
Points : 2099
Reputation : 0
Join date : 2012-01-30
Age : 23
Location : Singapore

View user profile

Back to top Go down

Re: Lag/freeze issues

Post by ☠ ~ Aɳɳ ~ ☠ on Sun 12 Feb 2012, 11:59

Hello,
I'm just using the default settings.
Try lowering your video settings and/or playing in windowed mode.

_________________
"Under sun and sky, we greet you warmly"

avatar
☠ ~ Aɳɳ ~ ☠
Forum Administratrix
First Lady of the Forum
Forum Administratrix First Lady of the Forum

Windows version :
  • Windows 8
  • Windows XP
  • Windows 10

System architecture :
  • 32 bits (x86)
  • 64 bits (x64)

Female Posts : 15112
Points : 20086
Reputation : 1437
Join date : 2011-05-31

View user profile

Back to top Go down

Re: Lag/freeze issues

Post by MintyChew on Sun 12 Feb 2012, 12:40

Neither worked, so i guess it's a classic bug? Would reinstallation of base game fix this bug?

MintyChew
Beginner
Beginner

Windows version :
  • Windows 7

System architecture :
  • 64 bits (x64)

Female Posts : 10
Points : 2099
Reputation : 0
Join date : 2012-01-30
Age : 23
Location : Singapore

View user profile

Back to top Go down

Re: Lag/freeze issues

Post by ☠ ~ Aɳɳ ~ ☠ on Sun 12 Feb 2012, 13:31

Hello,
That's a little radical, first try this:
Start a new game to see if the lag persists, if it does, try this:

1. Go to: (My) Documents\Electronic Arts\
2. Backup (Read: copy to an other folder) the folder called "The Sims 3".
3. Now completely remove the "The Sims 3" folder from: (My) Documents\Electronic Arts\
4. Now start the game and see if the lag persists

If it doesn't, you can put your saves folder back.


_________________
"Under sun and sky, we greet you warmly"

avatar
☠ ~ Aɳɳ ~ ☠
Forum Administratrix
First Lady of the Forum
Forum Administratrix First Lady of the Forum

Windows version :
  • Windows 8
  • Windows XP
  • Windows 10

System architecture :
  • 32 bits (x86)
  • 64 bits (x64)

Female Posts : 15112
Points : 20086
Reputation : 1437
Join date : 2011-05-31

View user profile

Back to top Go down

Re: Lag/freeze issues

Post by MintyChew on Sun 12 Feb 2012, 15:47


Seems to be working now without the lags/freeze! Thanks a lot (:


//EDIT

Alright, the problem is back >< Is there any other solutions because Overwatch doesn't help also. Or should I just uninstall then install all over again?

MintyChew
Beginner
Beginner

Windows version :
  • Windows 7

System architecture :
  • 64 bits (x64)

Female Posts : 10
Points : 2099
Reputation : 0
Join date : 2012-01-30
Age : 23
Location : Singapore

View user profile

Back to top Go down

Re: Lag/freeze issues

Post by ☠ ~ Aɳɳ ~ ☠ on Mon 13 Feb 2012, 09:48

Hello,
No you simulated that when you removed the folder before so that's not going to work.
Let me ask you this though: Have you been playing this world for a long time (several generations)? And which world is it?

_________________
"Under sun and sky, we greet you warmly"

avatar
☠ ~ Aɳɳ ~ ☠
Forum Administratrix
First Lady of the Forum
Forum Administratrix First Lady of the Forum

Windows version :
  • Windows 8
  • Windows XP
  • Windows 10

System architecture :
  • 32 bits (x86)
  • 64 bits (x64)

Female Posts : 15112
Points : 20086
Reputation : 1437
Join date : 2011-05-31

View user profile

Back to top Go down

Re: Lag/freeze issues

Post by MintyChew on Mon 13 Feb 2012, 10:43


Hmm.. I disabled ageing 'cause I don't seem to like my Sims ageing too fast. Personal preference =x

I'd been playing in Bridgeport. Since the download issue, I'd been playing for approximately more than 10 days, more than 5 hours each day. My household consists of only 1 female Sim, no pets. But there are 2 items I bought in Buy Mode using "buydebug" cheat.

Edit: Alright, I went to search on the net. And I tried the resetsim *. It works well for now, hopefully it'll stay that way >< Thanks for your help again Lady Eldi (:

MintyChew
Beginner
Beginner

Windows version :
  • Windows 7

System architecture :
  • 64 bits (x64)

Female Posts : 10
Points : 2099
Reputation : 0
Join date : 2012-01-30
Age : 23
Location : Singapore

View user profile

Back to top Go down

View previous topic View next topic Back to top


Permissions in this forum:
You cannot reply to topics in this forum