Problems with cats after installing showtime and store content oddities

Page 1 of 2 1, 2  Next

View previous topic View next topic Go down

Problems with cats after installing showtime and store content oddities

Post by illusions on Mon 12 Mar 2012, 23:13

Hello,

There's something wrong with the cats in my game. After I installed Showtime, the cat in a family became uncontrollable. It would still appear in the house, but I couldn't select it and it's profile picture was missing. The box was still there, but the picture inside was gone and I couldn't select it. Even weirder, the second cat in the family was perfectly fine, it was only the first one. I tried getting rid of all custom content and mods and then applied the ultimate fix, but it still didn't work... Also, the store content wouldn't install properly. I would install the stuff, and it says that it installed it properly, then when I go into the game, it's not there. I go back to the launcher and it says that it's not installed. I tried clearing the caches, and it still did the same thing. Then I tried deleting all the CC and mods, and when I go into the game, the stuff that had previously installed was still there. It would only go away after I actually went and deleted all the files from the folder and cleared the caches again.

I don't know what I'm doing wrong

The store content problem has resolved itself, but the cats are still gone!

illusions
Beginner
Beginner

Posts : 16
Points : 2120
Reputation : 0
Join date : 2012-03-12

View user profile

Back to top Go down

Re: Problems with cats after installing showtime and store content oddities

Post by grieralexander on Tue 13 Mar 2012, 01:28

@illusions wrote:Hello,

There's something wrong with the cats in my game. After I installed Showtime, the cat in a family became uncontrollable. It would still appear in the house, but I couldn't select it and it's profile picture was missing. The box was still there, but the picture inside was gone and I couldn't select it. Even weirder, the second cat in the family was perfectly fine, it was only the first one. I tried getting rid of all custom content and mods and then applied the ultimate fix, but it still didn't work... Also, the store content wouldn't install properly. I would install the stuff, and it says that it installed it properly, then when I go into the game, it's not there. I go back to the launcher and it says that it's not installed. I tried clearing the caches, and it still did the same thing. Then I tried deleting all the CC and mods, and when I go into the game, the stuff that had previously installed was still there. It would only go away after I actually went and deleted all the files from the folder and cleared the caches again.

Hello,
Youa re not the only one with this issue. It comes from the EA patch itself. To have your content show up; you may chosse two uptions after clearing your caches, remember that DCbackup and DC cache keep all you alredy installed CC through the launcher. You may install your packs one by one or you may use CC magic. It has worked for various people. As for the pets issues try reseting them with debug enabled. If it doesn´t work try going into edit town, build buy and then come back to the regular game. Let us know

I don't know what I'm doing wrong
avatar
grieralexander
Posting Lord
Posting Lord

Windows version :
  • Windows 7

System architecture :
  • 64 bits (x64)

Favourite games : Sims 3; Assasins Creed; Rise of Nations; Age of Empires series; Titan Quest; Overlord
Male Posts : 248
Points : 2426
Reputation : 11
Join date : 2012-01-30
Location : Brazil

View user profile

Back to top Go down

Re: Problems with cats after installing showtime and store content oddities

Post by illusions on Tue 13 Mar 2012, 02:25

After I uninstalled and deleted the files, and cleared the caches, it seems that when I install the store content stuff, it will install, and the launcher will say that it has installed, so I go into the game, and most everything is there. But when I go back to the launcher, it says that the stuff isn't installed, but it's still there in the game, with only some items that are missing. The only things that the launcher says are installed are the lots (houses), but not the clothes, items, worlds etc.

My cats won't show up when I try the reset debug. The going into buy/build mode doesn't work either.

illusions
Beginner
Beginner

Posts : 16
Points : 2120
Reputation : 0
Join date : 2012-03-12

View user profile

Back to top Go down

Re: Problems with cats after installing showtime and store content oddities

Post by ☠ ~ Aɳɳ ~ ☠ on Tue 13 Mar 2012, 10:55

Hello,

Have you also tried resetsim [cats] [name]?
You can try a hard reset of the cat with master controller which can be found here. It seems strange that it's just the 1 cat that has become bugged.

_________________
"Under sun and sky, we greet you warmly"
avatar
☠ ~ Aɳɳ ~ ☠
Forum Administratrix
First Lady of the Forum
Forum Administratrix First Lady of the Forum

Windows version :
  • Windows 8
  • Windows XP
  • Windows 10

System architecture :
  • 32 bits (x86)
  • 64 bits (x64)

Female Posts : 15118
Points : 20172
Reputation : 1460
Join date : 2011-05-31

View user profile

Back to top Go down

Re: Problems with cats after installing showtime and store content oddities

Post by illusions on Tue 13 Mar 2012, 22:37

The resetsim thing doesn't work. I can't select the cat at all. I can see it lying on the floor, but when I try to click it, I can't. Normally when I click something, the nrass menu thing will pop up, even with the floor, but nothing happens when I try to click the cat, the cursor turns grey. The mastercontroller mod didn't work either.

illusions
Beginner
Beginner

Posts : 16
Points : 2120
Reputation : 0
Join date : 2012-03-12

View user profile

Back to top Go down

Re: Problems with cats after installing showtime and store content oddities

Post by grieralexander on Wed 14 Mar 2012, 00:24

Have you tried reseting the whole World at the City HAll, using MC, instead of clicking on the cat?
avatar
grieralexander
Posting Lord
Posting Lord

Windows version :
  • Windows 7

System architecture :
  • 64 bits (x64)

Favourite games : Sims 3; Assasins Creed; Rise of Nations; Age of Empires series; Titan Quest; Overlord
Male Posts : 248
Points : 2426
Reputation : 11
Join date : 2012-01-30
Location : Brazil

View user profile

Back to top Go down

Re: Problems with cats after installing showtime and store content oddities

Post by illusions on Wed 14 Mar 2012, 01:24

I went and tried the reset option at the cityhall, but it doesn't work, the cat's profile picture is still just a green box and she's still stuck there and unselectable...

illusions
Beginner
Beginner

Posts : 16
Points : 2120
Reputation : 0
Join date : 2012-03-12

View user profile

Back to top Go down

Re: Problems with cats after installing showtime and store content oddities

Post by grieralexander on Wed 14 Mar 2012, 01:31

Ok, one more suggestion, Force Kill the cat and get a new one in game to see if it works. or if you have the cat saved in your sim library you can add her to the family again!
Let us know
avatar
grieralexander
Posting Lord
Posting Lord

Windows version :
  • Windows 7

System architecture :
  • 64 bits (x64)

Favourite games : Sims 3; Assasins Creed; Rise of Nations; Age of Empires series; Titan Quest; Overlord
Male Posts : 248
Points : 2426
Reputation : 11
Join date : 2012-01-30
Location : Brazil

View user profile

Back to top Go down

Re: Problems with cats after installing showtime and store content oddities

Post by illusions on Wed 14 Mar 2012, 02:26

So, I force killed the stuck cat and adopted another one and that cat was perfectly normal. Then I got a call from the science thing about restoring a ghost. So I tried to restore the previously stuck cat, and she came back, but it was like before where she was unselectable and had a green box as a portrait. So I guess there's something wrong with the cat itself?

illusions
Beginner
Beginner

Posts : 16
Points : 2120
Reputation : 0
Join date : 2012-03-12

View user profile

Back to top Go down

Re: Problems with cats after installing showtime and store content oddities

Post by grieralexander on Wed 14 Mar 2012, 02:53

@illusions wrote:So, I force killed the stuck cat and adopted another one and that cat was perfectly normal. Then I got a call from the science thing about restoring a ghost. So I tried to restore the previously stuck cat, and she came back, but it was like before where she was unselectable and had a green box as a portrait. So I guess there's something wrong with the cat itself?

There is really nothing wrong with the cat, is some new bug this new EA patch has; however this problem has been around since patch 1.29, with some people, specially in saves that have pets!. You need to get rid of this cat permanetly because it is currupted already, so; using MC again in The Town hall do a total alianation with the restore cat. This will take it aout of your game permanetly. Ah, next time you do a cleanup (force kill) go back to town hall, select town and cleanse the dead; this will eliminate added tomb stones etc. to the game and prevent the undesired pet to come back .
At least I am glad we got to solve that problem. Any other questions feel free to contact us, we are glad to help!
avatar
grieralexander
Posting Lord
Posting Lord

Windows version :
  • Windows 7

System architecture :
  • 64 bits (x64)

Favourite games : Sims 3; Assasins Creed; Rise of Nations; Age of Empires series; Titan Quest; Overlord
Male Posts : 248
Points : 2426
Reputation : 11
Join date : 2012-01-30
Location : Brazil

View user profile

Back to top Go down

Re: Problems with cats after installing showtime and store content oddities

Post by illusions on Wed 14 Mar 2012, 03:14

Thank you everyone for the help. Although I will miss that cat, it's nice to know there's not some weird problem with it.

illusions
Beginner
Beginner

Posts : 16
Points : 2120
Reputation : 0
Join date : 2012-03-12

View user profile

Back to top Go down

Re: Problems with cats after installing showtime and store content oddities

Post by grieralexander on Wed 14 Mar 2012, 06:28

@illusions wrote:Thank you everyone for the help. Although I will miss that cat, it's nice to know there's not some weird problem with it.
I know what you mean. I share Pets on the net and I have all of my creations spread through different worlds and you do get attach to the family in game. The good side is that you got your word in working order again. Thanks for the update! And please do come back.
avatar
grieralexander
Posting Lord
Posting Lord

Windows version :
  • Windows 7

System architecture :
  • 64 bits (x64)

Favourite games : Sims 3; Assasins Creed; Rise of Nations; Age of Empires series; Titan Quest; Overlord
Male Posts : 248
Points : 2426
Reputation : 11
Join date : 2012-01-30
Location : Brazil

View user profile

Back to top Go down

Re: Problems with cats after installing showtime and store content oddities

Post by ☠ ~ Aɳɳ ~ ☠ on Wed 14 Mar 2012, 10:40

Aww that is just so sad Sad

How about your store and cc?


_________________
"Under sun and sky, we greet you warmly"
avatar
☠ ~ Aɳɳ ~ ☠
Forum Administratrix
First Lady of the Forum
Forum Administratrix First Lady of the Forum

Windows version :
  • Windows 8
  • Windows XP
  • Windows 10

System architecture :
  • 32 bits (x86)
  • 64 bits (x64)

Female Posts : 15118
Points : 20172
Reputation : 1460
Join date : 2011-05-31

View user profile

Back to top Go down

Re: Problems with cats after installing showtime and store content oddities

Post by illusions on Thu 15 Mar 2012, 22:52

The store content stuff seems to be working. The launcher still doesn't list them as installed but most of them seem to show up in the game (I haven't had the time to make sure that they're all there, but I think so...)

I've run into another problem...I had a saved game in Bridgeport, and when I loaded it yesterday, none of my sim icon picture things on the left side of the screen showed up and the motive bar that's normally green was blue and transparent...When I tried to switch characters with the space bar, two of the profile pictures would show up, but no matter what I did, the rest wouldn't come back. I tried going into build/buy mode, and Edit town, but it didn't do anything. (Should I make a new thread for this?)

illusions
Beginner
Beginner

Posts : 16
Points : 2120
Reputation : 0
Join date : 2012-03-12

View user profile

Back to top Go down

Re: Problems with cats after installing showtime and store content oddities

Post by grieralexander on Fri 16 Mar 2012, 00:08

@illusions wrote:The store content stuff seems to be working. The launcher still doesn't list them as installed but most of them seem to show up in the game (I haven't had the time to make sure that they're all there, but I think so...)

I've run into another problem...I had a saved game in Bridgeport, and when I loaded it yesterday, none of my sim icon picture things on the left side of the screen showed up and the motive bar that's normally green was blue and transparent...When I tried to switch characters with the space bar, two of the profile pictures would show up, but no matter what I did, the rest wouldn't come back. I tried going into build/buy mode, and Edit town, but it didn't do anything. (Should I make a new thread for this?)

I ahve spend hours reading today on all this glitches and see if there are work arounds for them. Apparently patches 1.31 and on are having this problem, specially with saved games. Have you tried reseting the entire Town with MC in regular game mod? It seems to be working for some. Let us know!
avatar
grieralexander
Posting Lord
Posting Lord

Windows version :
  • Windows 7

System architecture :
  • 64 bits (x64)

Favourite games : Sims 3; Assasins Creed; Rise of Nations; Age of Empires series; Titan Quest; Overlord
Male Posts : 248
Points : 2426
Reputation : 11
Join date : 2012-01-30
Location : Brazil

View user profile

Back to top Go down

Re: Problems with cats after installing showtime and store content oddities

Post by illusions on Fri 16 Mar 2012, 10:28

My computer died so I had so get it fixed. I won't be able to play sims for a while and I'll have to reinstall after I get my computer back so I'm hoping the problem will be gone after that...

illusions
Beginner
Beginner

Posts : 16
Points : 2120
Reputation : 0
Join date : 2012-03-12

View user profile

Back to top Go down

Re: Problems with cats after installing showtime and store content oddities

Post by ☠ ~ Aɳɳ ~ ☠ on Fri 16 Mar 2012, 10:30

Hello,

When you reinstall, be sure to follow this guide.

_________________
"Under sun and sky, we greet you warmly"
avatar
☠ ~ Aɳɳ ~ ☠
Forum Administratrix
First Lady of the Forum
Forum Administratrix First Lady of the Forum

Windows version :
  • Windows 8
  • Windows XP
  • Windows 10

System architecture :
  • 32 bits (x86)
  • 64 bits (x64)

Female Posts : 15118
Points : 20172
Reputation : 1460
Join date : 2011-05-31

View user profile

Back to top Go down

Re: Problems with cats after installing showtime and store content oddities

Post by illusions on Mon 19 Mar 2012, 20:49

Hello,

Everything works smoothly now, but there were a few hitches along the way. When I reinstalled, I followed the guide, but when I went to load a saved game, it would give me an error message saying "a serious error has occured while loading "...", it is strongly recommended that you restart the application." No matter which world I tried to load, it would give me that message. I tried removing the mods and download folders, but nothing worked. I tried following the guide that said to get rid of the windows 95 compatibility mode thing, but I couldn't find the "layers" after AppCompatFlags. Then I tried ErrorTrap, and it worked! The game finally loaded and the sim icons were back but the cat was missing so I reset her with mastercontroller at the cityhall and she came back. Now everything is working smoothly So happy!

Edit: It doesn't work again...It worked that one time, now none of my families will load. It keeps coming up with that "serious error while loading" thing...I can load a new game just fine though.

illusions
Beginner
Beginner

Posts : 16
Points : 2120
Reputation : 0
Join date : 2012-03-12

View user profile

Back to top Go down

Re: Problems with cats after installing showtime and store content oddities

Post by grieralexander on Tue 20 Mar 2012, 03:06

@illusions wrote:Hello,

Everything works smoothly now, but there were a few hitches along the way. When I reinstalled, I followed the guide, but when I went to load a saved game, it would give me an error message saying "a serious error has occured while loading "...", it is strongly recommended that you restart the application." No matter which world I tried to load, it would give me that message. I tried removing the mods and download folders, but nothing worked. I tried following the guide that said to get rid of the windows 95 compatibility mode thing, but I couldn't find the "layers" after AppCompatFlags. Then I tried ErrorTrap, and it worked! The game finally loaded and the sim icons were back but the cat was missing so I reset her with mastercontroller at the cityhall and she came back. Now everything is working smoothly So happy!

Edit: It doesn't work again...It worked that one time, now none of my families will load. It keeps coming up with that "serious error while loading" thing...I can load a new game just fine though.
One more question. Were you using any induction MODS in those saves? Like Story progression, AW Mod, etc.
Since they are not working try this and let us know. Go into your save games folder. You will see that you have two files of each saved game: The name you gave to the game example: Greek Isles.Sims3 and Greek Isles.Sims3.backup. Ok backup your saves games folder first! ok remove the .backup part from any backup you choose so that the backup will look like Name.Sims3 delete the original, since your original now is the backup and try loading it now. Let us know!
Also, are your saved sims working? CAS OK? I am trying to see if the corruption of the file is just limited to the save games and what caused it.
avatar
grieralexander
Posting Lord
Posting Lord

Windows version :
  • Windows 7

System architecture :
  • 64 bits (x64)

Favourite games : Sims 3; Assasins Creed; Rise of Nations; Age of Empires series; Titan Quest; Overlord
Male Posts : 248
Points : 2426
Reputation : 11
Join date : 2012-01-30
Location : Brazil

View user profile

Back to top Go down

Re: Problems with cats after installing showtime and store content oddities

Post by illusions on Tue 20 Mar 2012, 03:44

I'm not too sure what you mean by induction mod, but the mods that I have are the nraas debugenabler, mastercontroller, woohooer, overwatch, and errortrap. They should all be updated to the newest version (just changed them yesterday). I tried renaming a backup file and deleting the original, but when it was loading, it still gave me the error while loading thing...My saved sims and CAS seem to be working normally.

Also, I'm not sure if this means anything, but when I create a new family in a new game, after I pick a house and start playing, there'll be one of those pop-ups at the top right corner that says "Errortrap recorded: 2"...


Last edited by illusions on Tue 20 Mar 2012, 04:10; edited 1 time in total

illusions
Beginner
Beginner

Posts : 16
Points : 2120
Reputation : 0
Join date : 2012-03-12

View user profile

Back to top Go down

Re: Problems with cats after installing showtime and store content oddities

Post by grieralexander on Tue 20 Mar 2012, 03:53

@illusions wrote:I'm not too sure what you mean by induction mod, but the mods that I have are the nraas debugenabler, mastercontroller, woohooer, overwatch, and errortrap. They should all be updated to the newest version (just changed them yesterday). I tried renaming a backup file and deleting the original, but when it was loading, it still gave me the error while loading thing...My saved sims and CAS seem to be working normally.

Induction mods are like story progression,etc, that alter the way the vanilla game was suppose to. However if you are up to date there should be no problems in that area. Ok, then the problem is that your saves got corrupted by the patch. Ok another question? Are you able to save a new game and upload it again? I am asking to make certain that the problem is just with your old saves. Try and let me know.
avatar
grieralexander
Posting Lord
Posting Lord

Windows version :
  • Windows 7

System architecture :
  • 64 bits (x64)

Favourite games : Sims 3; Assasins Creed; Rise of Nations; Age of Empires series; Titan Quest; Overlord
Male Posts : 248
Points : 2426
Reputation : 11
Join date : 2012-01-30
Location : Brazil

View user profile

Back to top Go down

Re: Problems with cats after installing showtime and store content oddities

Post by illusions on Tue 20 Mar 2012, 06:27

I tried creating a new game, saving it, and loading it and it works just fine.

illusions
Beginner
Beginner

Posts : 16
Points : 2120
Reputation : 0
Join date : 2012-03-12

View user profile

Back to top Go down

Re: Problems with cats after installing showtime and store content oddities

Post by ☠ ~ Aɳɳ ~ ☠ on Tue 20 Mar 2012, 11:46

Hello,

The errortrap messages can occur regularly so that's normal.
The fix you're referring to only works when you've previously set the compatibility mode, it doesn't apply for other causes of the serious error.
At this point I'd suggest this:

1. Go to: (My) Documents\Electronic Arts\
2. Backup (Read: copy to an other folder) the folder called "The Sims 3".
3. Now completely remove the "The Sims 3" folder from: (My) Documents\Electronic Arts\
4. Start the game and see if it works now. Create a new save game and attempt to load it.

If that works, you can go back to the folder you backed up before and return your saves folder to the new The Sims 3 folder, and try to load them. If that works, you can do the same with the mods folder.

_________________
"Under sun and sky, we greet you warmly"
avatar
☠ ~ Aɳɳ ~ ☠
Forum Administratrix
First Lady of the Forum
Forum Administratrix First Lady of the Forum

Windows version :
  • Windows 8
  • Windows XP
  • Windows 10

System architecture :
  • 32 bits (x86)
  • 64 bits (x64)

Female Posts : 15118
Points : 20172
Reputation : 1460
Join date : 2011-05-31

View user profile

Back to top Go down

Re: Problems with cats after installing showtime and store content oddities

Post by illusions on Wed 21 Mar 2012, 03:49

When I removed the Sims 3 folder, loaded a new game, saved and then loaded it, it worked perfectly fine. But when I moved some old saved games into the new Sims 3 folder, the serious error message came up when I tried to load those. So there's a problem with the old saves then? Because I tried playing a game with the old Sims 3 folder, and it works like a charm. It's only when I try to load the old games that I'd saved before updating that I get that error message.

illusions
Beginner
Beginner

Posts : 16
Points : 2120
Reputation : 0
Join date : 2012-03-12

View user profile

Back to top Go down

Re: Problems with cats after installing showtime and store content oddities

Post by ☠ ~ Aɳɳ ~ ☠ on Wed 21 Mar 2012, 12:03

Hello,

And what if you saved a new game, and tried to load that later, does the same issue come up?

_________________
"Under sun and sky, we greet you warmly"
avatar
☠ ~ Aɳɳ ~ ☠
Forum Administratrix
First Lady of the Forum
Forum Administratrix First Lady of the Forum

Windows version :
  • Windows 8
  • Windows XP
  • Windows 10

System architecture :
  • 32 bits (x86)
  • 64 bits (x64)

Female Posts : 15118
Points : 20172
Reputation : 1460
Join date : 2011-05-31

View user profile

Back to top Go down

Re: Problems with cats after installing showtime and store content oddities

Post by Sponsored content


Sponsored content


Back to top Go down

Page 1 of 2 1, 2  Next

View previous topic View next topic Back to top


Permissions in this forum:
You cannot reply to topics in this forum