SIMS MEDIEVAL PROBLEM. [SOLVED]

View previous topic View next topic Go down

SIMS MEDIEVAL PROBLEM. [SOLVED]

Post by Alexa_Michelle on Wed 28 Mar 2012, 14:35

Hello,
I just downloaded the Sims Medieval, followed all the instructions correctly and the game loads fine till I reach the Kingdom Mode. But for some reason I'm not able to see the palace (maybe a glitch) and when I try to ‘Create A Monarch’ it just keeps on loading and loading. There never seems to be an end and when I try to ‘Start A New Game’ it doesn't even load (makes a sound and then nothing happens). I tried applying the fix (temporary too) and I went through a lot of posts but none solved my problem. I re-installed the game about 3 times. Please help, I’m dying to play this game!

Sorry , but I have a problem with the Pirate Bay too. Usually I download the file from '(GET TORRENT FILE)' link but its not there anymore. Only ' GET THIS TORRENT ' link is there and when I click it, uTorrent and the 'Add new Torrent' window pops up and when I click 'OK' it shows 'Invalid path specified. Please modify and try again.' Because of this I can't download anything from Pirate Bay anymore. Any ideas in fixing this?


Last edited by Alexa_Michelle on Wed 28 Mar 2012, 14:52; edited 1 time in total
avatar
Alexa_Michelle
Posting Nerd
Posting Nerd

Windows version :
  • Windows 8

System architecture :
  • 32 bits (x86)

Favourite games : The Sims ( 3,Medieval ) xP
Female Posts : 28
Points : 2030
Reputation : 0
Join date : 2012-03-06
Location : US

View user profile

Back to top Go down

Re: SIMS MEDIEVAL PROBLEM. [SOLVED]

Post by Aɾყα on Wed 28 Mar 2012, 14:43

Hello,

Do you also have the Pirates&Nobles expansion?

_________________




"Under sun and sky, we greet you warmly"

avatar
Aɾყα
Forum Administratrix
First Lady of the Forum
Forum Administratrix First Lady of the Forum

Windows version :
  • Windows 8
  • Windows XP
  • Windows 10

System architecture :
  • 32 bits (x86)
  • 64 bits (x64)

Female Posts : 15105
Points : 20009
Reputation : 1430
Join date : 2011-05-31

View user profile

Back to top Go down

Re: SIMS MEDIEVAL PROBLEM. [SOLVED]

Post by Alexa_Michelle on Wed 28 Mar 2012, 14:54

Lady ElDi wrote:Hello,

Do you also have the Pirates&Nobles expansion?

Yes. The fix only works if we have the expansion pack right?
avatar
Alexa_Michelle
Posting Nerd
Posting Nerd

Windows version :
  • Windows 8

System architecture :
  • 32 bits (x86)

Favourite games : The Sims ( 3,Medieval ) xP
Female Posts : 28
Points : 2030
Reputation : 0
Join date : 2012-03-06
Location : US

View user profile

Back to top Go down

Re: SIMS MEDIEVAL PROBLEM. [SOLVED]

Post by Aɾყα on Wed 28 Mar 2012, 15:00

Hello,

Yes, that's right.
Lets see... did you try tweaking your graphics options?
As for the Pirate bay, they are only using magnet links these days, you should be able to use them if your torrent client is up to date.

_________________




"Under sun and sky, we greet you warmly"

avatar
Aɾყα
Forum Administratrix
First Lady of the Forum
Forum Administratrix First Lady of the Forum

Windows version :
  • Windows 8
  • Windows XP
  • Windows 10

System architecture :
  • 32 bits (x86)
  • 64 bits (x64)

Female Posts : 15105
Points : 20009
Reputation : 1430
Join date : 2011-05-31

View user profile

Back to top Go down

Re: SIMS MEDIEVAL PROBLEM. [SOLVED]

Post by Alexa_Michelle on Wed 28 Mar 2012, 15:58

Its up to date but I still have the problem and..
how do I tweak it?


Last edited by Alexa_Michelle on Wed 28 Mar 2012, 17:01; edited 1 time in total
avatar
Alexa_Michelle
Posting Nerd
Posting Nerd

Windows version :
  • Windows 8

System architecture :
  • 32 bits (x86)

Favourite games : The Sims ( 3,Medieval ) xP
Female Posts : 28
Points : 2030
Reputation : 0
Join date : 2012-03-06
Location : US

View user profile

Back to top Go down

Re: SIMS MEDIEVAL PROBLEM. [SOLVED]

Post by Aɾყα on Wed 28 Mar 2012, 16:04

Hello,

In the game options, try lowering the video quality setting etc.

_________________




"Under sun and sky, we greet you warmly"

avatar
Aɾყα
Forum Administratrix
First Lady of the Forum
Forum Administratrix First Lady of the Forum

Windows version :
  • Windows 8
  • Windows XP
  • Windows 10

System architecture :
  • 32 bits (x86)
  • 64 bits (x64)

Female Posts : 15105
Points : 20009
Reputation : 1430
Join date : 2011-05-31

View user profile

Back to top Go down

Re: SIMS MEDIEVAL PROBLEM. [SOLVED]

Post by Alexa_Michelle on Wed 28 Mar 2012, 16:59

Even the options won't come up. Same thing when I try to start a new game - makes a sound and then nothing happens.
avatar
Alexa_Michelle
Posting Nerd
Posting Nerd

Windows version :
  • Windows 8

System architecture :
  • 32 bits (x86)

Favourite games : The Sims ( 3,Medieval ) xP
Female Posts : 28
Points : 2030
Reputation : 0
Join date : 2012-03-06
Location : US

View user profile

Back to top Go down

Re: SIMS MEDIEVAL PROBLEM. [SOLVED]

Post by Aɾყα on Wed 28 Mar 2012, 17:04

Hello,

I'm not sure what to tell you at this point, we don't get a lot of medieval problems, so please wait for Admin's suggestion.

_________________




"Under sun and sky, we greet you warmly"

avatar
Aɾყα
Forum Administratrix
First Lady of the Forum
Forum Administratrix First Lady of the Forum

Windows version :
  • Windows 8
  • Windows XP
  • Windows 10

System architecture :
  • 32 bits (x86)
  • 64 bits (x64)

Female Posts : 15105
Points : 20009
Reputation : 1430
Join date : 2011-05-31

View user profile

Back to top Go down

Re: SIMS MEDIEVAL PROBLEM. [SOLVED]

Post by Alexa_Michelle on Wed 28 Mar 2012, 17:06

Ok. Hope I don't have to wait too long.
avatar
Alexa_Michelle
Posting Nerd
Posting Nerd

Windows version :
  • Windows 8

System architecture :
  • 32 bits (x86)

Favourite games : The Sims ( 3,Medieval ) xP
Female Posts : 28
Points : 2030
Reputation : 0
Join date : 2012-03-06
Location : US

View user profile

Back to top Go down

Re: SIMS MEDIEVAL PROBLEM. [SOLVED]

Post by lolz-4-life on Wed 28 Mar 2012, 17:20

Most of the time he's back in the evening.
But there is a time difference

_________________

"Feel free to ask anything you want!
There are no stupid questions only stupid answers!"



Lolz-4-life


Forum Developer






How to install The Sims 3 correctly: http://games4theworld.bestgoo.com/t1171-must-read-how-to-install-the-sims-3-correctly-must-read
The Sims 3 Ultimate Fix: http://games4theworld.bestgoo.com/t752-the-sims-3-ultimate-fix-should-fix-most-of-your-problems
Áll ® Games4theworld Downloads can be found on: http://www.games4theworld.org and thepiratebay.org/user/games4theworld

lolz-4-life
Developer
Some kind of Einstein
Developer Some kind of Einstein

Windows version :
  • Windows 8
  • Windows 7
  • Windows Vista
  • Windows XP
  • Windows 98
  • Windows 95

System architecture :
  • 32 bits (x86)
  • 64 bits (x64)

Favourite games : The Sims 3, The Saboteur, Tropico
Male Posts : 127
Points : 2123
Reputation : 16
Join date : 2012-03-26
Age : 22
Location : The Netherlands

View user profile

Back to top Go down

Re: SIMS MEDIEVAL PROBLEM. [SOLVED]

Post by Alexa_Michelle on Thu 29 Mar 2012, 19:05

Any solution yet?
avatar
Alexa_Michelle
Posting Nerd
Posting Nerd

Windows version :
  • Windows 8

System architecture :
  • 32 bits (x86)

Favourite games : The Sims ( 3,Medieval ) xP
Female Posts : 28
Points : 2030
Reputation : 0
Join date : 2012-03-06
Location : US

View user profile

Back to top Go down

Re: SIMS MEDIEVAL PROBLEM. [SOLVED]

Post by Aɾყα on Fri 30 Mar 2012, 12:09

Hello,

I will bring this topic to his attention.

_________________




"Under sun and sky, we greet you warmly"

avatar
Aɾყα
Forum Administratrix
First Lady of the Forum
Forum Administratrix First Lady of the Forum

Windows version :
  • Windows 8
  • Windows XP
  • Windows 10

System architecture :
  • 32 bits (x86)
  • 64 bits (x64)

Female Posts : 15105
Points : 20009
Reputation : 1430
Join date : 2011-05-31

View user profile

Back to top Go down

Re: SIMS MEDIEVAL PROBLEM. [SOLVED]

Post by Adwomin on Fri 30 Mar 2012, 15:39

Hello,

I'm sorry for the late reply, I wanted to reply yesterday, but I had to leave in a hurry.
Please update your Graphic Card's drivers. If you do not know where to find me, please post your GPU's model, brand and your OS (Also whether it's 32-bit or 64-bit), so I can provide you the download link.

_________________
Bonsoir, friend.


~ Nobody's gril. ~
avatar
Adwomin
free society
free society

Windows version :
  • Windows 8
  • Windows 7

System architecture :
  • 32 bits (x86)
  • 64 bits (x64)

Favourite games : GTA Series, Cities: Skylines, Prison Architect, Borderlands series
Female Posts : 19211
Points : 1026346
Reputation : 2242
Join date : 2010-03-12
Age : 15
Location : Del Perro Heights

View user profile https://www.games4theworld.org

Back to top Go down

Re: SIMS MEDIEVAL PROBLEM. [SOLVED]

Post by Alexa_Michelle on Fri 30 Mar 2012, 18:29

I have Windows 7 Professional ( 32-bit )
ATI Radeon HD 5670
avatar
Alexa_Michelle
Posting Nerd
Posting Nerd

Windows version :
  • Windows 8

System architecture :
  • 32 bits (x86)

Favourite games : The Sims ( 3,Medieval ) xP
Female Posts : 28
Points : 2030
Reputation : 0
Join date : 2012-03-06
Location : US

View user profile

Back to top Go down

Re: SIMS MEDIEVAL PROBLEM. [SOLVED]

Post by Adwomin on Fri 30 Mar 2012, 20:57

Hello,

Thank you!
This is the one you need: http://www2.ati.com/drivers/12-3_vista_win7_32_dd_ccc.exe
It has been updated just 2 days ago, so it's certainly worth updating.
After the updating finished, don't forget to restart your PC and then test the game.

Good luck!

Ps. If possible, choose "Clean installation" during the installation process.

_________________
Bonsoir, friend.


~ Nobody's gril. ~
avatar
Adwomin
free society
free society

Windows version :
  • Windows 8
  • Windows 7

System architecture :
  • 32 bits (x86)
  • 64 bits (x64)

Favourite games : GTA Series, Cities: Skylines, Prison Architect, Borderlands series
Female Posts : 19211
Points : 1026346
Reputation : 2242
Join date : 2010-03-12
Age : 15
Location : Del Perro Heights

View user profile https://www.games4theworld.org

Back to top Go down

Re: SIMS MEDIEVAL PROBLEM. [SOLVED]

Post by Alexa_Michelle on Sun 01 Apr 2012, 14:31

Ahh.. Thanks a lot Admin and Lady Eldi !!
It worked Very Happy
I'm the most happiest person in the world right now.
Thanks a lot again!

//EDIT

Any ideas in fixing the problem I have with Pirate Bay?
I can't download games from Games4theworld anymore.
Any help would be brilliant!
avatar
Alexa_Michelle
Posting Nerd
Posting Nerd

Windows version :
  • Windows 8

System architecture :
  • 32 bits (x86)

Favourite games : The Sims ( 3,Medieval ) xP
Female Posts : 28
Points : 2030
Reputation : 0
Join date : 2012-03-06
Location : US

View user profile

Back to top Go down

Re: SIMS MEDIEVAL PROBLEM. [SOLVED]

Post by Aɾყα on Sun 01 Apr 2012, 20:00

Hello,

Are you using the latest µtorrent version?

_________________




"Under sun and sky, we greet you warmly"

avatar
Aɾყα
Forum Administratrix
First Lady of the Forum
Forum Administratrix First Lady of the Forum

Windows version :
  • Windows 8
  • Windows XP
  • Windows 10

System architecture :
  • 32 bits (x86)
  • 64 bits (x64)

Female Posts : 15105
Points : 20009
Reputation : 1430
Join date : 2011-05-31

View user profile

Back to top Go down

Re: SIMS MEDIEVAL PROBLEM. [SOLVED]

Post by Alexa_Michelle on Tue 03 Apr 2012, 10:30

Yes , uTorrent 3.1.2
avatar
Alexa_Michelle
Posting Nerd
Posting Nerd

Windows version :
  • Windows 8

System architecture :
  • 32 bits (x86)

Favourite games : The Sims ( 3,Medieval ) xP
Female Posts : 28
Points : 2030
Reputation : 0
Join date : 2012-03-06
Location : US

View user profile

Back to top Go down

Re: SIMS MEDIEVAL PROBLEM. [SOLVED]

Post by Adwomin on Tue 03 Apr 2012, 17:05

Hello,

When you download the .magnet file, it opens in your uTorrent client and you do not see any files, right?
Just click "OK" and let it "start". It might show idle for a few minutes, but after a while it should start downloading. It just takes a little bit (Read: a lot) more time than the usual .torrent files.

Ps. If you download from www.games4theworld.org , you'll still download the actual .torrent file, instead of .magnet files.

_________________
Bonsoir, friend.


~ Nobody's gril. ~
avatar
Adwomin
free society
free society

Windows version :
  • Windows 8
  • Windows 7

System architecture :
  • 32 bits (x86)
  • 64 bits (x64)

Favourite games : GTA Series, Cities: Skylines, Prison Architect, Borderlands series
Female Posts : 19211
Points : 1026346
Reputation : 2242
Join date : 2010-03-12
Age : 15
Location : Del Perro Heights

View user profile https://www.games4theworld.org

Back to top Go down

Re: SIMS MEDIEVAL PROBLEM. [SOLVED]

Post by Alexa_Michelle on Wed 04 Apr 2012, 15:09

Yeah. But I won't be able to select the files that I want to download.
But whatever , I don't care now. I got the game to work Very Happy
That's all what I wanted. Thanks Admin.
avatar
Alexa_Michelle
Posting Nerd
Posting Nerd

Windows version :
  • Windows 8

System architecture :
  • 32 bits (x86)

Favourite games : The Sims ( 3,Medieval ) xP
Female Posts : 28
Points : 2030
Reputation : 0
Join date : 2012-03-06
Location : US

View user profile

Back to top Go down

Re: SIMS MEDIEVAL PROBLEM. [SOLVED]

Post by Adwomin on Wed 04 Apr 2012, 15:15

Hello,

There's nothing you can change, it's only one .rar file. (If downloaded from Games4theworld)

Anyhow, enjoy playing and please let us know if you need any more assistance!

_________________
Bonsoir, friend.


~ Nobody's gril. ~
avatar
Adwomin
free society
free society

Windows version :
  • Windows 8
  • Windows 7

System architecture :
  • 32 bits (x86)
  • 64 bits (x64)

Favourite games : GTA Series, Cities: Skylines, Prison Architect, Borderlands series
Female Posts : 19211
Points : 1026346
Reputation : 2242
Join date : 2010-03-12
Age : 15
Location : Del Perro Heights

View user profile https://www.games4theworld.org

Back to top Go down

View previous topic View next topic Back to top


Permissions in this forum:
You cannot reply to topics in this forum