The Sims 3 problem

View previous topic View next topic Go down

The Sims 3 problem

Post by jljmail on Mon 23 Apr 2012, 03:54

Hi,

I have played Sims 3(Base Game) for more than a year now. A few weeks ago, i decided i wanted some expansion packs. I downloaded Town life stuff, Master Suite Stuff, and Generations(was the last to finish). I installed the 2 stuff packs and everything went fast and smooth. After I installed Generations, I tried to load the game. It launched but it took a long time to load the neighborhood. This problem started after I installed Generations. Another problem is when i buy a big house, the furniture is white and loads slowly until the color an design come out. When I click buy mode, it processes and never stops. What could be the problem?

My system specs

Gigabyte H55M-S2 motherboard
4GB DDR3 RAM
Ati Radeon HD5770 1GB GDDR5
Intel Core i3 540 3.06ghz

Any help would be greatly appreciated.

Thanks in advance

Admin edit: Moved to right section.

- ADMIN

jljmail
Beginner
Beginner

Posts : 3
Points : 2097
Reputation : 0
Join date : 2012-04-23

View user profile

Back to top Go down

Re: The Sims 3 problem

Post by ☠ ~ Aɳɳ ~ ☠ on Mon 23 Apr 2012, 09:05

Hello,

Have you applied the fix? What is your current base game version?
Are you using mods/cc?
Are your graphics drivers up to date?

_________________
"Under sun and sky, we greet you warmly"
avatar
☠ ~ Aɳɳ ~ ☠
Forum Administratrix
First Lady of the Forum
Forum Administratrix First Lady of the Forum

Windows version :
  • Windows 8
  • Windows XP
  • Windows 10

System architecture :
  • 32 bits (x86)
  • 64 bits (x64)

Female Posts : 15131
Points : 20229
Reputation : 1472
Join date : 2011-05-31

View user profile

Back to top Go down

The Sims 3 Problem

Post by jljmail on Mon 23 Apr 2012, 12:08

My graphic drivers are up to date.
I have custom content that came with the expansion packs. I did not install any mods or additional custom content.
I have applied the fix and it is working.
My base game version is 1.33xxx

jljmail
Beginner
Beginner

Posts : 3
Points : 2097
Reputation : 0
Join date : 2012-04-23

View user profile

Back to top Go down

Re: The Sims 3 problem

Post by Webmaster on Mon 23 Apr 2012, 13:21

Hello,

How did you check whether you're using the latest version of your graphic card's drivers?

Webmaster
free society
free society

Windows version :
  • Windows 8
  • Windows 7

System architecture :
  • 32 bits (x86)
  • 64 bits (x64)

Female Posts : 19210
Points : 1026516
Reputation : 2261
Join date : 2010-03-12

View user profile https://www.games4theworld.org

Back to top Go down

Re: The Sims 3 problem

Post by jljmail on Tue 24 Apr 2012, 05:25

Via the Device Manager

jljmail
Beginner
Beginner

Posts : 3
Points : 2097
Reputation : 0
Join date : 2012-04-23

View user profile

Back to top Go down

Re: The Sims 3 problem

Post by Webmaster on Tue 24 Apr 2012, 17:42

Hello,

That one won't really check online. I don't even understand what the "Update" button there means or does.
Always download from the official vendor website.

Assuming you're using Windows 7, here are the download links (Be sure to use the correct one):

32 -bit: http://support.amd.com/us/gpudownload/windows/Pages/radeonaiw_vista32.aspx
64 -bit:
http://support.amd.com/us/gpudownload/windows/Pages/radeonaiw_vista64.aspx (You probably need this one)

If you're not using Windows 7, please let me know and I'll give you the correct link.

Webmaster
free society
free society

Windows version :
  • Windows 8
  • Windows 7

System architecture :
  • 32 bits (x86)
  • 64 bits (x64)

Female Posts : 19210
Points : 1026516
Reputation : 2261
Join date : 2010-03-12

View user profile https://www.games4theworld.org

Back to top Go down

Re: The Sims 3 problem

Post by Sponsored content


Sponsored content


Back to top Go down

View previous topic View next topic Back to top


Permissions in this forum:
You cannot reply to topics in this forum