Expansion content isn't included when I start and play the game. [SOLVED]

View previous topic View next topic Go down

Expansion content isn't included when I start and play the game. [SOLVED]

Post by IvIDes on Fri 04 May 2012, 17:33

So, background information for if it might help, you could skip directly to the actual problem if you so desire ;p

I downloaded the full (up to and including town life stuff) sims 3 package with a torrent. After I installed the basegame, the launcher wouldn't start, but it would with the Ts3.exe. (I've not downloaded ea/origin or had to use it) So I continued the installation of the package, downloaded a manual 1.33.2 patch update, so I updated it, and continued installing steps 1 - 9. I then replaced the files with all the fix files from the fix folder, and ofcourse (re)placed the ts3w.exe and the ts3hostthing.dll in the base game folder. (from #crack). Tried starting the launcher, wouldn't work, tried starting it through ts3w.exe, would work, but it didn't show any background in the initial loading screen, the text under the loading bar seemed to replicate itself while scrolling across the screen. I got to the main menu, saw that it missed some text, but hell, I proceded anyways, and my game would crash when loading any world file (around 1/6th of the loading bar).

Tried some of the fixes from the topic which is included on this forum, wouldn't work, decided to stop giving fucks, and (only) uninstalled the base game. (the rest of the games remained installed)
I then installed Origin. Origin said that I magically had ts3 (only the base game) in my possession (I can recall buying and installing ts3 somewhere in 2009). So.. whatever, I downloaded and installed the game through Origin, and once again, the sims3launcer wouldn't work (the screen where you can buy stuff and such), but it would through Ts3. It worked, played about 1 hour of it, decided I wanted more, and started installing the expansion packs 1 by 1 (because I wanted to know which expansion pack caused the game to crash when loading any world). When installing the expansion packs (from your full sims 3 package I downloaded earlier) I first had to uninstall it, and then install it again. Did that with world adventures, replaced the files from fix folder into the adventure world's bin folder, started the ts3ep01 exe (or whatever it was) from the expanion's folder. The game would start. great. still the base game's loading screen.. weird.. but when playing the game, it didn't have any of the additional content world adventures included.. so I quit the game, tried to install the high end loft stuff expansion, replaced the fix files, started the game, and once again, no high end lof stuff content.

So I came here, after I read the FAQ ofcourse, in which I couldn't find any solution to the problem.

I hope it's a bit.. understandable..


Last edited by IvIDes on Sun 06 May 2012, 17:24; edited 1 time in total (Reason for editing : solved)

IvIDes
Beginner
Beginner

Posts : 9
Points : 1940
Reputation : 0
Join date : 2012-05-04

View user profile

Back to top Go down

Re: Expansion content isn't included when I start and play the game. [SOLVED]

Post by Aɾყα on Fri 04 May 2012, 19:58

Hello,

G4TW doesn't have a complete The Sims 3 package, but I believe someone has compiled and uploaded all G4TW torrents up to town Life if I'm not mistaken.
They should still be unmodified though, so they should work much the same.
My suggestion would be to uninstall everything for the moment, and restart the pc. Then, start installing the game according to this guide and you should be ok.
Let us know if you need any assistance.

_________________




"Under sun and sky, we greet you warmly"

avatar
Aɾყα
Forum Administratrix
First Lady of the Forum
Forum Administratrix First Lady of the Forum

Windows version :
  • Windows 8
  • Windows XP
  • Windows 10

System architecture :
  • 32 bits (x86)
  • 64 bits (x64)

Female Posts : 15105
Points : 20009
Reputation : 1430
Join date : 2011-05-31

View user profile

Back to top Go down

Re: Expansion content isn't included when I start and play the game. [SOLVED]

Post by IvIDes on Sun 06 May 2012, 12:40

Loads of love and thanks ;d, it worked.. now, for another problem.. My sims3 launcher won't work? the game works fine when I start it through ts3w.exe though, but I'd just like to install those store updates aswell :p

IvIDes
Beginner
Beginner

Posts : 9
Points : 1940
Reputation : 0
Join date : 2012-05-04

View user profile

Back to top Go down

Re: Expansion content isn't included when I start and play the game. [SOLVED]

Post by Aɾყα on Sun 06 May 2012, 13:03

Hello,

You can also try by doubleclicking them, or install them with an alternative installer like cc magic.

_________________




"Under sun and sky, we greet you warmly"

avatar
Aɾყα
Forum Administratrix
First Lady of the Forum
Forum Administratrix First Lady of the Forum

Windows version :
  • Windows 8
  • Windows XP
  • Windows 10

System architecture :
  • 32 bits (x86)
  • 64 bits (x64)

Female Posts : 15105
Points : 20009
Reputation : 1430
Join date : 2011-05-31

View user profile

Back to top Go down

Re: Expansion content isn't included when I start and play the game. [SOLVED]

Post by IvIDes on Sun 06 May 2012, 13:35

Hmm, been reading the instructions, can't really make much of it, I get stuck on the sims 3 downloads folder, I don't seem to have one/can't find one, not sure if I should create one manually and where, do you have any idea?

IvIDes
Beginner
Beginner

Posts : 9
Points : 1940
Reputation : 0
Join date : 2012-05-04

View user profile

Back to top Go down

Re: Expansion content isn't included when I start and play the game. [SOLVED]

Post by Aɾყα on Sun 06 May 2012, 14:51

Hello,

The downloads folder should be found in (My) Documents\Electronic Arts\The Sims 3.

_________________




"Under sun and sky, we greet you warmly"

avatar
Aɾყα
Forum Administratrix
First Lady of the Forum
Forum Administratrix First Lady of the Forum

Windows version :
  • Windows 8
  • Windows XP
  • Windows 10

System architecture :
  • 32 bits (x86)
  • 64 bits (x64)

Female Posts : 15105
Points : 20009
Reputation : 1430
Join date : 2011-05-31

View user profile

Back to top Go down

Re: Expansion content isn't included when I start and play the game. [SOLVED]

Post by IvIDes on Sun 06 May 2012, 17:16

Everything sorted now with your help! Thanks a bunch!

IvIDes
Beginner
Beginner

Posts : 9
Points : 1940
Reputation : 0
Join date : 2012-05-04

View user profile

Back to top Go down

Re: Expansion content isn't included when I start and play the game. [SOLVED]

Post by Aɾყα on Sun 06 May 2012, 18:21

Hello,

You're welcome.
Don’t hesitate to post if you have questions or problems again!
Happy simming The Sims Plumbob 1 topic closed.


_________________




"Under sun and sky, we greet you warmly"

avatar
Aɾყα
Forum Administratrix
First Lady of the Forum
Forum Administratrix First Lady of the Forum

Windows version :
  • Windows 8
  • Windows XP
  • Windows 10

System architecture :
  • 32 bits (x86)
  • 64 bits (x64)

Female Posts : 15105
Points : 20009
Reputation : 1430
Join date : 2011-05-31

View user profile

Back to top Go down

View previous topic View next topic Back to top


Permissions in this forum:
You cannot reply to topics in this forum