I hate to sound like a broken record here but (Service Initialization failed).[SOLVED]

View previous topic View next topic Go down

I hate to sound like a broken record here but (Service Initialization failed).[SOLVED]

Post by BassClef on Sun 05 Aug 2012, 16:17

Greetings,
Before posting here, I've tried my best to find a solution from the numerous threads that have already been created for this particular error. I did everything word to word that admin and lady eidi suggested in those posts, but in vain, as the conclusion always resulted with a scrambled screen and the error message. Maybe this issue is different and may need an alternate solution to the ones already given.

I installed the Sims 3 reloaded base game from a different up-loader as I read that G4TW still needs to arrange for a Mac base game installer. Apart from that, I've installed World Adventures, High End Loft Stuff, Ambitions, and Town life stuff, all downloaded from G4TW. Before I installed the expansions and stuff packs, I manually patched the base game with the latest 1.36 patch. Once everything was installed, I cracked the game with the Ultimate fix.

The Sims 3 launcher starts up with out any issues, but when I click on the play button, I get a blue screen with the Sims 3 Plumbob, followed by a black screen, followed by a scrambled windowed screen showing me the (service initialization failed) error message, and then asks me to debug it. I wish I could do that.

Experts may also want to ask me if I have any mods and cc installed. I do intend to, but currently there are no mods and cc installed in the game.

I've run out of options here, as I've reinstalled the game thrice, re-downloaded the patch and ultimate fix numerous times, made sure that I only used winrar to unarchive all the .rar files.

My hope lies in the knowledge, that I may get my answer and solution here, in this forum.

Warm Regards,
BassClef

_________________
avatar
BassClef
Beginner
Beginner

Windows version :
  • Windows 7

System architecture :
  • 64 bits (x64)

Favourite games : Sims-3, Walking dead, Call of Duty series
Male Posts : 7
Points : 1929
Reputation : 0
Join date : 2012-07-30
Location : India

View user profile

Back to top Go down

Re: I hate to sound like a broken record here but (Service Initialization failed).[SOLVED]

Post by Adwomin on Sun 05 Aug 2012, 19:11

Hello,

Welcome to the Forum!
To be honest, I do not have a lot of Mac knowledge, but I'll try to help.

Install all the expansions you want and then re-apply the 1.36 manual patch, as found here: http://games4theworld.bestgoo.com/t3597-can-t-update-the-sims-3-to-v136-fix-manual-patch (If you didn't use this one last time, download this specific patch!)
After patching the game to the latest version, only apply the "# Crack", found in the Mac version of the Ultimate Fix, here: http://games4theworld.bestgoo.com/t752-the-sims-3-ultimate-fix-should-fix-most-of-your-problems (Please RE-DOWNLOAD the Fix, prior to doing so!)

Let us know how it went. Good luck!

_________________
Bonsoir, friend.


~ Nobody's gril. ~
avatar
Adwomin
free society
free society

Windows version :
  • Windows 8
  • Windows 7

System architecture :
  • 32 bits (x86)
  • 64 bits (x64)

Favourite games : GTA Series, Cities: Skylines, Prison Architect, Borderlands series
Female Posts : 19211
Points : 1026424
Reputation : 2253
Join date : 2010-03-12
Age : 16
Location : Del Perro Heights

View user profile https://www.games4theworld.org

Back to top Go down

Re: I hate to sound like a broken record here but (Service Initialization failed).[SOLVED]

Post by BassClef on Sun 05 Aug 2012, 20:15

Greetings
Dear admin,
Thank you for the prompt reply, I am aware of the fact that you do not possess a mac and therefore have difficulty in helping out distressed souls like me. However, your willingness to help nonetheless is admirable and should be acknowledged.
The links that you have provided are familiar, yes, these are the same files that I have downloaded. However I haven't re-patched the game after installing the expansion packs like you have suggested. I shall do the same and then revert back to you with the conclusion. Thanks again for your help.
BassClef.

_________________
avatar
BassClef
Beginner
Beginner

Windows version :
  • Windows 7

System architecture :
  • 64 bits (x64)

Favourite games : Sims-3, Walking dead, Call of Duty series
Male Posts : 7
Points : 1929
Reputation : 0
Join date : 2012-07-30
Location : India

View user profile

Back to top Go down

Re: I hate to sound like a broken record here but (Service Initialization failed).[SOLVED]

Post by Adwomin on Sun 05 Aug 2012, 20:27

Hello,

You're always welcome!
Try exactly as suggested and let us know how it went. Good luck!

_________________
Bonsoir, friend.


~ Nobody's gril. ~
avatar
Adwomin
free society
free society

Windows version :
  • Windows 8
  • Windows 7

System architecture :
  • 32 bits (x86)
  • 64 bits (x64)

Favourite games : GTA Series, Cities: Skylines, Prison Architect, Borderlands series
Female Posts : 19211
Points : 1026424
Reputation : 2253
Join date : 2010-03-12
Age : 16
Location : Del Perro Heights

View user profile https://www.games4theworld.org

Back to top Go down

Re: I hate to sound like a broken record here but (Service Initialization failed).[SOLVED]

Post by ☠ ~ Aɳɳ ~ ☠ on Sun 05 Aug 2012, 21:04

Hello,

What kind of errorcode are you getting with the "service initialization failed" message? I may not know anything about MAC, but the numeric codes usually indicate the same problem on MAC as it does on PC.
I'm also wondering if the problem could have anything to do with outdated graphicsdrivers, going on the description of events.

_________________
"Under sun and sky, we greet you warmly"

avatar
☠ ~ Aɳɳ ~ ☠
Forum Administratrix
First Lady of the Forum
Forum Administratrix First Lady of the Forum

Windows version :
  • Windows 8
  • Windows XP
  • Windows 10

System architecture :
  • 32 bits (x86)
  • 64 bits (x64)

Female Posts : 15112
Points : 20090
Reputation : 1437
Join date : 2011-05-31

View user profile

Back to top Go down

Re: I hate to sound like a broken record here but (Service Initialization failed).[SOLVED]

Post by BassClef on Mon 06 Aug 2012, 08:23

Greetings,
Dear Admin and Lady Eidi,
It is with immense pleasure I'd like to inform that the game started up with out any issues, after I followed your suggested steps. Lady Eidi, I don't know if this is important anymore but the error code I received earlier was (0x024e424f) I forgot to mention it in my first post, apologies Embarassed

For the benefit of mac users who might be reading this thread for a solution, here is what I did:

1) Installed base game (downloaded Sims3 Reloaded from a different uploader on the internet)
2) Downloaded and installed the manual patch from here
3) Installed the Sims 3 expansion packs (World Adventures, HELS, Ambitions, TLS)
4) Installed the manual patch again (As suggested by Admin)
5) Downloaded and Cracked the game using ultimate fix from here
6) Started up the game to check if it's working, and it worked.

Admin and Lady Eidi, I've gone through so many of your posts, I appreciate and acknowledge the effort that the both of you put in for the benefit of others. Salutations to you.
Warm Regards,
BassClef.

_________________
avatar
BassClef
Beginner
Beginner

Windows version :
  • Windows 7

System architecture :
  • 64 bits (x64)

Favourite games : Sims-3, Walking dead, Call of Duty series
Male Posts : 7
Points : 1929
Reputation : 0
Join date : 2012-07-30
Location : India

View user profile

Back to top Go down

Re: I hate to sound like a broken record here but (Service Initialization failed).[SOLVED]

Post by ☠ ~ Aɳɳ ~ ☠ on Mon 06 Aug 2012, 09:44

Hello,

Thank you for your nice words and you're welcome Smile
The error code indicates an outdated crack, or an outdated mod. Usually we find it's the crack, and it was probably the same for you, looking at the steps you took.
Don't hesitate to post if you have questions or problems again.
Happy simming The Sims Plumbob 1 topic closed.

_________________
"Under sun and sky, we greet you warmly"

avatar
☠ ~ Aɳɳ ~ ☠
Forum Administratrix
First Lady of the Forum
Forum Administratrix First Lady of the Forum

Windows version :
  • Windows 8
  • Windows XP
  • Windows 10

System architecture :
  • 32 bits (x86)
  • 64 bits (x64)

Female Posts : 15112
Points : 20090
Reputation : 1437
Join date : 2011-05-31

View user profile

Back to top Go down

View previous topic View next topic Back to top


Permissions in this forum:
You cannot reply to topics in this forum