Mass Effect 1 problem. [SOLVED]

View previous topic View next topic Go down

Mass Effect 1 problem. [SOLVED]

Post by AGPPyroman on Fri 10 Dec 2010, 02:36

Alright, So I downloaded and extracted Mass Effect fine, everything worked okay. Then when I tried to install it everything went smooth until after I entered the installation code. After I entered the code I got a window saying I was missing a couple .dll files. Then the install aborted and now everytime I try to install the game it says that the installation failed and click finish to exit. Also I no longer get the pop-up saying which files I'm missing it just jumps straight to "the installation failed". I've also tried re-extracting the rar without success. Any reccommendations?

Regards, AGPPyroman

AGPPyroman
Beginner
Beginner

Posts : 6
Points : 2458
Reputation : 0
Join date : 2010-12-10

View user profile

Back to top Go down

Re: Mass Effect 1 problem. [SOLVED]

Post by Adwomin on Fri 10 Dec 2010, 17:55

Hello,

Please try the following:

1. Open the .rar file you Downloaded using WinRar, which can be Downloaded from www.games4theworld.org . (If you use any other Software, the files will get messed up)
2. Select áll the files in the .rar file and drag & drop them to a folder on your Desktop.
3. Open that folder on your Desktop and read the included "# Installation Guide.txt" on how to Install the Game.
4. See if it works now.

_________________
Bonsoir, friend.


~ Nobody's gril. ~
avatar
Adwomin
free society
free society

Windows version :
  • Windows 8
  • Windows 7

System architecture :
  • 32 bits (x86)
  • 64 bits (x64)

Favourite games : GTA Series, Cities: Skylines, Prison Architect, Borderlands series
Female Posts : 19211
Points : 1026352
Reputation : 2242
Join date : 2010-03-12
Age : 15
Location : Del Perro Heights

View user profile https://www.games4theworld.org

Back to top Go down

Re: Mass Effect 1 problem. [SOLVED]

Post by AGPPyroman on Fri 10 Dec 2010, 19:34

It installed fine now, thanks!

But if you wouldn't mind answering one more question.
What is the difference of dragging and droping the files rather then just extracting them?

//EDIT

Also now it won't run.

I try I start the program and it brings up the typical pop-up with the options like play, uninstall, support, configurations... When I click play it open up the config utility (probably 'cause it's the first time thing). but the config utility crashes every every time.

AGPPyroman
Beginner
Beginner

Posts : 6
Points : 2458
Reputation : 0
Join date : 2010-12-10

View user profile

Back to top Go down

Re: Mass Effect 1 problem. [SOLVED]

Post by Adwomin on Sat 11 Dec 2010, 12:25

@AGPPyroman wrote:It installed fine now, thanks!

But if you wouldn't mind answering one more question.
What is the difference of dragging and droping the files rather then just extracting them?

//EDIT

Also now it won't run.

I try I start the program and it brings up the typical pop-up with the options like play, uninstall, support, configurations... When I click play it open up the config utility (probably 'cause it's the first time thing). but the config utility crashes every every time.

Hello,

Well, because some people don't know the term "extracting", I just tell them like that, since it sounds more simple. (Drag & drop)

Try to restart your PC. At which part does the config utility crash? When you click "Play"? Do you get an error? Try to lower the settings.

_________________
Bonsoir, friend.


~ Nobody's gril. ~
avatar
Adwomin
free society
free society

Windows version :
  • Windows 8
  • Windows 7

System architecture :
  • 32 bits (x86)
  • 64 bits (x64)

Favourite games : GTA Series, Cities: Skylines, Prison Architect, Borderlands series
Female Posts : 19211
Points : 1026352
Reputation : 2242
Join date : 2010-03-12
Age : 15
Location : Del Perro Heights

View user profile https://www.games4theworld.org

Back to top Go down

Re: Mass Effect 1 problem. [SOLVED]

Post by AGPPyroman on Sat 11 Dec 2010, 18:28

Restarting does nothing, it still crashes. Also the settings aren't the problem. I can run Crysis, Dragon Age, Starcraft 2 all maxed settings.

I've also tried a different video card to no avail.

This is what happens every time I click play.



Thanks for your help.

Regards, AGPPyroman

AGPPyroman
Beginner
Beginner

Posts : 6
Points : 2458
Reputation : 0
Join date : 2010-12-10

View user profile

Back to top Go down

Re: Mass Effect 1 problem. [SOLVED]

Post by Adwomin on Sun 12 Dec 2010, 11:54

Hello,

Go to: C:\Program Files (x86)\Mass Effect and start the Game directly via the .exe . (So try to skip the utility)

_________________
Bonsoir, friend.


~ Nobody's gril. ~
avatar
Adwomin
free society
free society

Windows version :
  • Windows 8
  • Windows 7

System architecture :
  • 32 bits (x86)
  • 64 bits (x64)

Favourite games : GTA Series, Cities: Skylines, Prison Architect, Borderlands series
Female Posts : 19211
Points : 1026352
Reputation : 2242
Join date : 2010-03-12
Age : 15
Location : Del Perro Heights

View user profile https://www.games4theworld.org

Back to top Go down

Re: Mass Effect 1 problem. [SOLVED]

Post by AGPPyroman on Mon 13 Dec 2010, 15:48

The .exe that I found still opened up the launcher unless you know of a different .exe that's in one of the sub-folders rather than the main one.

Though I read the read-me for the game and it said that the game didn't run "optimally" on Sapphire Radeon x1550 GPUs. And I have a Sapphire Radeon HD 5770 so I'm wondering whether they're related enough that they have similar problems. Because it seems that the config utility errors when it's detecting my hardware.

But just in case it is a hardware case I'll leave your my loadout in case you know something about the hardware issues with the game that the read-me doesn't specify.

Windows 7 home premium 64-bit
Core i7 860 (2.8GHz)
8GB DDR3
1.5TB HDD
Saphire Radeon HD 5770

AGPPyroman
Beginner
Beginner

Posts : 6
Points : 2458
Reputation : 0
Join date : 2010-12-10

View user profile

Back to top Go down

Re: Mass Effect 1 problem. [SOLVED]

Post by Adwomin on Mon 13 Dec 2010, 18:27

Hello,

Please see if http://cyri.systemrequirementslab.com/cyri/ shows something "wrong".

_________________
Bonsoir, friend.


~ Nobody's gril. ~
avatar
Adwomin
free society
free society

Windows version :
  • Windows 8
  • Windows 7

System architecture :
  • 32 bits (x86)
  • 64 bits (x64)

Favourite games : GTA Series, Cities: Skylines, Prison Architect, Borderlands series
Female Posts : 19211
Points : 1026352
Reputation : 2242
Join date : 2010-03-12
Age : 15
Location : Del Perro Heights

View user profile https://www.games4theworld.org

Back to top Go down

Re: Mass Effect 1 problem. [SOLVED]

Post by AGPPyroman on Mon 13 Dec 2010, 21:23

Nothing wrong, passed the test. Though it did stall on the "installing components" stage but after I refreshed the page it worked like it always does.


//EDIT

I got it working now.

I changed my GPU to my spare (and it didn't work). Then I changed back to my good one (still didn't work) Upgraded my PSU (this was pre-planned I wouldn't spend $100 on a PSU, that probably wouldn't fis it, for a game I can buy for $20) and deleted everything Mass Effect related and re-downloaded and re-installed it (still didn't work). But this time I didn't put in the map fix and it seemed to work if I run it straight from the .exe.

AGPPyroman
Beginner
Beginner

Posts : 6
Points : 2458
Reputation : 0
Join date : 2010-12-10

View user profile

Back to top Go down

Re: Mass Effect 1 problem. [SOLVED]

Post by Adwomin on Tue 14 Dec 2010, 17:06

Hello,

Well, that's good news. The utility still doesn't work?

Have fun playing!

_________________
Bonsoir, friend.


~ Nobody's gril. ~
avatar
Adwomin
free society
free society

Windows version :
  • Windows 8
  • Windows 7

System architecture :
  • 32 bits (x86)
  • 64 bits (x64)

Favourite games : GTA Series, Cities: Skylines, Prison Architect, Borderlands series
Female Posts : 19211
Points : 1026352
Reputation : 2242
Join date : 2010-03-12
Age : 15
Location : Del Perro Heights

View user profile https://www.games4theworld.org

Back to top Go down

Re: Mass Effect 1 problem. [SOLVED]

Post by AGPPyroman on Tue 14 Dec 2010, 19:00

Yeah, the utility doesn't work. I was a little worried because several games you can only adjust visual settings from the utility so I was worried that I'd be playing in 1024 X 768 rather than 1920 X 1080 but you can change settings in game.

Thanks for all the help,

Regards, AGPPyroman

AGPPyroman
Beginner
Beginner

Posts : 6
Points : 2458
Reputation : 0
Join date : 2010-12-10

View user profile

Back to top Go down

Re: Mass Effect 1 problem. [SOLVED]

Post by Adwomin on Tue 14 Dec 2010, 19:14

Hello,

Ok, good. Problem solved then. Have fun playing!

_________________
Bonsoir, friend.


~ Nobody's gril. ~
avatar
Adwomin
free society
free society

Windows version :
  • Windows 8
  • Windows 7

System architecture :
  • 32 bits (x86)
  • 64 bits (x64)

Favourite games : GTA Series, Cities: Skylines, Prison Architect, Borderlands series
Female Posts : 19211
Points : 1026352
Reputation : 2242
Join date : 2010-03-12
Age : 15
Location : Del Perro Heights

View user profile https://www.games4theworld.org

Back to top Go down

View previous topic View next topic Back to top


Permissions in this forum:
You cannot reply to topics in this forum